ZWave binding updates

Tags: #<Tag:0x00007f4332d1c690>

I included new zwave thing: AEOTEC button quad mode, while having 2.4.0 zwave binding, which does not have this device in DB.

Having notice that, I manually updated zwave binding to the 2.5.0.

Upon whole openhab restart, this device is still marked as unrecognized (I have verified that I’m running now zwave 2.5.0, also other zwave devices are working). I did (from paper ui) on thing: ‘reinitialize device’.

What are options EXCEPT for exclude/include, for binding to recognize this thing? What can I do?

A new device type and id (0002:0003) was added 3 weeks ago, so make sure you have a very recent zwave binding if you have this id combination.
Also make sure you delete the Thing and readd it.

2 Likes

Thank you for fast reply @sihui.

I checked and you’re right, I had binding 2.5.0.201901201452.
That was strange as I downloaded it yesterday from http://www.cd-jackson.com/downloads/openhab2/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

Anyway I downloaded it now from https://ci.openhab.org/job/openHAB2-Bundles/lastSuccessfulBuild/artifact/bindings/org.openhab.binding.zwave/target/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar, I verified that bundle:list shows now version: 2.5.0.201912080410

(BTW for this binding build, I needed to add xstream.jar to my addons from http://central.maven.org/maven2/org/apache/servicemix/bundles/org.apache.servicemix.bundles.xstream/1.4.7_1/org.apache.servicemix.bundles.xstream-1.4.7_1.jar )

Unfortunately it still does not work. It still unknown. (openhab.log: “2019-12-08 12:25:34.849 [WARN ] [ng.zwave.discovery.ZWaveDiscoveryService] - NODE 30: Device discovery could not resolve to a thingType! Manufacturer data not known.”

Does it mean that exclude/include is the only possiblity? Or maybe may thing is sth not in db?

I did, remove/add thing from paperui.

BTW, there is no xml file for this node in /var/lib/openhab2/zwave directory.

OK, situation is now ok - the thing works.

In addition to the above I did wakeup on the thing, by pressing button for 5 secs. Upon it the thing communicated with controller and was recognized, xml written etc.

In total 3 things were needed:

  1. jar downloaded from cd-jackson has old/wrong version (this is strange?)
  2. you must remove/add thing
  3. you must force thing to wakeup and communicate

BTW, the thing description in web DB does not have proper id (ZWA003). I submitted change to DB.

Thank you again @sihui!

Please use official snapshots only - not test versions that I may make available for unofficial testing.

This generally means that you need to wake up the device so that the binding can read the data.

Same thing - the binding will only write the XML file when it has downloaded data from the device, and it will only do this once discovery is complete. For battery devices, you need to wake them up.

No - it’s not strange. This is not the right place to download snapshots from unless explicitly told to do so.

1 Like

That has been true since Milestone 2, I believe. That is why I recommend using the install script to manually install the binding.It handles dependencies.

Yeah, I’ve analysed your script, but to my taste it’s too long/overeningered* with lot of old code/urls. Kind of clutter, but this is my subjective opinion, dont take it too serious :slight_smile: I appreciate your time you put into it.

BTW it did not work properly for first time run: I did not have time to analyse due to the size of it, and I’m using quite non-standard openhab deployment so maybe it was a factor.

In effect I wrote short one script for myself for update procedure, using some info from yours.

Hello!
I’m having strange problem with newer zwave binding (I guess it’s binding, and not the core problem). I was using #1460 nightly snapshot and everything was working fine. I’ve made a backup of the complete OH folder (I’m using OH on Windows 10 with latest java JRE installed) before I made an upgrade. I’ve tried upgrading to the latest nightly but both, controller and all the zwave things started going offline and online every minute or so. I’ve tried reverting to the backup, and it is working as expected. Than I’ve upgraded to milestone 6 (made an upgrade to backup of #1460), and zwave started going online and offline again. I’ve also tried removing all the things and recreating them, I even tried excluding and reincluding all zwave devices, and than recreating things, but it still behaved the same. Reverting to backup fixed it again. @chris, sorry to bother you, but you’re the only one that has insight in binding’s functionality. I’m using Aeon stick 2nd gen. Is it still supported with the latest versions of the binding? Also, strange error message (handle is invalid) that was showing back in January '17 and disappeared after some upgrade started to show up again (Strange error message in OH2 - Karaf console).
Any help would be highly appreciated.

Best regards,
Davor

Yes. Most sticks should be supported - some of the newer ones that may come out could have issues as ZWave revert to their closed system again :frowning: .

I don’t think there are any Aeon sticks that shouldn’t work with the binding.

Do you have any idea why is this happening, or do you know something I could try to make new binding work, and stop controller from going offline and online all the time? I don’t need new version of zwave binding, but I need new OH version for some other stuff that old version does not support. Thank you for your help.

Best regards,
Davor

Sorry - no, I’m not sure. It looks like a low level serial/USB issue rather than a binding issue.

1 Like

I hope you mean latest Java 8. Newer versions are not currently supported by openHAB.

1 Like

Hello!

Yes, that’s what I meant. Actual version is JRE 1.8.0 build 231.

Best regards,
Davor

That’s strange, because it works with older version of OH/binding. I’ll try to find if there’s an update for driver and/or stick firmware. Thank you for your help.

Best regards,
Davor

The newer binding is probably using a newer serial driver as it now uses the OH embedded serial driver.

Just to post my findings regarding this problem. I’ve updated both, Z-Stick S2 firmware (to v3.08, not sure what version it had before upgrade) and Z-Stick S2 Windows driver (to CP210x driver from June 2019; previous driver was from April 2018). After that, I’ve upgraded OH to latest snapshot, but Z-Wave devices (I guess controller is problem that causes other devices to misbehave too) are still changing state from online to offline and vice verse every minute or so. I’ve reverted to backup and I will leave it that way for some time, to see if some future OH update will solve this.

Best regards,
Davor

Not too likely. the code is frozen for 2.5.
2.5 Release Candidate 1 releases today and 2.5 stable releases on Sunday according to the current schedule.

Just to be clear Davor, you tried several recent snapshot and 2.5M6 and had this issue with controller going offline and online repeatedly then downgraded to 2.5M5 and it fixed the issue right?
Also you are on Windows platform which to me seems important for trying to run this down. Guessing but…

sounds like could be part of problem

1 Like

Hello!

Yes, I’ve tried 2 recent snapshots and M6 and they didn’t work. I haven’t reverted to M5, but the backup of snapshot #1460 I had installed before updates. I’m on Windows 10 platform (not sure what build, since I turned updates off - had many problems with them).

Best regards,
Davor

Some people have has issues with recent OH versions of they were using an old version of Zulu Java 8.

I would expect recent versions of Java 8 are tuned to work with the latest Windows 10 builds. If this were commercial software, their first response would be to update Windows & try again. Many updates fix bugs & flaws in the underlying OS. Those who do not update are, many times, left to solve their own issues.