ZWave binding updates

zwave
Tags: #<Tag:0x00007f0144031488>

(Andrej Rolih) #340

I’ve just noticed a weird issue with the new version of the binding and my Fibaro Roller Shutter 2. Mainly it’s current state doesn’t seem to always be refreshed correctly.

This is for instance an event log form when I set the shutter to 77%:

2018-12-28 22:50:39.040 [ome.event.ItemCommandEvent] - Item 'Zgoraj_AndrejSoba_Rolete_Output' received command 77

2018-12-28 22:50:39.049 [nt.ItemStatePredictedEvent] - Zgoraj_AndrejSoba_Rolete_Output predicted to become 77

2018-12-28 22:50:39.061 [vent.ItemStateChangedEvent] - Zgoraj_AndrejSoba_Rolete_Output changed from 71 to 77

2018-12-28 22:50:40.601 [vent.ItemStateChangedEvent] - Zgoraj_AndrejSoba_Rolete_Output changed from 77 to 71

The last event is wrong basically. My shutters moved to the correct position, but the state is wrongly reported. Similarly the current power wrongly reports something while it should be 0 (since the device is stopped).

This happens also when I move my shutters from 0% to 77% for instance. The state at the end is reported as 7% instead of 77% and the power is > 0.


(SiHui) #341

I cannot confirm that:

2018-12-29 08:45:01.247 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East_Pwr changed from 0 to 152.6
2018-12-29 08:45:14.532 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East_Pwr changed from 152.6 to 71.9
2018-12-29 08:45:16.338 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East_Pwr changed from 71.9 to 0


2018-12-29 08:45:00.319 [ome.event.ItemCommandEvent] - Item 'FibFGR222_Kitchen_East' received command 0
2018-12-29 08:45:00.386 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East changed from 85 to 0
2018-12-29 08:45:01.808 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East changed from 0 to 79
2018-12-29 08:45:16.317 [vent.ItemStateChangedEvent] - FibFGR222_Kitchen_East changed from 79 to 0

The log shows opening the blinds this morning from 85 to 0. Configuration is “Invert percentage”

Are you using the correct channels?

Rollershutter FibFGR222_Kitchen_East "Küche Ost [%d %%]"  { channel="zwave:device:uzb:node11:blinds_control" }
Number FibFGR222_Kitchen_East_Pwr "East Pwr [%.2f W]" { channel="zwave:device:uzb:node11:sensor_power" }
Number FibFGR222_Kitchen_East_kWh "East kWh [%.2f kWh]" { channel="zwave:device:uzb:node11:meter_kwh" }

(SiHui) #342

You need to email Chris with your username and ask for edit rights:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide


(Andrej Rolih) #343

That is weird. Yes, I am using the correct channels:

Rollershutter Zgoraj_AndrejSoba_Rolete_Output "Rolete"  (Zgoraj_AndrejSoba) {channel="zwave:device:ebf2caa1:node2:blinds_control"}
Number Zgoraj_AndrejSoba_Rolete_CurrentPower "Rolete - trenutna moč" (Zgoraj_AndrejSoba) {channel="zwave:device:ebf2caa1:node2:sensor_power"}

And I am using invert percentage as well.

This happened again this morning when I moved my blinds to 0% from 77%. The position is currently stuck at 71%. It will refresh correctly if I press any of the controls.


(Kris K) #344

Is anyone having issues with Habmin and a lack of zwave map? mine wont display at all, even after heal or reboots. Using 2.4 stable
Thanks!


(David Phillips) #345

Thanks Markus @mstormi,

I checked my devices’ lifeline associations and none of them was set to ‘controller’. I went through and set them all. I then retested, however I still do not receive data updates from these devices. See logs attached.

zwave.log (234.0 KB)

The data values only seem to update after an interaction with the device from the OH server. but they often ‘lag’ in value. For instance, a device turned on at the device (i.e. physical switch) does not register in OH as it used to.

regards,

Dave.


(David Phillips) #346

Hi Kris @dastrix80,

I have no problem with the zwave map in Habmin, also running 2.4 stable.

Regards,

Dave.


(SiHui) #347

Same here, although after a restart of openHAB it takes one nightly heal to display it.


(Chris Jackson) #348

If there is nothing received, then there’s probably not a lot of point in looking at the logs is there? Or is there something else you want to show?

My guess of what is happening is that due to the issues with the UIs, associations are getting changed. The associations are set when the binding starts - it will set an association to the Lifeline automatically if the device is a ZWave plus device, and it will set it automatically if the association is configured in the database. However, as the UI doesn’t present this properly, when the data for the device is edited and sent to the binding, the binding may then remove the associations.

I’ve created a PR last week to stop removal of associations that are either the lifeline, or configured in the database, and I hope that this will prevent this happening. I will try and get that tested today or tomorrow.


(Robert Angeli) #349

@chris

Hey, I am using the Aeotek ZWave stick on a raspberry pi 3. I am trying to test switches for building out a smart home we are currently building. I am using the GE12725 (Jasco) in-wall dimmer. I am having to wait ~ 10 minutes to receive an update on the status of the switch in the UI, so if someone turns off the switch manually, there is a great delay. When I turn it off from the Paper UI, it indicates off in the UI momentarily, then reverts back to on for ~ the 10 minutes. I cannot change the polling to faster than 10 minutes in the Paper UI… Please help!


(Chris Jackson) #350

The device doesn’t support associations, so there will be limitations to how well this works unfortunately. I would in future recommend getting devices that support such reports (not that that helps you now :frowning: ).

Strange - it should be configurable down to about 10 seconds (maybe 15) unless PaperUI has some sort of issue with numbers? I would not recommend this, but it’s up to you - it may swamp your network.


(Robert Angeli) #351

Wow. Thanks for the quick response! So I should be looking for switches that use associations? Can you recommend any in wall switches/dimmers that would work well? I have not purchased anything in mass yet, as I am laying out a test bed first. Sounds like I made the right choice…


(Chris Jackson) #352

Ideally, yes. This is the best way to get real-time reports. There are other mechanisms, but they are never going to be as quick/reliable.

I’m in the UK, so I’ll leave someone from the US to reply on this one…


(Mark) #353

I have had good results with the Leviton switches and dimmers. I have

  • 22 VRMX1 dimmers along with several “coordinating” devices for 3- and 4-way applications
  • 3 DZ15S switches
  • 7 various other Leviton switch/dimmer devices

(Robert Angeli) #354

I have just tested 1 more dimmer I had just purchased: "Zooz Z-Wave Plus S2 Wall Dimmer Switch ZEN27. It works perfectly. I never knew that behavior could vary so much being they are all z-wave protocol, but I guess it all depends on the command classes supported, etc.

Thanks guys. Very happy with these… I will probably buy these for the new house.


(Andrej Rolih) #355

I think I managed to solve my issue above (with the status not refreshing properly for my Roller shutter 2). I selected “reinitialize device” in the thing settings and now everything seems to be working correctly again.


(Chris Jackson) #356

I forgot to post on this thread yesterday, but I would strongly suggest people update to the latest snapshot as it has some fixes for associations to try and protect from invalid data formats coming in from the UIs. I found in a number of logs that either null data was coming in from the UI, or in some cases the data was just the wrong format (it looked like the UI, or ESH was converting the arrays into a string rather than a list). I’ve tried to detect these different formats and work around them.

It will also hopefully stop removal of associations that are required by the binding if you have “master controller” set to true (which most people should have). This should enforce the ZWave plus lifeline association group, and also any groups marked in the database as requiring to be set to the controller. This should again avoid mishaps in the UI that render the associations inoperable.

If there are still issues, then please provide logs of what is received from the UI. I’m not 100% sure that this will cover all possible formats that UIs may send as I made some educated guesswork from what I was seeing in various logs…


(Mr. Wiseman) #357

Good morning Chris,

Can you post URL to the latest JAR for zWave? I’m manually dropping the JAR into my Synology OH 2.3 build.

Thanks again for all your work! Your consistently helping everybody!

Best, Jay


(Chris Jackson) #358

Sure - it’s here.

Hmmm - I’d be pretty surprised if it worked with 2.3. I think that in OH 2.4 ESH made some breaking changes? Maybe this can be worked around…


(Mr. Wiseman) #359

I have your 2.4 v5 installed since 11/11/18 and it works great . . . I’ll let you know if 2.5 works on OH 2.3.

Best, Jay