ZWave binding updates

zwave
Tags: #<Tag:0x00007f51e4592990>

(Christoph Nagel) #584

@mhilbush, @sihui
Thank you, guys! :+1:


(Tz) #585

Hi To all,

I very new with Openhab, I have play with it for a couple of month now, after the update of z-wave binding to 2.4 all my vrcs2 switches are unknown to the db. The switches are detected as 001d:1102. Any hints?.
I also have other devices (less critical ) unknown to the db, but that could be for later.
I have some basic skills on linux (running openhab2 on linuxbox), frequently apt-get updated, but my skills in openhab are very limited, but I really want to give OH a try and someday be part of the community on a more usefull way, so please be patient with me :slight_smile: . Where do I get the z-wave debug error log?, which error log viewer is used?.

Cheers,
T


(HRE) #586

mhilbush - why does everything have to become personal? I am not attacking anyone, but I am saying that the people who wrote and created this update have done a great disservice to me and other by not COMPLETING the process, and giving me a means of implementing the patch without a bunch of research and effort on my part. YOU are taking that as an insult, and if so, then I would say you know you havent handled this situation well.

I write code as part of my job. I would be ashamed to push out a patch that comes with “hey, this will break your stuff, go here to try to figure out how to unbreak it after applying the patch.” Are you not similarly ashamed of creating work for me? I applied this patch, it broke my functioning, working system, and you are berating me for being upset. Sorry, Sir, you are wrong on this. The problem is not me, its an attitude on the part of whoever developed this patch that ist OK to break someone’s functioning system and leave them to pick up the pieces.

I use Openhab. I am a “customer” and you are a supplier. I am very angry and disappointed in how I have been treated. Berating me for being angry and disappointed only makes me like you and Openhab less.

You should go look at how letsencrypt is handling their recent changes. They are making every effort possible to make their recent changes work for users instead of throwing a patch into the apt-get process and letting the pieces fall where they may.

Suppliers should look in the mirror when customers get angry; rarely is it prudent to blame the customer.


(HRE) #587

Another satisfied customer of the recent patch. I have same problem. I am trying to figure out how to get my stuff working again.


(HRE) #588

All the items in my list of “things” appear with “UNINITIALIZED - HANDLER_CONFIGURATION_PENDING”. I have tried deleting the thing. It just disappears. Nothing appears under the inbox. So how do I reinitialize?

If this reinitialization is something that is scriptable, why wasn’t the patch put out with such a script to cause the reinitialization?


(Mark) #589

As I understand this statement (and my English is pretty good), you accused me of knowingly putting out an update that destroyed your functioning system. That statement is factually untrue, and is about as personal as it gets.

You’re kidding, right?

After you delete your things, you should run the discovery process. In HABmin, it’s the little search glass. Click the search glass and select ZWave Binding. After that, your inbox should be populated with ZWave things.

I believe @5iver wrote a script to help with the process. I haven’t used it, but others found it helpful for the migration.


(Markus Storm) #590

OpenHAB is not a commercial product, you don’t neither pay nor contribute anything.
@mhilbush is not a developer but someone who is voluntarily dedicating his spare time to help other people USE openHAB so it’s plain wrong claim that “his” patch destroyed anything.
And no matter how disappointed you might be and if your problem really was caused by @mhilbush, any other OH developer or just yourself, would you please respect the forum rules IMMEDIATELY and stop blaming anyone for whatever happened. I’m stating this as a forum moderator.


(HRE) #591

This post was flagged by the community and is temporarily hidden.


(Mark) #592

Nope


(HRE) #593

Well, that’s helpful.


(SiHui) #594

I’m pretty sure you won’t get any help on this forum anymore.


(HRE) #595

Why, because I am critical of a patch that I trusted, and got screwed?

You and the master mhilbush seem to be missing the point. Help me or tell me to eat shit, I dont care, the point is that openhab community KNOWINGLY put out a patch that breaks peoples systems. And you make no apologies for it. Great attitude, that. I am here complaining about that, and people are taking it personally because I am pointing out their precious baby is ugly. Wow, lets dont MAKE OPENHAB GREAT AGAIN, lets tell the guy who says it has a flaw that he is a buggar and shouldn’t be helped.

Does no one see the difference? Its not about me, its about the attitude that lets a patch go into the wild that wrecks stuff people have worked hard to build and that people depend on.

I think my next step is to uninstall openhab and shoot for a different solution. I am tired of this holier-than-thou attitude. This attitude is well characterized by the fact that this bug (which is the root of a lot of my issues) remains unsolved after nearly 4 years. Ugly baby, that.


(vossivossi) #596

Sorry, but you are miles away from seeing the reality.

First of all, mhilbush ist NOT the developer of the Z-Wave binding, so just stop to blame him for code he did not write.

Second, we do not talk about a “patch” but a totally new release which indeed included some breaking changes (like many major releases before and like many major releases from other software). So you should perhaps read the release notes before installing (where all these breaking chances were anounced).
Before this breaking change in the release the new Z_Wave binding version was tested for nearly 2 years by many community members (including myself) and only offered to the large public when it was really mature. And it is a VERY good implementation with many great feature by far better than the old one. All the breaking changes were also communicated here in the forum long time ago in detail.

Third: All you have to do is delete your Z-Wave things with a few clicks and let them rediscover with a few clicks and you are done.

I am also critical to some quality issues and long time unresolved issues in OpenHab, but the Z-Wave binding is a jewel. Try to get something similar - I bet you won’t.
Your only problem is that your old setup for releases < 2.3 was not compatible with the new release because you did not inform yourself. My advice is to do a one time deletion and rediscovery of things and enjoy the benefits.

Cheers :wink:


(Markus Storm) #597

No because you’re misunderstanding many things.
I say it again as you obviously didn’t care to read:
@mhilbush is no developer so he didn’t cause whatever is wrong in the code (if so at all) to have caused your issue.So you mustn’t blame him or anyone else on this forum - most people to answer here are NO developers.

And because unlike you claim you DID get personal (seems everybody except you noticed).

I don’t know what patch you refer to but it’s plain nonsense that anyone would ever knowingly put out a patch that breaks things without also giving proper guidance what you need to do so it does not break your system. And if it unintentionally breaks things it was a snapshot release and anyone to use those is responsible for being aware of the risk.
As it’s apparently the reworked zwave binding in 2.4 you refer to to bring the need to delete/recreate your zwave things then this was thoroughly communicated as @vossivossi told.
So you will either have read about in the release notes or it’s your own fault because you didn’t put the minimum amount of caution, care and work into your upgrade that is expected from any user, so blame noone but yourself for being so careless.


(Mark) #598

Great! Don’t let the door hit you on the way out.


(Ra) #599

@alabamatoy this should help :wink:


(Tz) #600

Thanks for your reply alabamatoy,

I can see a lot of frustration in your writing, but dont push me away from the solution with sarcasm nor put words in my writing that are not what I meant. I am a happy user of this very interesting project, I have not payed a cent, I am not a customer and I am not expecting to be. What I do want is to join the community and share experiences to build something better. I have seen things done with OH that I would love to get it done in my place, and I dont want a cloud based system so right now, OH seems to me a good place to start. I came from testing another project of linux based domotics and invested in a large amounts of z-wave items, I would love to get them all running again.
What have you try to get your stuff working again?, can you make a list?
That would help me a lot, maybe others too.

Cheers


(J Wee) #601

I am also one who is very grateful for all the kind people who have tried to help me.

@mhilbush, I have had to hard reset my z wave controller. started from scratch again. Again. I put in 2 battery type contact sensors, and a z wave wall plug . But I do not seem to be getting any kind of readings from the battery ones.
this is my log

https://drive.google.com/open?id=1JFXqQuG1K0rMst28CETJXe0wylEN6S81

Not sure what is going on.


(Mark) #602

All 3 of your nodes are being identified correctly. Node 3 is the NAS-WR01ZE plug, and nodes 2 & 4 are the NAS-DS01Z sensors, right?

Did you try waking up nodes 2 and 4 so that they can complete initialization?


(J Wee) #603

Yes whenever I try to refresh in habamin, the error of “polling deferred till initialisation complete” always comes up

I wake on the sensor itself. Nothing seems to happen.

so being included and being correctly identified does not equal initilisation complete?