Zwave bindings

Hello all
Maybe is trivial questiin but I canr solve this problem.
I installed and run OH2 . In addons directory I copy zwawe bindig but i cant see it in Paper UI>Configuration>Bindigs
When I run setup wizard from main menu I see astro , avm bindigs etc but no zwave
What I do wrong ?

The zwave binding is an OH1 binding, so will not show up in the OH2 bindings list.


Is there any plan to change the binding to work with OH2? I seem to see conflicting information about which bindings work with with version of OH.

I’ve been away from OH for some months and decided to look at it again but it still seems to be rather convoluted to set up.

I basically want to run OH (2 preferably), with Zwave, and with a great UI. I had used HABmin 1 but that wasn’t quite good enough for my purposes. With the new Paper UI I was hoping to easily add wave devices.

Is there any working set of OH, ZWave and UI that’s working sexily together?


The current OH1 binding works fine with OH2 now, however there is a plan to port it to OH2 as a native OH2 binding. This is mostly done.

Yes - that is the plan for OH2 and HABmin is being updated to work with this as well :smile:

Thanks Chris. Can’t wait!

One question, for now, if I’m using the new HABmin with OH2 and the ZWave
binding, how do I configure my zwave devices? Do I have to manually edit
the files for now?

Also, it seems HABMin 2 doesn’t work with Safari at all. In the old HABmin
it worked for the most part (Rule editor didn’t) but now all I ever get is
a “Loading” screen whereas on Chrome it’s all good it seems.


The current version of HABmin2 should allow you to configure zwave devices in a similar way to the HABmin1 version. To be honest, I’ve not used this for a while as I’ve been focusing on the OH2/HABmin2 version, so it might not be 100% :blush:

It seems to work fine here. I normally use Chrome or Firefox, but I just tried Safari and it seems fine (on my MacBook pro).

Again, the version that’s on Github at the moment is a bit old and I’m concentrating on the OH2 version. The error you have on Safari is hopefully fixed, and I’ll release a new HABmin when I release the test version of the OH2 zwave binding…

Thanks Chris.

OK maybe I’m not seeing where zwave config is. I see there are dashboards,
groups, things etc but when I go to add a thing I’m not seeing the ZWave
binding at all. In the terminal it all looks like zwave is running.

Just thinking about it though (I’m at work, not at home) I think I’m seeing
bindings for WeMo, Hue etc even though I can’t remember installing those.
Could I be running some silly demo config or version by default?


OK, so something must be up. I freshly installed OH2 with all addons,
Habmin 2 (org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.0.15), set wave device,
started OpenHab. All looks good but thing discovery shows no ZWave at all
even though it looks like it started OK. There’s lots of Wave NODE messages
and initialisation of the device didn’t error out.

Do I need a different version of OH, HabMin, extra files???


On Mon, 14 Sep 2015 at 09:10 Aaron Koolen-Bourke

Discovery is an OH2 concept, so it doesn’t work with OH1 bindings…

The zwave config area should be at the bottom of the CONFIGURATION menu- you should just need to install the HABmin 2 JAR file for this to work (along with zwave of course).

OK, thanks. So I now see the Wave item in the configuration menu and my devices are showing up for the most part, but I can’t seem to see where I can add that device as an item in OpenHAB.

Configuration->Thing Configuration->Add doesn’t show ZWave and therefore I can’t add ZWave things to it. Is there somewhere else I need to add things “things”


You need to follow the openHAB1 instructions for adding items - remember, this is an OH1 binding, so you can’t add items etc other than through the text files - the same as OH1.

Again, this is an OH1 binding - OH2 features like this will not work for OH1 bindings.