Zwave Blind control from Duwi not recognized

Thanks i delete the thing and add it back and now i have the blind control channel and it works !
i have just only one problem, when i fully open (or close) whith openhab and the blind control channel it never stopped ?

I try to configure in habmin the parameters 4 or 5 (full close or open time) but i can’t, i can only select : “keep in permanent motion”

Do you know why ? thanks again !

These parameters have the “All free entry” tick set - so you should just be able to type in a value (ie a number) directly into the box?

no i can just select the “keep in permanent motion”

Can you attach an image of how this is rendered please?

i cant type any number, just select

Ok - I’ll take a look - it’s definitely not rendering as I expect.

Thanks !

Hi, I have exactly the same issue with the rollershutter parameter 4 and 5 as mentioned by Johan_Thomas. I can’t set numeric values for open and close time. Is there something new? How I can handle it?

I think this problem was probably caused by the default setting of the <limitToOptions> parameter -:

This was changed at some point from true to false and it means that you now can’t type in values that aren’t in the database.

I’ll try and add a PR for this tonight (I actually thought this was closed, but it seems not).

Thanks Chris!

Is there a way to set additional custom options manually at the moment, for example in the nodeX.xml device file? Where are these options defined?

No - the configuration parameters are only defined in the thing XML files and handled within the ESH core so there’s no easy way around this.

I could do an update to the database exporter so that it adds the option into all the XML files so as not to make assumptions about the default. This would allow you to update to the snapshot version of Z-Wave to fix this rather than waiting for ESH updates to flow through the system…

@chris: I use openHABian on Raspi3 and I never updated single components myself. If you give me some advise how to use the snapshot version of z-wave, I will give it a try.

If you are on a snapshot release: just uninstall the binding, wait a minute, install it again and you have the most recent version.
If you are on the stable version: uninstall the zwave binding, download the newest binding and put it in your addons folder.

Ok, then I need the link to the modified version of the z-wave binding release, as mentioned by @chris

do you have the link ?$org.openhab.binding.zwave/

No I didn’t. I downloaded version 2.1.x from git, where the open and close time issue isn’t fixed. But overall it’s running very stabile with my config with round about 25 z-wave devices.

I have tried to uninstall the zwave binding then download this one but i get this error : (i am on the stable version)

2017-02-08 19:35:25.289 [ERROR] [org.openhab.binding.zwave           ] - FrameworkEvent ERROR - org.openhab.binding.zwave
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [207]
  Unresolved requirement: Import-Package:

        at org.eclipse.osgi.container.Module.start([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent([org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager$[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]