Zwave Button - how to prove it's working?

I’m using an Openhabian Pi, running OpenHAB 2.5.9, and a zwave dongle (which I’ve used very successfully with a Fibaro plug-in power switch). I’m mostly using the PaperUI, but also have looked in HABmin.

I’m now trying to use a SCN04 Four-key Scene Controller - I’ve added the “thing” easily enough, and added two “items”. The button has a channel for “scene number” and another for “battery level”, so I added an item for each.

My problem is that I can’t really “see” if the button is working. That is, pressing it makes the little LED light up, but I don’t see any particular reaction from OpenHAB - nothing in the UI and I don’t see any extra being written to the log either.

I notice that if I edit the Thing, I’m given a screen with some Association Groups. All of these are empty, but I believe should be set to “controller”. If I make those changes and save, the log says:

2020-09-24 17:43:29.628 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30fd47f1:node6' has been updated.
2020-09-24 17:43:29.636 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[ConfigStatusMessage [parameterName=wakeup_node, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null], ConfigStatusMessage [parameterName=wakeup_interval, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null]]]
2020-09-24 17:43:53.660 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:30fd47f1:node6' has been updated.

However, if I go back into the edit Thing screen, all my previous config is gone (in both UIs). This problem, coupled with the lack of log output makes me wonder if the config has really taken effect or not. I wondered if the device needs to wake up to then receive the config from the controller - but pressing a button on it for 3 seconds (or a single click, double click etc) doesn’t seem to do anything either.

Is there a way to check, or indeed to see every button press (even if mishandled later on)?

I have a different button with 4 possible outputs. I created items for scene number and battery level. and connected the channels appropriately. In order to use it, I watch for scene messages from those devices and have rules that trigger and some messages. If you’e not created items and connected them, I don’t think you’ll see anything.

Sorry if that’s obvious, but it’s all I can think of.


You have looked at the binding documentation, right? It tells you how to create debug logs to troubleshoot issues.

Is there an xml file creates in the zwave directory of userdata? It not, device discovery has not been completed.

Awesome! Thanks folks for the super-quick and helpful replies.

There was no file in the userdata/zwave directory - so even though things looked about right in the UI, the device wasn’t paired properly. The clue was the configuration that wouldn’t set.

To solve this, I found the removal of the device pretty painful. Following the manual didn’t seem to successfully remove it, but I was able to factory reset it and delete all the duffer devices in OpenHAB. Then I re-added the device (which would only join as a secure device). Once re-added, the file appeared and the config had “controller” set in the “central notification” section in the associations. My other observation was that the log file shows some Zwave start frames every time I press a button on the switch now - which of course it didn’t before.

Getting rules to work was its usual fun experience. However, I managed to get OpenHAB to turn on the Fibaro switch with the first button push and switch it off again with the second. The gist of the rules was the first is triggered when an item updates, but has a condition that says “only if the switch is off”. The second is the same, but with the condition of the switch being off.

Thanks again - really helpful and much appreciated!