ZWave Device Add request: FF-ZWAVE5-ECO Firefighter audio detector


I searched but only found one old thread from Jan '19 that mentions getting this device added to the database, however there was no follow-up with the XML file to allow it to be added. Starting a new thread just for this. Attached is the XML file I have from adding this unrecognized device to my network. Let me know if there is any other information I need to provide in order to get this added.

FF-ZWAVE5-ECO.xml (13.4 KB)

Here’s the database guide if you want to try.

A pdf of the user manual is usually useful too.

Thanks, but I don’t see a “Tools” button on the top-right of the Device List page when attempting to follow the instructions:
" Go to the Device List and click on the tools button in the top right of the page…"

I assume I need a login to do this?

Sorry, yes. I thought that was mentioned in the guide.

Sorry, yes it does, I was impatient and jumped down to the section about adding a device, but getting a login is right there near the top of the doc.

1 Like

Did you get this working? I was able to add it in the ZWave network and configure the items such as Temperature, Battery, Smoke Alarm, etc in Openhab but i don’t receive any alerts or status of temp and battery.

I’m still running 2.5.3 and it doesn’t have the device in the ZWave database. I was holding off updating since I saw some reported issues updating to 2.5.4. I see 2.5.5 is available so I’ll have to make some time to do the update. Assuming the ZWave database has been updated to include this device, I’ll report back when I’ve tested (hopefully Friday).

I updated to 2.5.5 and the device is recognized now. However, only some of the channels seem to work. So far I’ve only gotten a battery level report and a temperature (Celcius) report. When I remove the cover I’m not seeing a change in the alarm_burglar channel like I’d expect. In addition, testing my smoke detector does not trigger the alarm_smoke, alarm_co, sensor_binary, or sensor_general channels. I also haven’t seen anything from the meter_watts channel. I do however see the red LED pulsing when I test my smoke alarm, so it does appear that it detects the sound. I’ll have to try collecting some ZWave debug logs and get some help looking at that.

1 Like

So I excluded and re-included the device to see if things behaved differently. It is now included as node 152 but I don’t see any improvement in behavior, still only temperature and battery level is reported.

During the include process I captured the zwave debug logs. Note that it didn’t complete the include process on its own, and with just pressing the tamper button a couple of times it didn’t help, so eventually I held the include/exclude button for 1 second and then it progressed, but it was more than a minute later in the log when that happened. Once it was included and I had updated my items to reference the new node ID, i attempted to get a change in burglar_alarm by pressing the cover button, but I didn’t see any update in the item state.

I’m hoping someone can look at this debug log in the ZWave log viewer and make sense of it. I looked at it in the log viewer but I’ve got more to learn before I can draw any useful conclusions.

ff_zwave_node152_include.log (883.2 KB)

It looks like everything is working ok, but the tamper alarm, which is the only alarm in the log is not handled at the moment. I’ve now added this to the database and it will be in the next update.

1 Like

Thank you Chris! I’ll try to look at the DB entry and understand what needed to be changed to get this working. I also captured a zwave debug log when it was triggered by the smoke alarm, this isn’t handled properly either. I don’t have a way to trigger the CO alarm at the moment so I can’t capture a zwave debug log for that. However, is it possible to setup the smoke and CO alarms to correct them both in the DB based on what is seen in the attached log for the smoke alarm?
ff_zwave_node152_smoke_alarm_test.log (156 KB)

The change needed to happen in the binding, not the database entry, from my understanding.

Interestingly enough, I posted above after capturing the log and assumed like before the smoke alarm trigger didn’t make it to the item. However, I had already coded the rule to send a notification if the smoke alarm triggered. In this case I did get a notification twice (and I tested my smoke alarm twice), so it worked today and it didn’t yesterday. Not sure what to make of that.

What is wrong with it?

From the log, it seems it works fine -:

This shows the smoke alarm messages being received, and the state is being updated accordingly.

1 Like

I agree, you are correct. I didn’t notice it worked since it transitioned from OFF to ON to OFF while I was holding my finger on the test button. However my rule to catch it did fire and I got the notification 10 minutes later.

1 Like