ZWave, Fibaro Dimmer2, Scene Activation, "Channel unlinked, polling stopped"

Yesterday I installed openHAB fresh (2.5.0M1 before, 2.4.0 now). Before the reinstall my openHAB was able to get the SCENE_ACTIVATION triggers from my Fibaro Dimmer 2 (triple click).

Now after reinstall (with older ZWave binding as well, as I downgraded openHAB to 2.4), somehow that doesn’t work anymore. When triple clicking the button, I get the following log entries:

2019-10-14 18:40:16.991 [TRACE] [WaveSerialHandler$ZWaveReceiveThread] - Received SOF
2019-10-14 18:40:17.004 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 20 00 49 84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B AC
2019-10-14 18:40:17.014 [TRACE] [wave.internal.protocol.SerialMessage] - NODE 255: Creating new SerialMessage from buffer = 01 20 00 49 84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B AC
2019-10-14 18:40:17.017 [TRACE] [wave.internal.protocol.SerialMessage] - Calculated checksum = -84
2019-10-14 18:40:17.020 [TRACE] [wave.internal.protocol.SerialMessage] - NODE 255: Checksum matched
2019-10-14 18:40:17.028 [TRACE] [wave.internal.protocol.SerialMessage] - NODE 5: Message payload = 84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 18:40:17.031 [TRACE] [WaveSerialHandler$ZWaveReceiveThread] - Message is valid, sending ACK
2019-10-14 18:40:17.034 [TRACE] [WaveSerialHandler$ZWaveReceiveThread] - Response SENT 6
2019-10-14 18:40:17.043 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 18:40:17.051 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 18:40:17.056 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-10-14 18:40:17.058 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 0
2019-10-14 18:40:17.061 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Last transaction: null
2019-10-14 18:40:17.071 [DEBUG] [ve.internal.protocol.ZWaveController] - Incoming Message: Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 18:40:17.074 [TRACE] [ve.internal.protocol.ZWaveController] - Incoming Message type = REQUEST
2019-10-14 18:40:17.077 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 5: Application update request. Node information received. Transaction null
2019-10-14 18:40:17.081 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 5: resetResendCount initComplete=true isDead=false
2019-10-14 18:40:17.083 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 5: Application update - no transaction.
2019-10-14 18:40:17.087 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2019-10-14 18:40:17.090 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
2019-10-14 18:40:17.093 [TRACE] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage nothing
2019-10-14 18:40:17.338 [TRACE] [ng.zwave.internal.protocol.ZWaveNode] - NODE 5: Node is listening - ignore wakeup

I do have a linked item to the scene_number channel (I can see it in HABmin), but the message itself doesn’t contain any “scene”, so I guess my item can’t really receive anything? What could be causing this problem? Do I have to use a newer ZWave binding version for it to work?

Thank you in advance!

You downgraded and the Zwave binding with it.
You will need to update the Zwave binding
There is a script for that:

Yea, but does SCENE_ACTIVATION work only in ZWave binding >2.4? I thought that should work with version 2.4 as well (at least I haven’t found anything that says otherwise).

Do I have to use a snapshot version of the ZWave binding for the functionality to work (and if so, where does it say so)?

The channel is still in the database:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/133

Your log is much too short and please don’t use TRACE, just DEBUG:

Make sure you have scene numbers enabled (parameter 28):

https://manuals.fibaro.com/dimmer-2/

I did not change parameter 28, it’s still 1 (activated). I actually tried changing it to 0 and then back to 1, but that didn’t change anything.

Sorry about the length of the log, but that’s all I’m getting when triple clicking. I changed to DEBUG instead of TRACE and this is the output:

2019-10-14 19:59:23.557 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 20 00 49 84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B AC
2019-10-14 19:59:23.567 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 19:59:23.572 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 19:59:23.575 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-10-14 19:59:23.578 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 0
2019-10-14 19:59:23.580 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Last transaction: null
2019-10-14 19:59:23.585 [DEBUG] [ve.internal.protocol.ZWaveController] - Incoming Message: Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-14 19:59:23.587 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 5: Application update request. Node information received. Transaction null
2019-10-14 19:59:23.590 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 5: resetResendCount initComplete=true isDead=false
2019-10-14 19:59:23.591 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 5: Application update - no transaction.
2019-10-14 19:59:23.595 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2019-10-14 19:59:23.596 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

Everything else seems to be working fine. I have two Fibaro Rollershutters and two more Dimmer 2. Controlling lights and the shutters work fine, just that scene activation somehow stopped working.

For all of them?

Also the zwave github repo shows the correct channels:

<channel id="scene_number" typeId="scene_number">
        <label>Scene Number</label>
        <properties>
          <property name="binding:*:DecimalType">COMMAND_CLASS_SCENE_ACTIVATION</property>
        </properties>

I have no idea what is going on …

Sorry, for all of what? I have two Fibaro Dimmer 2 in total. Just wanted to point out that all my ZWave devices seem to be working, except for SCENE_ACTIVATION in the one Dimmer 2 (have not set that up in the other Dimmer 2).

I recommend to do that for testing.

Downgrading your configuration is explicitly no supported if you used your old configuration backup or files…

I did not use my backup with the restore method. I actually set up all things by discovery or “by hand” and then used my old items / rules files to set everything up. Why would that cause a problem?

1 Like

I tried it with my second Fibaro Dimmer 2, and it looks like it’s not working with that one either. When triple pressing the button, I get:

2019-10-19 09:16:19.387 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 20 00 49 84 06 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B AF
2019-10-19 09:16:19.407 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationUpdate[73], type=Request[0], dest=6, callback=132, payload=84 06 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-19 09:16:19.415 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationUpdate[73], type=Request[0], dest=6, callback=132, payload=84 06 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-19 09:16:19.418 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-10-19 09:16:19.420 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 0
2019-10-19 09:16:19.423 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Last transaction: null
2019-10-19 09:16:19.430 [DEBUG] [ve.internal.protocol.ZWaveController] - Incoming Message: Message: class=ApplicationUpdate[73], type=Request[0], dest=6, callback=132, payload=84 06 1A 04 11 01 5E 20 86 72 26 5A 59 85 73 98 7A 56 70 31 32 8E 60 75 71 27 22 EF 2B
2019-10-19 09:16:19.434 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 6: Application update request. Node information received. Transaction null
2019-10-19 09:16:19.437 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 6: resetResendCount initComplete=true isDead=false
2019-10-19 09:16:19.443 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 6: Application update - no transaction.
2019-10-19 09:16:19.446 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2019-10-19 09:16:19.449 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

Somehow it worked with ZWave 2.5, but not with 2.4. What can I do?

Do the 2.5 versions of the binding work with openHAB 2.4?

I will check with my FGD this evening …

Is the current development version of the ZWave binding backward compatible, so can I install it on openHAB 2.4?

Quick update: I installed the latest ZWave 2.5.0 snapshot version, and it’s still not working. Really I have no clue why. It worked with openHAB 2.5.0 M1 with ZWave 2.5. I did not change anything to the devices configuration. :frowning:

How did you install it? There is a manual install script for updating that also checks & adds new dependencies. More than just the zwave addon is needed.

Hm, I installed it by just putting the newest snapshot jar in the addons folder. I had to install a couple of dependencies myself (org.apache.servicemix.bundles.xstream and another one which I don’t remember, and then the installation of the snapshot version worked without problems. My devices seem to be working fine, just triple press / scene activation still doesn’t.

The manual steps are in the README here.

Okay, I checked this out today:

Triple clicking is only available on S2, as I only have S1 connected I can’t test, sorry.

Make sure you have Group 3 set to your controller and scenes are activated.