Zwave : GE/Jasco Door Hinge Sensor errors

Tags: #<Tag:0x00007f5c955b1b68>
  • Platform information:
    • PI3
    • Openhabian
    • Latest Updates

Item: https://www.openhab.org/addons/bindings/zwave/thing.html?manufacturer=ge&file=smartdoorsensor_0_0.html

Hardly ever do i go out and buy multiple sensors before testing atleast one. I order 5 of these sensors, they were 25 on amazon. 2 have arrived. First one is getting all kinds of errors and no data sent back. Second one manufacturer can’t be recognized.

I have no clue where to start with this. I’ve tried, excluding it, re-adding, multiple updates and reboots. Any suggestions?

Hinge Debug Log.txt (9.2 KB)

That looks to be a filtered trace log with little useful information. Debug level unfiltered logs are needed for debugging.

Yeah I have it filtered for that node, I’ll remove the filter and see if I can capture it.

The developer has said trace level is not useful. Please use debug.

I have debug turned on for zwave, is there anything else i should change?

I woke up this morning to half my zwave items being offline, and front door (this sensor) was also offline but in habmin it was waiting to initialize. Rebooted openhab and it looks like the item fully installed but still not getting a reading. Actually seen node dead for node 25 at one point. Attached is a new log unfiltered.Hinge Debug Log.txt (124.7 KB)

Now it says in habmin “Node Initializing MANUFACTURER”

Status: ONLINE Node initialising: APP_VERSION

dbReference	504
defaultAssociations	1
manufacturerId	0063
manufacturerRef	4953:3032
modelId	32563
vendor	Jasco Products
zwave_beaming	true
zwave_class_basic	BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic	GENERIC_TYPE_SENSOR_NOTIFICATION
zwave_class_specific	SPECIFIC_TYPE_NOTIFICATION_SENSOR
zwave_deviceid	12338
zwave_devicetype	18771
zwave_frequent	false
zwave_lastwakeup	2020-05-19T15:16:22Z
zwave_listening	false
zwave_manufacturer	99
zwave_neighbours	
zwave_nodeid	25
zwave_routing	true
zwave_secure	false
zwave_version	0.0

Hey look at that, started working.

working.txt (76.6 KB)

I can see the switch go from 0 to 255 and I can see item go on and off, but I can’t see it in paper under the thing or on sitemap other then a lightbulb icon goes on/off

The zwave log viewer might make it easier to see what is happening.

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Yes I’ve been using the log viewer, nothing stands out. I got it fully working however its item status is blank in paper. I added the second one and this time its was able to identify it however same issues as the first. This is going to be painful as I have three more to add as well.