Zwave - GE-ZW3010

Has anyone had luck adding a GE ZW3010 dimmer to openhab.

I’m running 2.5 on a RasPi, with a Aeotec’s Z-Stick .

And all I get is, unknown device? I’ve tried twice with the same result.

See screen shot from Habmin attributes:


Thanks for any help?

It is defined in our database but it looks to me many of the configuration parameters are missing. The entry is here.

I will try to add the missing parameters. We then need to wait for the weekly database export and then a snapshot build of the Z-Wave binding.

EDIT: I was able to add more configuration parameters and some options to existing ones.

I just added one of these (ZW3010) and openHab shows it as an “Unknown Device”. Is there something i need to do to get the updated database?

You are running Unknown OH version. The answer is therefore unknown.

Sorry, Bruce.

Platform information:

  • Hardware: Intel Atom x5, 4gb
  • OS: Windows 10
  • Java Runtime Environment: (Zulu (build 1.8.0_222-b10)
  • openHAB version: 2.4.0

You need to update to openHAB 2.5.2. Be sure to read the Release Notes first.
If you have restdocs installed, uninstall first & reinstall. Its location moved.

1 Like


Also be careful. 2.5.2 added a whitelist for the exec binding due to security concerns. Check the announcement here.

Thanks for the heads up on the Exec binding: I followed the instructions in the binding documentation, but I’m still getting an error.

2020-03-07 14:33:34.234 [WARN ] [ng.exec.internal.handler.ExecHandler] - Tried to execute 'c:\apcupsd\bin\apcaccess -u', but it is not contained in whitelist.

My file exec.whitelist looks like this:

c:\apcupsd\bin\apcaccess -u

Perhaps I misunderstood what was meant by this:

Allowed commands need to be added to the misc/exec.whitelist file in the configuration directory

I placed the file at C:\openHAB2\conf\misc\exec.whitelist

Thanks again for the your quick replies!

I do not use the exec binding but I know there is plenty of advice here. Perhaps search for whitelist.

1 Like