Zwave: How to migrate to a new controller when the old one doesn't work

I had a bit of a frustrating weekend and feared that I was going to be out a significant amount of money.

The problem was up to this point I’ve been running my home automation on an old Aeotech Gen 2 controller which does not support backing up and restoring. I recently purchased a HUSBZ-1 because it also has a Zigbee controller on the same dongle. I don’t have a use for Zigbee yet, but it is nice to know it is an option.

So based on some threads here and elsewhere the recommended approach is to exclude the device using the old controller, then include the device on the new controller.

But, for some reason my Gen 2 controller would not successfully perform the exclude. I wasn’t getting much feedback from the zwave logs (I honestly didn’t look that closely) but when I tried to use ozwcp it would just exit with an error when I tried to run an exclude.

Start the panic.

After a nights sleep I did some more searching and I discovered an old posting buried deep in the old Google Groups forum for ozwcp that you can exclude a device using ANY controller. The device doesn’t have to be joined to the controller performing the exclude.

So I plugged in the new one and:

  • ran an exclude through Habmin
  • watched the zwave logs to verify that exclude mode has started
  • press the button (or what is required device) on the device
  • wait for the zwave log to show that exclude mode as ended
  • the perform the include through Habmin

Worked perfectly.

Hopefully this will help someone in the future.


I wish I saw this a few days ago :slight_smile:
I just had all my zwave devices hard-reset to be able to include them again with a fresh controller…
But thanks for the tip - I’ll remember this for next time

I was wondering if you got zigbee and z-wave running on the HUSBZ ?

Zwave runs great. I don’t have any zigbee devices yet to test with. The coordinator shows online and there are no errors in the logs. Beyond that I’ve seen some report that the zigbee on this stick is pretty poor.

Hi Rich
Thanks for quick reply…the stick is not so cheap (around 90EUR in europe)…are you running it on a Raspberry (there were issues with more than one stick on raspberries) or other hardware ?

I run OH in a Docker container on Ubuntu 18.04 server on a VM on ESXi.