Zwave Items not binding OH1.8.2 please help

Version OH 1.8.2, Habmin 1.7.2 (snapshot), zwavebinding 1.8.2, /opt installation, modified with \ so port is recognized

I’m trying to get a dimmer (aeotech micro dimmer), a wall plug (fibaro FGWPx) and a thermostat (danfoss living connect z) to work in a zwave network on openhab using a razberry. Log messages, Itemconfig and sitemap at end of post.

I’ve been messing around with this for a few days. I was able to switch the dimmer on and off once and then never again. I keep getting messages about the items not bound to events (when the zwave devices sent updates to the bus) and items not existing in registry when I sent a command from the web interface of openhab.
I included the devices using habmin. Whenever I open habmin only some of the items I created in the test.items folder under /opt/openhab/items appear.

I tried using the two snapshots of the zwave binding and habmin binding. And now I’m using the zwave binding from the addons bundle and the same snapshot 1.7.2 habmin binding.

I’ve been scouring the forums for answers, but haven’t found anything helpful yet. I hope this is the right place to post this. Can anybody help?

Messages from the openhab log:

12:07:02.729 [DEBUG] [ ] - REST API has been started.
12:07:03.007 [INFO ] [org.atmosphere.util.IOUtils :370 ] - META-INF/services/org.atmosphere.cpr.AtmosphereFramework not found in class loader
12:07:03.158 [INFO ] [sphere.cpr.AtmosphereFramework:2601 ] - Atmosphere is using org.atmosphere.cpr.DefaultAnnotationProcessor for processing annotation
12:07:05.049 [INFO ] [cpr.DefaultAnnotationProcessor:138 ] - AnnotationProcessor class org.atmosphere.cpr.DefaultAnnotationProcessor$BytecodeBasedAnnotationProcessor being used
12:07:05.206 [WARN ] [cpr.DefaultAnnotationProcessor:178 ] - Unable to detect annotations. Application may fail to deploy.

12:07:20.863 [DEBUG] [.zwave.internal.ZWaveActivator:36 ] - Z-Wave binding started. Version 1.8.2
12:07:21.015 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ] - ConverterHandler not initialised. Polling disabled.
12:07:21.022 [INFO ] [.z.internal.ZWaveActiveBinding:325 ] - Update config, port = /dev/ttyAMA0
12:07:21.024 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ] - Initialising zwave binding
12:07:21.030 [INFO ] [.service.AbstractActiveService:169 ] - ZWave Refresh Service has been started
12:07:21.120 [INFO ] [b.z.i.protocol.ZWaveController:148 ] - Starting Z-Wave controller
12:07:21.122 [INFO ] [b.z.i.protocol.ZWaveController:156 ] - Z-Wave timeout is set to 5000ms. Soft reset is false.
12:07:21.124 [INFO ] [b.z.i.protocol.ZWaveController:322 ] - Connecting to serial port /dev/ttyAMA0
12:07:21.235 [DEBUG] [eController$ZWaveReceiveThread:1413 ] - Starting Z-Wave thread: Receive
12:07:21.243 [DEBUG] [WaveController$ZWaveSendThread:1197 ] - Starting Z-Wave thread: Send
12:07:21.246 [INFO ] [b.z.i.protocol.ZWaveController:342 ] - Serial port is initialized
12:07:21.247 [DEBUG] [b.z.i.protocol.ZWaveController:1154 ] - Starting Z-Wave thread: Input
12:07:24.253 [DEBUG] [veController$WatchDogTimerTask:178 ] - Initialising network

…(Nodes talking to razberry getting everything setup I guess)

12:07:33.419 [DEBUG] [ZWaveConfigurationCommandClass:121 ] - NODE 6: Node configuration report, parameter = 101, value = 0
12:07:33.420 [DEBUG] [b.z.i.protocol.ZWaveController:635 ] - Notifying event listeners: ZWaveConfigurationParameterEvent
12:07:33.421 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ] - ZwaveIncomingEvent
12:07:33.421 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 6: Got a value event from Z-Wave network, endpoint = 0, command class = CONFIGURATION, value = org.openhab.binding.zwave.internal.protocol.ConfigurationParameter@8ce97d
12:07:33.422 [WARN ] [.z.internal.ZWaveActiveBinding:467 ] - NODE 6: No item bound for event, endpoint = 0, command class = CONFIGURATION, value = org.openhab.binding.zwave.internal.protocol.ConfigurationParameter@8ce97d, ignoring.

12:07:41.593 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ] - ZwaveIncomingEvent
12:07:41.594 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ] - NODE 7: Got a value event from Z-Wave network, endpoint = 0, command class = METER, value = 12.3
12:07:41.595 [WARN ] [.z.internal.ZWaveActiveBinding:467 ] - NODE 7: No item bound for event, endpoint = 0, command class = METER, value = 12.3, ignoring.

12:32:33.018 [WARN ] [.w.internal.servlet.CmdServlet:100 ] - Received command ‘TOGGLE’ for item ‘ATDDimmer’, but the item does not exist in the registry
12:32:40.765 [INFO ] [c.internal.ModelRepositoryImpl:98 ] - Refreshing model 'test.items’
12:32:40.776 [DEBUG] [i.internal.GenericItemProvider:154 ] - Processing binding configs for items from model 'test.items’
12:32:40.778 [DEBUG] [i.internal.GenericItemProvider:133 ] - Read items from model 'test.items’
12:32:40.799 [ERROR] [.o.m.c.i.folder.FolderObserver:105 ] - An unexpected exception has occured
java.lang.NullPointerException: null
at org.openhab.core.internal.items.ItemRegistryImpl.isValidItemName( ~[na:na]
at org.openhab.core.internal.items.ItemRegistryImpl.initializeItem( ~[na:na]
at org.openhab.core.internal.items.ItemRegistryImpl.allItemsChanged( ~[na:na]
at org.openhab.model.item.internal.GenericItemProvider.modelChanged( ~[na:na]
at org.openhab.model.core.internal.ModelRepositoryImpl.notifyListeners( ~[na:na]
at org.openhab.model.core.internal.ModelRepositoryImpl.addOrRefreshModel( ~[na:na]
at org.openhab.model.core.internal.folder.FolderObserver.checkFolder( ~[na:na]
at ~[na:na]


Group Lights "Lights"
Group Dimmer

Dimmer ATDDimmer “Dimmer [%d %%]” (Dimmer, Lights) { zwave=“5:0:command=SWITCH_MULTILEVEL” }
Switch ATDSwitch “Lightswitch” (Dimmer, Lights) { zwave=“5:0:command=SWITCH_MULTILEVEL” }

Number ATDPower “Dimmer Power [%.2f W]” { zwave=“5:0:command=METER, meter_scale=E_W, refresh_interval=300” }
Number ATDEnergy “Dimmer Energy [%.2f KWh]” { zwave=“5:0:command=METER, meter_scale=E_KWh, refresh_interval=300” }

Group Plug

Switch FWPSwitch “Wall Plug Switch” (Plug, Lights) { zwave=“6:0:command=switch_binary”}

Number FWPPower “Wall Plug Power [%.1f W]” (Plug, Lights) { zwave=“6:0:command=sensor_multilevel, sensor_type=4”}
Number FWPEnergy “Wall Plug Energy [%.2f KWh]” (Plug) { zwave=“6:0:command=meter, meter_scale=E_KWh” }

Group Thermostat “Thermostat”

Number DTSetpoint (Thermostat) “Thermostat Setpoint [%.2f C]” { zwave=“7:0:command=THERMOSTAT_SETPOINT, setpoint_type=1, setpoint_scale=0” }
Number DTBattery “Thermostat battery [%d %%]” (Thermostat) { zwave=“7:0:command=BATTERY” }


sitemap default label=“Main Menu”
Frame label=“Aeotech Dimmer” {
Text item=ATDEnergy icon="none"
Text item=ATDPower icon="none"
Switch item=ATDSwitch
Switch item=ATDDimmer
Frame label=“Fibaro Wall Plug” {
Text item=FWPEnergy icon="none"
Text item=FWPPower icon="none"
Switch item=FWPSwitch icon=“none”

    Frame label="Danfoss Thermostat"{ 
        Setpoint item=DTSetpoint label="Set Temperature [%d °C]" minValue=10 maxValue=24 step=1 
        Text item=DTBattery icon="none" 


Group Dimmer

I don’t think that “Dimmer” is an allowed name for a group (or any item in this regard). Are you using the designer to edit your files? This should show an error in the designer if I am not wrong.

Thank you for the quick reply. :slight_smile:

That makes sense. I wasn’t using the designer. But now it works. There were three more syntax errors beyond that. They were items, where I put the group before the label

For anyone reading this thread with similar issues:
-Designer is here
-add the following to the *.ini file (Ubuntu)


-Delete Workspace folder
-It might need to be run as root, easiest way in ubuntu in my experience is

sudo nautilus

and then open the designer from there
-I copied the files from the pi to my computer, used the designer there and then copied them back when I was done
-I used dconf tools or unity tweak tool to expand nautilus in order to get to the system folders like /opt on the pi