Zwave Jar download location?

I had been grabbing the latest/udpdate JAR file from the link in the 1st post of the Zwave testing topic. But in looking today, it appears it may have been moved?

So in continuing to test,can someone point me towards the latest JAR file. Or should we now begin installing through the PaperUI?

Yes - the latest is available in the OH2 repository and can be installed through PaperUI.

I am also trying to get zwave working in my OH2 testbed - installed zwave from paper UI and then dropped in Habmin2 (org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.0.15.jar)

However, I am not seeing the zwave binding under bindings, neither am I able to see the devices in in habmin (/habmin/index.html#/binding/zwave). I can confirm that ozwcp is working fine.

(zwave) Log file: https://gist.github.com/petrklus/1a38caab88bf2c8f6a6f

It looks like you’re running the OH1 binding - this won’t show up in the bindings section, or list devices in the things area. I’d suggest using the OH2 binding…

Thanks Chris.

I’ll remove the ZWave from my Addons and install via the PaperUI.

Should we also remove the transport.serial file now as well from the addons?

Yes - Karaf should handle the dependancies for you so you should also be able to remove this…

It might pay to go to the console, and do a ‘list |grep ZWave’ command to make sure it’s really gone. Karaf can decide to keep multiple versions which doesn’t work too well :wink:

How can I do that?

What I’ve done:

  • install OH2
  • “export EXTRA_JAVA_OPTS=-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0” to get the port exposed
  • run OH2, install zwave via UI (I got 1.9 version)
  • configure zwave

I get:

openhab> list |grep ZWave
171 | Active   |  80 | 1.9.0.201602210212    | openHAB ZWave Binding

How can I get the v2 binding?

1 Like

In PaperUI, go to extensions, select bindings, and install the ZWave binding (selecting ZWave rather than ZWave1).

that’s exactly what I’ve done and what got me the 1.9. I am using OFFLINE distro though, which may the problem. Will try ONLINE.

I must admit that I don’t do this as I’m just using the addons folder due to doing a lot off development, but I gather others are using this ok (??).

Ok, the online distro lists two zwave extensions and I’ve installed the V2.

However, now the HABMIN2 does not start, also, I do not see any zwave messages in the log. Any hints?

openhab> list |grep ZWave
166 | Active    |  80 | 2.0.0.201602280202    | ZWave Binding

Use the version here for the OH2 binding -:

https://github.com/cdjackson/HABmin2/tree/theme/output

This will all be merged in the coming week so that the master contains the binding for OH2…

ok, progress - got the new HABMin to work, looks amazing!

However, it does not seem that I have any information about zwave in the log:display, even though it is listed as active:

166 | Active    |  80 | 2.0.0.201602280202    | ZWave Binding

I’ve added zwave into conf/services, is that correct location? Contents are:

# The Z-Wave controller port. Valid values are e.g. COM1 for Windows and /dev/ttyS0 or
# /dev/ttyUSB0 for Linux
port=/dev/ttyAMA0

# Z-Wave nightly heal time. This is the hour (eg 2AM) at which the automatic nightly
# network heal will be performed.
healtime=2

It might be worth having a read through the first post in the ZWave testing thread…

The important part is below…

Firstly, you need to manually add the controller - in HABmin or PaperUI, you need to go to the add thing option (in HABmin, this is the Configuration | Thing Configuration menu, and click on the + at the top). Select the “Z-Wave Serial Controller” thing. You need to go to the port settings and set the COM port address.

You should soon see a bunch of new things being found - click on the ADD button, and hopefully things will work ok! If the node name isn’t a real name (e.g. instead of device name it shows the Type and ID) then it means the device isn’t detected in the database and we need to work this out… It should still generate the XML files, so we need to feed them into the database4. If you’re unsure about what to do here, then please discuss it so we can get this right - once this gets sorted for a device, hopefully everyone else will be able to use the device very easily…

Once the things are generated, the channels and items should also be generated automatically. If this doesn’t work as you expect, then we likely need to sort this out in the database.

My apologies - did not see that thread! Will read before asking any further questions.

Got it working - in my test bed of raZberry + fibaro smoke sensor, I could see the smoke sensor as a “thing” in my inbox after triple-clicking the button to speed things up.

I am still unable see anything in the zwave log reader:
/habmin/index.html#/tools/zwave/logreader

Or to see the network and be able to add/remove devices:
/habmin/index.html#/binding/zwave

Is the above link still correct?

This isn’t a live log display - you need to manually load the log - there’s a button in the top right of the window.

In OH2, to add devices you go to the device discovery (In HABmin, it’s the little search icon on the top of the Thing Configuration screen. To remove devices, select the controller, and look in the tools menu on the right side of the window.

Got it - found both of the options!

I almost have a full picture now, only section I am not 100% sure about is the association groups - in my case, they seem to be simple textboxes, not dropdowns as they were in oh1

Is this expected behaviour / still work in progress?

They should be either multi-select dropdowns, or single select dropdowns depending on the number of nodes the group can be set to.

If you have problems, I would suggest trying a different browser - I use Chrome for development - I’ve seen some problems in Firefox and Safari that I need to look at when I get time…

That’s what I am trying - latest Chrome & using the Paper UI:

This is the markup of the field:

<input ng-init="focus=false" name="group_3" ng-model="configuration[parameter.name]" ng-required="parameter.required" type="text" ng-focus="focus=true" ng-blur="focus=false" class="ng-pristine ng-valid md-input ng-valid-minlength ng-valid-maxlength ng-valid-required ng-touched" id="input_2000" aria-invalid="false">

I do see dropdowns in HABMin though - is that the correct behaviour then?