ZWave: No Map and a Queue Full Message

Tags: #<Tag:0x00007f6170085f60>

I had my freshly-migrated OH2 run for the last couple of days. I expected the ZWave network heal to take place at 2AM, as per configuration showing both in HABmin and Paper UI, but that did not seem to happen: there is no entry in the logs and none of the nodes show that they have any neighbours. To be precise, I cannot see where I could even see the neighbours, HABmin does not list a section called “Neighbours” even. All I see is for each node is more or less this:

 Thing Type Label
 Thing Type Description
 Properties
 Configuration Parameters
 Association Groups
 Device Configuration
 Configuration
 Channels [3 active, 18 total]
 Attributes

Is there somewhere else in the UI where I can find neighbours? It is showing in OH1’s Habmin for me.

I also cannot see the ZWave network diagram, it is blank. Am I correct to assume that is because no heal took place?

I tried executing “Synchronize Network” (unsure what it does as it is not documented) but saw this message in the log:

2020-05-25 08:35:42.940 [WARN ] [age.RequestNetworkUpdateMessageClass] - RequestNetworkUpdate not placed on stack.

On another note, I have also noticed this Queue full error in the morning, and I could see that ZWave communication was not taking place, ie. a command sent to a ZWave device was not being actioned by the light, even though OH log shows that is has (both “predicted” and “changed” messages were in the log):

020-05-25 07:57:46.176 [WARN ] [WaveSerialHandler$ZWaveReceiveThread] - Exception during ZWave thread.  
java.lang.IllegalStateException: Queue full 
        at java.util.AbstractQueue.add(AbstractQueue.java:98) ~[?:1.8.0_252] 
        at java.util.concurrent.ArrayBlockingQueue.add(ArrayBlockingQueue.java:312) ~[?:1.8.0_252] 
        at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager.processReceiveMessage(ZWaveTransactionManager.java:435) ~[bundleFile:?] 
        at org.openhab.binding.zwave.internal.protocol.ZWaveController.incomingPacket(ZWaveController.java:1078) ~[bundleFile:?] 
        at org.openhab.binding.zwave.handler.ZWaveControllerHandler.incomingMessage(ZWaveControllerHandler.java:437) ~[bundleFile:?] 
        at org.openhab.binding.zwave.handler.ZWaveSerialHandler$ZWaveReceiveThread.run(ZWaveSerialHandler.java:409) [bundleFile:?] 

I had to restart OH to make things work again.

Any suggestions would be very welcome, many thanks.

Further info. I think the heal took place after all, even though it is not in the logs. I have just stumbled on the “Attributes” section of ZWave devices in HABmin, and I can see a listing of neighbours and the last heal time showing as 2:45am last night.

However, I still cannot see the ZWave network diagram. Is it broken?

Migrated from what version to what version?

For many upgrades it is recommended to delete (NOT exclude) & rediscover all Things except the controller to get the new binding settings. The Things come back with the same thing ids so Items do not break.

Have you tried following the binding documentation and collecting debug logs so the system can tell you what is happening?

I went from OH1.8.3 with the 1.9 ZWave binding to 2.5.5 with the rfc2217-compliant 2.5.5-SNAPSHOT of the ZWave binding and the 2.5.6 SNAPSHOT of the remainder, as that solved a Homekit issue. It was a new install, I have not moved any files over. I had to use the snapshot versions due to issues with rfc2217 ZWave binding support, which I have discussed extensively over the last few weeks in a few other threads here, and I have logged a couple of bugs on GitHub, including those affecting nrjavaserial (leading to a fix). Overall, there was a mixture of versions throughout this process, but in none of them could I ever see the ZWave network map. :confused:

I have discovered all Things, and I have manually recreated the .items files. Nothing got moved over, except the hardware, notably the preconfigured ZWave ZStick Aeotec Gen5. Resetting it and re-including all devices will be a royal pain if I have to do that.

Yes, and I have shared some issues with @chris using the debug logs as he has also suggested that bit of documentation—he is yet to comment on the last one (phantom devices). I am not sure I understand how the logs would help with the issue of the ZWave network map not working—please share if you have insight, many thanks for your help @Bruce_Osborne.

OH1 to OH2 is a massive upgrade. I think @rlkoshak has some tips on upgrading fro OH1 to OH2.

:tada: The ZWave network map has just appeared. Perhaps waiting patiently for 2+ days is what it needed. I suspect the reason was that while I could, at first, see the neighbours of the nodes, the controller itself did not show any neighbours. Those appeared after a full 3 network heals, and now I can see the map.

OP is basically starting over from scratch and not really migrating (yet). But everything I know about it is captured in https://www.openhab.org/docs/configuration/migration/#migration-from-openhab-1-x-to-openhab-2.

1 Like

Indeed. Thank you for that guide, it has been very useful. I am now well under way, need just a few more days to finish. I am already enjoying the massive increase in performance, mainly because my OH2 is running on a “proper” server (and on FreeNAS).

2 Likes