Zwave - no xml files


I did a search on the forum concerning my problem, but related posts seem to be to old, especially as I use the latest nightly build.

I had issues with my influx persistence and the mqtt persistence - the suddenly stopped to work after several minutes. As I couldn’t solve the problems (no errors in logs visible, also not in debug mode) I decided to do a fresh installation of openhab yesterday. I only restored the files in /config on purpose, because I wanted to get rid of any old userdate, which could have caused the problems before.

Everything is working except the Zwave Binding is not creating xml files and so the nodes in the inbox are not updating with the device infos.
The UZB Stick controller was added and seems to be working (otherwise detection would have failed).

As I am not at home I cannot post the exact version (or do I see it somewhere via myopenhab in PaperUI?), Zwave Binding just shows 2.4.0.SNAPSHOT. Around 50 nodes are in the Zwave network - different devices from different manufacturers.

I performed reboots, restarts of openhab and also the nightly heal did not help. Waking up nodes (does not matter if mains or battery powered) did not help too. I also let the system run for several hours (around 5) - nothing changed. Before I also tried to delete discovered items and rediscover them - no luck.

I attached a short log - please let me know if more info is needed. I guess it’s ok to point towards @chris aka Mr. Zwave.


zwave.log (34.0 KB)

The log doesn’t really show a lot - there are no transmissions at all, and I’m not sure what is going on (it’s also very short). It also seems to be filtered, and also the events log is included (possibly part of the filtering) which makes it hard to interpret. I’m not sure if the log has had the transmissions filtered out, or if there is no data being sent…

I would suggest to get an unfiltered log after a binding restart to see what is happening.

Dear chris,

hope this is what you’re looking for:!AqlDTSc6vEdFgZ8-km3Ra7olOf4ggg
I guess the “rejected by controller” messages are a bad sign?

For others: Turned on logging to a file according to Separate zWave log file? and rebooted the system.


P.S. any hints where to better upload the log files >1MB to share them here?

Hi @Chris

FYI: I tried to revert to 2.4.0~M8 including deletion of all things, same result as before…

don’t know what was the problem, but it’s working again

  • deleted all items in Inbox (nodes which were not identified - so all)
  • deleted Z-Wave Controller in things
  • upgraded to RC1
  • unpowered some of my fibaro plugs, as they send very oft power reports (intended for a research project) --> idea was to reduce z-wave traffic
  • included z-wave controller
  • started detection

–> about 95 % of my nodes are working again, remaining ones will hopefully work tomorrow morning (battery powered nodes)