Zwave node strange behaviour

Hi everyone,

At the moment I’m using openHabian with the latest openHAB 2.5.4-1.
Since the 2.5.3 update I’ve noticed that 1 node of my zwave network, a Fibaro RollerShutter 3, is behaving very strange.
Sometimes it responds on commands UP/DOWN,but won’t give the status back (I double checked the association of the lifeline). But somethings it responds on nothing.
Also, HABmin says sometimes that the node is not communication with the controller, but it will respond on commands.

However, if I restart the zwave bundle, it will response most of the time. But not for long.

What can be the problem? How to debug? I’ve captured a long log and see a lot of messages timeouts. What does that mean? (707.9 KB) (687.6 KB) (689.4 KB)
Above the log files, there are zipped, so you must remove the .log extension.
The node that is the problem is node 4.
This is what Habmin shows me:

If you need more info, let me know


A few weeks back, I’ve posted my problem. Somehow it was working for weeks and all of the sudden, since a few week the problem is back.
I’ve already updated to openHAB 2.5.5, but the problem exists (again).

What I noticed is that as soon the zwave device gets a command, it goes offline and within a very short time online again. But also if offline, a restart of the binding gets it online.
I’ve noticed that the zwave device only has 1 neighbour: node 2. But that node is further away than other nodes. I’ve tried to heal the device, but it fails -> it gets offline.

I’ve further tried to remove the xml file en re-initialise the device. It works for a moment, but then it reported offline.

What can this be? Re-including is for my a last resort. The device is difficult to acces (but not impossible).

This is my zwave log:

While waiting for the experts perhaps the log viewer can show something.

After you upgraded to 2.5.5 did you delete your device Thing (NOT exclude from the network) and rediscover & add it to get any new settings from the binding, The Thing id will stay the same so your items will not be broken.

Ah, that’s one thing i haven’t tried yet.

1 Like

It is recommended, especially with major upgrades, to delete all Z-Wave device Things (not the coordinator) and re-include to pick up any new database changes from the binding. The database is community maintained but part of the binding.

Well, I removed the thing and added it again. It reads the new database changes (such as the blinds control), but now I can’t configure it… The association for the controller can’t be changed. The log give an error 2020-06-15 20:01:46.007 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 4: Unknown association group 1
I get this error in both PaperUI (with error of all configurations) and Habmin.

What is this???

complete log file: zwavenode4.log (59.9 KB)