ZWave not generating XML for Aeotec TriSensor

Good day all,

For the last three weeks, I have been trying to add my first ever sensor (Aeotec TriSensor -Model: ZWA005-A) to my openhab 2.5.0.M1 using the ZWave stick (Aeon Labs Aeotec Gen5 Z-Wave Plus – ZW090) and I am not getting any information from the device.


The Z-Wave binding did recognize the TriSensor but I am not getting any information from it neither in the Control panel of the PAPER UI nor from any rules.

My “items” file seems to be OK.

detecteur.txt (704 Bytes)

I noticed that the Z-Wave binding did not create any XML file for that node in the openhab2/userdata/zwave directory. The “nightly heal” did not generate it as well.

Since the TriSensor is a battery powered device, I did wake it up numerous time (ie a lot !!!) within very close proximity of the ZWave stick but no success. In fact, according to the “events” log, this as far it went into the binding process:

node12 discovery - 2019-10-21.txt (1.4 KB)

In addition to waking up the device numerous times, I also deleted the node12 from the “PANAL UI - Configuration - Things” screen and re-added it from the Inbox, but no luck there. The exclusion of the device from the ZWave stick and its re-inclusion did not improve the situation except the fact that my node sequence jumps from node9 to node12.

Throughout my search of the openhab community, I came across this mention from @Chris dated back to November 2016 on issue: Node.xml does not esist
“The lack of an XML is not related to the database - it means that the initialisation isn’t completed. So, the real question is why the initialisation isn’t completing, and for this you’d need to get a debug log from startup.”

This is the zwave log I got when I stopped the openHAB2 service and restarted it.

zwave.txt (529.2 KB)

I am running my openhab 2.5.0.M1 with Window 10 Pro 64-bit on a laptop with Intel Core i7-3537U CPU @ 2.00GHz, 8.0GB RAM, Intel HD Graphics 4000.

Thank you in advance.


That means the device is not fully discovered by the binding. If you follow the documentation & enable debug logging that should be evident. Battery powered devices need to be waked up quite a few times to get discovered completely.

I had a similar issue last weekend with a defective sensor of a different brand.

the device is not awake:

Wake it up:

1 Like

Thank you for your quick replies,

I stopped the openHAB2 service, restarted it and woke up the device numerous times by pressing the button for 2s and getting the red light on. Still no luck.

zwave-log1.txt (483.2 KB)

Then I deleted node12 from the “PANAL UI - Configuration - Things” screen and re-added it from the Inbox. Unfortunately, I got less than no luck :slightly_frowning_face: since the device is now showing up as "Unknown ".

zwave-log2.txt (17.5 KB)

Now, I am very confused on what to do next…:thinking:

Any suggestions would be appreciated.

Thank you


Good news people,

Since I was not able to figure out why my node 12 has become “Unknown” after I deleted the node from the “PANAL UI - Configuration - Things” screen and re-added it from the Inbox, I decide to restore my openhab2 directory from a backup I took the day before. Now, it is back to be recognized as a “ZWA005 Motion, light, and temperature sensor”.

Thank God for backups. I will perform them more often.

I have made several attempts to get my node 12’s initialisation completed by stopping the openHAB2 service and restarting it while ensuring the device is awake. Still no luck (ie: no XML). This is the zwave log of my last attempt.

zwave-log4.txt (490.8 KB)

Thank you.


It was still not awake:

That is not the way how to do it. The initialization process will start over and over again and never finish.
Just wake it up during a running openHAB.

1 Like

It seems battery operated devices just require a lot of patience when getting discovered by OH. I am struggling now with a different PIR Sensor. I finally got it discovered and functioning in USB powered node but now I need to associate in battery powered mode to get it functioning. This particular sensor has 2 different assocation modes.

Thank you people for your comments,

Today, I have made some progress. In the TriSensor user guide (, there are the following instructions on the button pressing functions:

I tried almost every function except the “Press and hold for 15 seconds” for Factory Reset. The “Press and hold for 5 seconds” for the 5 minute Wakeup did not help me. In all my attempts, I got the feeling that it was a combination of “Press and hold for 9 seconds” for Health Test and “Tap once (when paired)” to send NIF that advanced the initialization process to the point that now my I getting the Motion, Temperature and Light information via a rule. Here the zwave log associated to this big progress.

zwave-log5.txt (679.6 KB)

However, I am still not getting the battery level information and still no XML file. That is telling me that the initialisation process isn’t completed. What puzzle me is how can I invoke (or provoke) the initialisation process. It seems that waking up the device does not necessary re-start the initialisation process.

Thank you for your help.


I had a different sensor with the same instructions and found a triple press woke it up. I saw the results with zwave debugging turned on.

1 Like

Good news people,

Three days ago, for some reason that I do not know, I started to receive the battery level information.

However, there is still no XML file. Here the zwave log when this happened.

zwave-log6.txt (104.3 KB)

Now from PAPER UI - Control panel, I am getting Temperature, Light and battery level information but not the motion switch information.


However, via rule, I am getting all the information from this sensor including the battery level information. That makes me wondering, why we need the XML file…:face_with_raised_eyebrow:

Yesterday, I tried the button triple press suggested by Bruce. At first nothing changes. However after I disable and enable the node 12 thing from the “PAPER UI - Configuration - Things” screen, I finally get the initialisation process completed (NODE 12: Device initialisation complete) and with it, the creation of the XML. Here the zwave log.:slightly_smiling_face:

zwave-log7.txt (4.2 KB)

What is still puzzling me is the fact that the PAPER UI - Control panel is still not showing the motion switch information.

I was counting on the “nightly heal” process to address that. However, this morning I noticed this from the zwave log: :slightly_frowning_face:

NODE 12: Can not start heal as initialisation is not complete (GET_CONFIGURATION).

Worst, I also noticed that the XML file was not updated overnight and this message showing up every hour:

NODE 12: Polling…
NODE 12: Polling deferred until initialisation complete

I tried again the button triple press, disabling and enabling the node 12 thing from the “PAPER UI - Configuration - Things” screen, but nothing really changes. Here the zwave log.

zwave-log9.txt (24.8 KB)

I will keep you posted if I make any further progress.

Thank you for your help.


I think I have noticed that too, but Paper UI is designed only for OH administration. I see proper motion switched in the Basic UI.

Good day people,

I am closing this issue since the XML file was created and it gets updated occasionally (i.e.: not every night like the other XML files). I have put a new battery hoping that it would help. No sure, if it did.

The Aeotec TriSensor (Model: ZWA005-A) is functioning well most of the time. About every 10 days, for no reason that I know, it stops recording and standing data to the openhab. The fact that openhab keeps on polling it does not seem to impact the result - the data does not get updated.

Disable and enable the node 12 thing from the “PAPER UI - Configuration - Things” screen does not help.

While opening the device, I noticed that the white light blinking when detecting motion was not even working. I guess that the device was really hung up.

Waking up the device by pressing the inside button once will force the device to resend the data it had gathered prior of getting hung up (i.e. data of several hours ago).

The only way to get that device back on track is to remove the battery, wait a little while and put it back.

Needless to say that I am not recommending the Aeotec TriSensor (Model: ZWA005-A). In fact, I am looking to get another light, motion and temperature sensor from another company probably from Dome Home Automation.

Thank you all for your help.


You might want to check out Zooz and They have started providing devices so we can keep our zwave database up to date. They have an OH compatibilty search too.

Good day people,

For your benefit and the one of cinadr who is struggling as well with an Aeotec TriSensor, AEOTEC TRisensor fw 1.21 (20200731) cannot set association groups, I am adding this update on my own saga.

First, to ensure the continuity of my smart home, I bought a FIBARO Z-Wave Plus Multi Sensor for Motion, Temperature and Light (FGMS-001-ZW5). I found its light sensor less precise than the Aeotec TriSensor but it has been very reliable for the last 3 months.

Back in June, I contacted the Aeotec Support and explained how my Aeotec TriSensor was unreliable. They suggested that I upgrade my firm firmware from 2.09 to 2.21. Note that part of the firmware upgrade, you have to remove and re-add your device and that changes your device node number/id. The firmware did not resolve my reliability problem since the Aeotec TriSensor stopped sending information during 2 days.

The Aeotec Support staff asked me to check for following parameters: polling period, Group Association #1, Parameter 21 - Temperature threshold setting, Parameter 22 - Light Threshold setting, Parameter 23 - Temperature report interval and Parameter 24 - Light report interval. Since all those parameters were OK, they recommended warranty replacement of the unit.

By the third week of July I received the new TriSensor and I paired it successfully to my Z-Wave network. If the pairing went well, the new TriSensor appears to be less reliable than the previous one. In fact, for the first 4 days, the TriSensor had updated the temperature, luminance and alarm motion data only a few times. As recommended by the Aeotec Support staff, that I upgraded my firm firmware from version 2.15 to 2.21. Unfortunately, the TriSensor stopped sending temperature, luminance and alarm_motion data about 7 days after the firmware upgrade. Even the DEL showing motion detection stopped functioning as well.

At the end of the first week of August, the Aeotec Support staff suggested that I changed the Parameter 1 [2 byte] to 241 (1 second over the timeout time on Parameter 2). Like before, after 7 days of working well, the TriSensor stopped sending data. However, about 35 hours later, it resumed sending data without any intervention from my part. Even the battery level was updated. I do not understand why the TriSensor stopped and why it resumed sending data.

The Aeotec Support staffs have not given up on me yet. They are testing the TriSensor at their end and talking to their engineering team. To be continued…


Good day people,

This is my last posting on this issue.

Last fall, the Aeotec Support staffs concluded that the update from V2.09 to V2.21 would not resolve my issue. The Light sensor itself was causing the device to freeze temporarily and then unfreeze on its own. Based on that new information it sounds like the firmware of the light sensor itself needs to be updated, but cannot be done directly. After performing testing on a new and updated replacement unit, Aeotec sent it to me. I am glad to report that after several months, the unit is still working flawlessly. The end. :slightly_smiling_face:

1 Like