[zwave] openHAB 2.5.0 Build #1725 Danalock

Hi all,
i have got a problem, and i wrote an email to @chris, but he is busy an i need assistance to solve the issue.
So im using Danalock V3 with openhab and ZWAVE beginning with March. Everything was OK.

Now, i installed the new firmware for the lock, and after that i cant add it to Openhab2.

Lock is hard-reseted, Zwave controller is hard reseted, i installed a fresh Openhab2 (version snapshot 1725)

and i tried to add the lock .

i got all the time the same message in the log:

2019-10-16 16:14:53.843 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:CONTROLLER:node2’ to inbox.
2019-10-16 16:15:00.049 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2019-10-16 16:15:00.256 [INFO ] [alization.ZWaveNodeInitStageAdvancer] - NODE 2: SECURITY_INC State=COMPLETE
2019-10-16 16:15:00.896 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 010E:0009:0001::1.2
2019-10-16 16:15:05.757 [INFO ] [mmandclass.ZWaveDoorLockCommandClass] - NODE 2: Door-Lock config report - timeoutEnabled=false timeoutMinutes=254, timeoutSeconds=254
2019-10-16 16:15:06.609 [INFO ] [mmandclass.ZWaveDoorLockCommandClass] - NODE 2: Door-Lock config report - timeoutEnabled=false timeoutMinutes=254, timeoutSeconds=254

is there a possibility, that we have got a database problem because of new firmware?

No, it is set to support all firmware versions:

thanks for the quick answer. Do you have a proposal where to start?
In Habmin i can see the following informations:

Not really as I don’t have any locks. Did you verify the correct security key?

no this will be the next step. But what is a good security key? on the lock there is a number, but this is longer than the number in openhab2

Build 1725 is a snapshot, correct? Z-Wave binding os broken in the latest snapshots for many people. Does Milestone 3 not contain all the entries you need?

I think there has been some GitHub activity troubleshooting the bining but I would expect it coud take a few days before a solution is verified.


Hi, thanks for the information, i will try it with M3.
(i verified the key, and it was ok, but i got the same result again)

OK The snapshot binding release a short while ago works as expected. I have verified it personally.

so under M3 secure inclusion is not working for me. i will try some days later with a new snapshot release

does somebody have an idea, how to solve the issue?

If you use the update script, the snapshot build from that works fine now.

1 Like

thanks a lot, with the newest snapshot 1728 it works!
that was an binding issue