Zwave Qubino SmartMeter ZMNHTD

@datsac: are you having any issues with the qubino smart meter? For me it works for the first 30 to 60 mn after power on, and then it does not deliver any actual data. If you poll it, it delivers the last actual reading. Only through a power on/ off, it restores normal operation. Is there any peculiarities for this device that we need to respect?


The qubino smart meter should send value updates according Parameter 40 (power reporting on power change) and parameter 42 (power reporting by time interval).

I have configured the Parameter 40 to 10% and the parameter 42 to 15 seconds, but any update is received.

I only receive updates every 30 minutos (polling period) or If I push “refresh items” button in the device description section in HABMIN.

Seems, there is any problem with multi_instance implementation in the qubino smart meter (see previous posts)

@chris: Have you found any solution about this problem?

@datsac I had a discussion with Qubino’s support. I possess a module with version S1. Now they are at version S6. I need to send mine back for SW update. As soon as I have it back, I will inform you about my tests.
btw, which version has your meter? (usually found on the right side of the module under PN: ZMNHTD1 H1S1P1)


Sorry for the delay, but I had to dismantle the electrical panel to know version of my smart meter module.

I confirm that I have the S6 version of the smart meter (H1S6P1).


Hi Chris,

By default, the qubino Smart Meter has the parameter 100 (Enable/Disable endpoints relays) to value 0 (=disabled). Disabling them will result in hiding endpoints 1 and 2.

I reinitialised the device with endpoints enabled (parameter 100 to value 3 (=Endpoints IR external relay and External relay enabled).

Now, zwave binding seems to find endpoints, but no changes in funcionality. Only updates meter values in the polling time established.

In the logs, a message every 10 seconds (as defined in the parameter 42 (power reporting by time interval):

2017-06-21 00:12:19.825 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 13: Application Command Request (ALIVE:DONE)
2017-06-21 00:12:19.826 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 13: Starting initialisation from DONE
2017-06-21 00:12:19.828 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 13: Incoming command class MULTI_INSTANCE
2017-06-21 00:12:19.828 [DEBUG] [class.ZWaveMultiInstanceCommandClass] - NODE 13: Received MULTI_INSTANCE command V2
2017-06-21 00:12:19.829 [DEBUG] [class.ZWaveMultiInstanceCommandClass] - NODE 13: Requested Command Class = METER (0x32)
2017-06-21 00:12:19.830 [DEBUG] [class.ZWaveMultiInstanceCommandClass] - NODE 13: Endpoint = 1, calling handleApplicationCommandRequest.
2017-06-21 00:12:19.831 [DEBUG] [.commandclass.ZWaveMeterCommandClass] - NODE 13: Received METER command V3
2017-06-21 00:12:19.833 [DEBUG] [.commandclass.ZWaveMeterCommandClass] - NODE 13: Meter: Type=Electric(1), Scale=A(5), Value=1.323
2017-06-21 00:12:19.835 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 13: Got an event from Z-Wave network: ZWaveMeterValueEvent
2017-06-21 00:12:19.835 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 13: Got a value event from Z-Wave network, endpoint = 1, command class = METER, value = 1.323

Previously to enable endpoints, the message was “NODE 13: Endpoint 1 not found. Cannot set command classes.”

Anyway, I think meter values should be send to endpoint 0, not to endpoint 1.

Power reportings in polling period time are sent to endpoint 0, but power reportings by time interval defined in parameter 42 are sent to endpoint 1.

On the other hand, has any relevance to this problem the message in device database “Endpoint 0 has no command class linked to the basic class”.



could you please post the generated xml for this node?
Mine works fine when reporting to openhab2, but something is strange when controlling the endpoints.
Endpoint1 seems to behave like endpoint 0, it turns ON and OFF both relays (IR and External). Endpoint 2 seems to control External Relay only.
In my generated xml I can see a third endpoint reported by the device. Is this also your case?
Maybe one should deleted the genrated xml, then exclude / include the device again without changing its parameters. (unfortunately I wasn’t able to check that yet).
BTW, I am running now S6.


I attach my xml file. Also I can see a third endpoint reported. Maybe It’s necessary to change endpoints IDs in zwave database ( endpoint 0 renamed to 1 , 1 to 2 and 2 to 3).

In openhab logs, meter values are always send to the endpoint 1 (not to the endpoint 0).

On the other hand, in my case, the smartmeter is only reporting every 30 minutos (=polling interval) and not when power changes occured

node13.xml (30.6 KB)


Why do you think this is strange?

Endpoint 0 is the root endpoint. It is normally a consolidation of the different functions that a device supports. So, if endpoint 0 controls both, endpoint 1 controls one and endpoint 2 controls the other, then this would sound correct to me (without knowing the device of course).

Please do not do this as it’s likely to cause (big!) problems.

do you possess an external relay and an IR relay?
Could you test to confirm the behavior described in my previous post?
I would be more than grateful.
It could be a Qubino fw issue. In that case I can contact them and ask for a fw update.

is it normal that the enumeration of the endpoints starts by 1 instead of 0?

Where are you looking? There is ALWAYS an endpoint 0 when it comes to some definitions, and NEVER an endpoint 0 is other definitions.

Endpoint 0 is the root so is not encapsulated by the MC classes. MultiChannel classes start at 1.

So - it depends on where you’re looking?


This is correct, but that is not what I wrote in my original post. I wrote that Endpoint1 behaves exactly like Endpoint0, which it should not be the case, right?

Sorry - I misread that. Probably it is not right and looking at the manual it is incorrect.

@Alexus1211 I’m sorry but I don’t have an external relay yet.

Maybe It’s necessary to change endpoints IDs in zwave database ( endpoint 0 renamed to 1 , 1 to 2 and 2 to 3).

Please do not do this as it’s likely to cause (big!) problems.

@chris Ok, Bad idea about changing endpoints ids.:worried:

Because I don’t have any relay i can’t see the behaviors explined by @Alexus1211

In reference to the status updates for our qubino smartmeter, maybe the problem is related to this post

As Allen explains, in the channel settings of the device, Association group field generally is blank, and if I try to add the controller to Group 1 / Lifeline it vanishes again at some point.

With no lifeline association with controller, updates are not going to work…??

Yes - I meant to comment on that, but I think this is likely. I hope to look at this issue shortly.

Hi Chris, any update on the Qubino issue?

No - I do now have a switch to play with and I hope to look at it over the weekend.

Please note that a fix will likely only be added to the development binding -:

At least initial testing will be done here and then I’ll have to see if it can be retro fitted (probably not as it’s quite a lot of changes).

What’s the best parameter to use with a Razberry? To me is working half good, I mean after 10 minuts, I don’t get measures anymore, may be has to be set some params?

Hello every one.
Any updates on this topic?
Does any one succeeded to control External relays?
I got the same issue. The firmware version of the Smart Meter is “S7”