Zwave refresh rate

Is there a way to increase the refresh rate of zwave devices? Also, how frequent is to much polling? I have rules that triggers and does things based on certain lights turning on. They work great when using the UI as the update is instant but the delay while waiting for the device to refresh automatically makes the rules useless. So if someone turns a light on via the switch it can take so long to trigger the rule that it ruins it.

I’ve tried adding the {zwave=“2:command=SWITCH_MULTILEVEL,refresh_interval=10”} to my items file but the devices refresh every 60 seconds regardless of how low i put the refresh number.

Sample of my items file:

`Dimmer Light_FF_Kitchen_Ceiling 	"Kitchen Ceiling" 		(FF_Lights,FF_group1,FF_mainarea,FF_Kitchen, Lights) {zwave="2:command=SWITCH_MULTILEVEL,refresh_interval=10"}
Dimmer Light_FF_Dining_Ceiling 	"Dining Ceiling" 		(FF_Lights,FF_group1,FF_mainarea,FF_Dining, Lights)  {zwave="3:command=SWITCH_MULTILEVEL,refresh_interval=5"}
Dimmer Light_FF_Living_Ceiling 		"Living Room Ceiling" 		(FF_Lights,FF_group1,FF_mainarea,FF_Living, famroomlights, Lights) {zwave="4:command=SWITCH_MULTILEVEL,refresh_interval=5"}
Dimmer Light_FF_Family_Ceiling 		"Family Room Ceiling" 		(FF_Lights,FF_mainarea,FF_Family, famroomlights, Lights) {zwave="5:command=SWITCH_MULTILEVEL,refresh_interval=5"}
Dimmer Light_FF_Foyer_Ceiling 	"Foyer Ceiling" 		(FF_Lights,FF_mainarea,FF_Foyer, Lights) {zwave="7:command=SWITCH_MULTILEVEL,refresh_interval=60"}
Dimmer Light_FF_Hallway_Ceiling 	"Hallway Ceiling" 		(FF_Lights,FF_mainarea,FF_Hallway, Lights) {zwave="10:command=SWITCH_MULTILEVEL,refresh_interval=60"}
Dimmer Light_FF_MasterBed_Ceiling 		"Master Bedroom Ceiling" 		(FF_Lights,FF_MasterBed, Lights) {zwave="6:command=SWITCH_MULTILEVEL,refresh_interval=60"}`

Config file:


Any help would be appreciated.

I would avoid polling unless you really need to. The binding is designed to keep polling down, so if you have a lot of devices where you’ve configured polling, then it will only allow 2 polls into the queue at once. This is done to keep the binding responsive - otherwise, if you fill the queue up will polls, when you go to turn on the lights, you might have to wait.

What devices do you have? If they support associations, then use associations, and disable polling.

1 Like

Great information, I was unaware of associations. I just read up on it and i guess i’m a little confused on how to set this up. I installed habmin and started following the instructions found here ( ) but I do not see anywhere to add associations. When I follow the instruction this is as far as I can get. Am I missing something?

I have GE dimmers, I don’t remember the model numbers but I can find out. I know they’re the most recent version, at least they were when i bought them earlier this year.

I guess you have the GE12724? At least that’s what HABmin is showing in the image you posted :smile:

Unfortunately the GE devices don’t support associations - one of the few brands not to (for some very strange reason!). I think they send a NIF when you press the buttons though, and then the binding should treat this as a hail, and should poll at that point. Unfortunately the NIF is not routed since it’s a broadcasted message, so this will only work if the controller can hear frames from the devices directly.

Otherwise, unfortunately you will be stuck with polling and the limitations this affords.

Firstly, Thanks for all your help Chris! With every reply I did more research based on what you’re saying and I quickly realized there’s more to the z wave setup than I thought. I believe even if I don’t have a happy ending to this issue my setup is better off as a result so thank you!

I figured out how to adjust the polling below once per minute but almost immediately corrupted the binding and foobar the zwave setup. After pretty much starting over, i got it working again and I think I set the polling que to high. Trying a lower number allows me to poll more frequently without breaking anything which helps my rule work better. However, i’m concerned about what will happen when I include the rest of my zwave devices. Currently only 16 are included into the network.

It looks like you’re correct about the GE switches. As I dig into this it looks like functionality has been removed from the new version of the switches. I have configuration perimeters for the few older switches I still have not replaced that allow me to turn off the status led and adjust the dim rate, etc but the new switches have nothing. NIF was apparently removed also, WTF. On my old switches openhab gets an update ONLY for single press on or off at the master switch. Dimming does nothing as far as updates and no updates at all from the slaves. I tried the same thing on the newer switches and i get nothing at all from the masters or the slaves. The logic or lack of around this is giving me a head ache. So weird they added official LED support but took away some pretty useful features. Those blue status leds are bright as heck for a bedroom.

What are the odds that the databases is incorrect and how would I go about verifying? If they are incorrect what are my options? I just can’t believe they would cripple the device and 2-way communication in this manner.

I’m a little more than frustrated with this discovery. I bought 3 switches to test and all went well so I proceeded to upgrade every switch in my house. I then decided to upgrade every bulb in the house to LEDS at a painful $1K plus price tag only to find out my zwave switches are not compatible. I then spent hundreds to replace all the zwave switches that i just bought 6 months earlier. Now I have zwave switches and LED bulbs without the flicker but the new switches are dumb compared to the old ones as they’re missing a whole bunch… every feature the old ones have. Very frustrating, I’m going to go play in traffic now.

Not sure what to do from here.

When did you buy your 12724s? I just bought one about two months ago and it has all of the features that your mentioned were missing. I’d be really surprised if GE took those features out. Have you tried calling their tech support?

I’m considering a large purchase myself, so I’d be curious to learn what you find out. Not sure if there are equivalent switches out there.

I should caveat that everything on my switches works, with the exception of setting the on/off dim rate and step. The local dim/rate works fine. Dimming OFF works as expected, but dimming ON is instant and ignores my settings. Have you noticed that at all?

I bought them in March of 2015. It’s very interesting you have these features. Can you also do associations? After reading your reply I did another search and found a quick blirp about the new version (12724) supporting association.

What version of openhab are you on and whats the version of your binding? I wonder if it’s a me problem, as in my openhab instance.

When I get a chance i’ll call support. I’m under the impression that i bought these fairly recently after they were released. Maybe I have to update them… Can they be updated?

I didn’t know what associations were until I read your post. I’ll have to give them a try.

I’m running openHAB 1.7 with the zwave add on version 1.8. The functions you see in habmin are likely pulled from your device xml file and not the device itself if that makes any sense.

Try the 1.8 binding and maybe uninstall and reinstall your device from the network. Let me know if that works!

Any luck fixing this?

Not yet, I called support and after going around someone who should never be in support I got someone who sounded like he knew what he was talking about. So the new switches should support all the configuration perimeters of the old switches along with the addition of associations. The configurations are all accessible by default and it’s up the the software to display and interact with them.

I guess my next steps is to update the binding and if that fails then remove and re-add the switches.

Dumb question, do I have to download each file individually off of github and add to a jar archive or just the file for the GE devices? I’m new to the binding update processes of openhab.

I would replace the whole binding so that you get the rest of the goodness of 1.8. It should be as easy as dropping the add on into the add on’s folder.

Instead os updating the binding I saw 1.8 was released so I just went ahead and updated the Openhab runtime. With that I can now change the configuration parameters with the exception of association groups. I also noticed they’re identified as GE ZW3003 which i don’t think is correct but they’re now working as expected so…

Also the NIF is working as it does on the older model switches so, awesome! Next question, How do I write a rule based on the NIF message? On the console it looks like any other status update message. It’s also not accurate as I think it displays the current state and not the target state. If you press on once from the off position, and the saved state is 100%, you’ll see an update of 2 because the dimmer was at 2% on the way to 100% when it sent the update. The same is true in reverse, the update would be 98%. Am I missing something, is there anyway to distinguish the NIF message from a polling update?

I’m curious about this as well. I have a bunch (6) 12724 dimmers that I recently installed and am starting to roll out OpenHAB2 (with hopes of contributing some UI work eventually). The hardest part I’m finding with rules is also with the fact that all I get is a status and initial value, which makes it very difficult to determine if the light is being turned on or off. Ideally I’d like to have a “double click” type rule, where if a switched is double-clicked on/off it turns a set of lights on/off.

I’m also noticing that even with refresh_interval=5, that my UI dimmer values don’t seem to get updated (i.e. if the light is turned off, the slider isn’t showing 0 etc).

sc1982 how did you find out that these dimmers have associations?

Originally I saw a mention of it on a forum that the new switches support association then I confirmed with jasco support that it is a feature on the newer model switches. Then, after I posted my last reply here I found this universal database online of what appears to be all zwave devices (didn’t save the URL, although I should have) and it’s listed as NOT supported there. Openhab is not showing it as a feature but my understanding is the capabilities of devices are pulled from universal lists like the one i found. So the million dollar question is who is correct, Jasco support or the internet? I’m leaning in favor of the internet but i’m cheering for Jasco… :grin:

Some work around I’ve implemented on the rules is to write the trigger as one of the following: (The location and use of the switch determines which one I use)

   Item switch changed from OFF

   Item switch changed from 0

   Item switch changed
if(switch.state > 0){

   Item switch changed
Thread::sleep(2000)  //Give the dimmer a chance to adjust
if(switch.state == 0){

You get the idea. I also had an idea of doing something like the following but never got around to implementing as i changed directions. There is a race condition once you factor in polling intervals and such but limited options:

   Rule 1:
var Number switchlevel=0
rule "Sync level"
      <Cron Job a few second longer that the polling interval> 
    switchlevel = switch.state

  Rule 2:
    Item switch changed
    Thread::sleep(1000) // no real need to pause as one digit is all that's needed for the evaluations below
    if{switch.state > switchlevel){ 
           //the switch was dimmed up}
    if{switch.state < switchlevel){ 
           //the switch was dimmed down}

I am very, very far from a programmer but this is how my mind work, makes sense to me…

Also, If refresh_interval=5 isn’t updating the UI or the state of the switch every 5 seconds check to make sure it’s actually polling every 5 seconds. I couldn’t get it to poll that frequently without upping the message queue limits in the config. I got it to poll very frequently but there are potential ramifications to upping the message queue limits.