Zwave scene activation behaviour

I am migrating zwave scenes from HS2 to OpenHAB but scene_activation is not working as I expected.
I have attached scene command of my Fibaro device using the syntax :

Number ECL_mN2_Chambre_SceneCmd	 "myTripleClicScene" (ECL, SCE)  { zwave="8:command=scene_activation,scene=15,state=0" }

I expected this to trigger a state change event in openHAB everytime I triple-click the button but indeed, the state change only happens every 2 times I triple-click.
I tried to add a 2nd device with state=1 and state=* with no success.

First triple-click > Number ECL_mN2_Chambre_SceneCmd state changed to 1
Second triple-click > nothing is reported
Third triple-click > Number ECL_mN2_Chambre_SceneCmd state changed to 1

Any idea why this behaviour and how to catch a state change everytime the scene is triggered on the device?

Thank you

Answering to myself: only one of my Fibaro dimmers is behaving that way. Others dimmers are sending properly the state message everytime I activate a scene.

I will look at the settings of the reluctant one more carefully to find what is causing this different behaviour.

I’ve found that zwave devices sometimes aren’t correctly included - sometimes obviously (i.e. they show as the wrong device type) and sometimes in a way that’s hard to spot. So may be worth excluding and then re-including the device, just in case.