Zwave stick Aeotec Gen5 plus offline in OH3.4

Like in this topic: , my Aeotec Z-stick Gen5 plus, stays off line.

System: Laptop Intel i5 gen8, 8GbRam, 256Gb SSD
OS: Debian 11
OH: OH 3.4.2 in docker
Z-stick: Aeotec Gen5 Zwave Plus (from 2016)

I backuped the zwave-network using the software from Aeotec on my Windows-laptop. This works fine, so I think I can conclude that the stick itself is fine.
Before I had OH2.4 running in Debian without a docker, and it was working just fine.

I have read lots of threads about this same problem but the solutions don’t seem to work for me.
I have installed a powered USB-hub although this is a solution to a RasPi-problem I think.
Of course I checked the userID from openHAB and passed it to the docker.
I Also connected both /dev/ttyACM0 and /dev/ttyUSB0 to the docker.
My zStick is on ttyACM0:

sudo dmesg | grep ttyACM
[ 5.386451] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

and I did:

docker exec \
    -d \
    openhab \
    /bin/chmod o+rw /dev/ttyACM0

Should this be done every time the docker starts/restarts?

I also tried the workaround: installing SerNet:

Sudo apt install ser2net
Sudo nano /etc/ser2net.conf
deleted the whole content and added only this line:
3001:telnet:0:/dev/ttyACM0:115200 8DATABITS NONE 1STOPBIT remctl
Sudo systemctl enable ser2net
Sudo systemctl start ser2net
Port configuration in zwave-thing:

This too does not do a thing for me.
Inside the docker I did this:
d /run/lock 0775 root dialout -

Add the following line to the legacy.conf:

d /run/lock 0775 root dialout -
And then copy the legacy.conf to tmpfiles.d
cp /usr/lib/tmpfiles.d/legacy.conf /etc/tmpfiles.d/
sudo nano /usr/lib/tmpfiles.d/legacy.conf
d /run/lock 0755 root root -
d /run/lock 0775 root root –

#d /run/lock/subsys 0755 root dialout -
d /run/lock 0775 root root -

Now I really don’t know what to do anymore. So I asked ChatGPT as it’s quick (not necessarily correct of course). It helped me do the following:

sudo docker exec -it openhab3 /bin/bash   
root@HAS:/openhab# ls /dev/tty*
/dev/tty  /dev/ttyACM0  /dev/ttyUSB0

I installed minicom on the docker.
Running minicom -D /dev/ttyACM0 -b 115200 brings me to a black screen
I think this meens I’m in the zwave stick???

When I press the button a few times I see this in the terminal:

 ▒H     `                                                                 2!4▒ ▒
2!4▒    `22!4H▒ `  2!4H▒    2!4H▒+   2!4H▒▒+  2!4L▒    2!4L▒    2!4L▒    2!4L▒ B

So it looks like there is some connection, but I don’t think it’s communicating well.

Now I hope you have an idea that I might have missed or that I went the wrong way somewhere?
Otherwise there are only two options: solder a wire inside like this: (I hope not, I barely understand what they say in that topic.
Or I have to buy a new stick. I hope to prevent both.

Just one thought (I’m running a very similar setup and just did a complete re-install according to my step-by-step): Perform the same on a test installation and see if this works, to check whether it‘s maybe a hardware problem?

Alternatively, before 3.4 was out, I faced the problem of the stick not coming online, which I solved like this. Though, to be fair, that was a solution for a stick tja got online once but not after a reboot.

Hi Cplant,
I used your -env and setup-file, so I have a fresh openhab-install (not using my existing /opt/openhab).
I love your setup, so I am going to re-write it such that it uses the /opt directory of the host-OS.
But as far as my question for this thread: unfortunately my zwave-bridge is still off line…

No experience with this setup and it is not likely binding related, however you could try putting the zwave binding in debug mode from a startup to see if there are any relevant messages.

edit: also if the zwave binding was not installed from the UI there is the karaf command feature:install openhab-transport-serial