ZWave Stick gone after reboot

Tags: #<Tag:0x00007f387b863368>

I am using a “ZMEEUZB1” Z-Wave stick on an Intel NUC as a OpenHAB Server.

sadly, we recently had a power loss and after my server rebooted, the zwave devices didn’t seem to work.

I checked openhab and no serial device was listed. so I unplugged and plugged back in the ZWave Stick.
now I cannot see it in lsusb anymore and a dmesg -c gives me:

[  802.026152] usb 1-2: new full-speed USB device number 6 using xhci_hcd
[  802.154453] usb 1-2: device descriptor read/64, error -71
[  802.390189] usb 1-2: device descriptor read/64, error -71
[  802.626079] usb 1-2: new full-speed USB device number 7 using xhci_hcd
[  802.754458] usb 1-2: device descriptor read/64, error -71
[  802.990482] usb 1-2: device descriptor read/64, error -71
[  803.098657] usb usb1-port2: attempt power cycle
[  803.750419] usb 1-2: new full-speed USB device number 8 using xhci_hcd
[  803.750640] usb 1-2: Device not responding to setup address.
[  803.958699] usb 1-2: Device not responding to setup address.
[  804.166551] usb 1-2: device not accepting address 8, error -71
[  804.294468] usb 1-2: new full-speed USB device number 9 using xhci_hcd
[  804.294704] usb 1-2: Device not responding to setup address.
[  804.502629] usb 1-2: Device not responding to setup address.
[  804.710013] usb 1-2: device not accepting address 9, error -71
[  804.710308] usb usb1-port2: unable to enumerate USB device

also on other devices, the stick isn’t found anymore.

does anyone have any idea how to reset this stick (the led still lights up)

don’t resort to resetting the stick yet. Have you tried restarting the box or OpenHAB?

well, it happened during a reboot of the system. I tried rebooting the system aftterwards multiple times, with and without the stick connected.

very very strange. After unplugging the Stick for a day, it now works.

odd indeed but glad it is working

Hmm, and the stick is gone again, after a openhab restart. Also my ZWave Network seemed to be extremely slow beforehand.

Ok, the order to make the ZWave stick appear:

systemctl disable openhab2.service
shutdown
# unplug stick now (when PC is off)
# boot
# plug stick in
lsusb #shows the device
systemctl enable openhab2.service