Zwave stick not working after clean installation of 2.5.5

  • Platform information:

    • Hardware: hp desktop, core two duo 3mhz, 4Gb memory, 160G HDD
    • OS: Ubuntu desktop 20.04 LTS, clean installation
    • Java Runtime Environment: open jdk 11.0.7
    • openHAB version:2.5.5 installed via SNAP
  • Issue of the topic: On adding a zwave stick item, the stick is not recognised “does not exist” although the port “ACM0” does - ls -l /dev/ACM0 which has the correct permissions (I installed Openhab in user “paulr” and have set the permissions). Please advise

  • Please post configurations (if applicable):

    • Items configuration related to the issue: zwave stick which worked in previous installation
    • Sitemap configuration related to the issue: none
    • Rules code related to the issue: none
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

openHAB 2.5.x requires Java 8 not 11. Research the advantages & disadvantages of the different implementations. Zulu seems to be preferred.

1 Like

Thanks I will.

Try adding the port to the, see:

The Z-Wave binding is known for having port discovery issues, see:

I have replaced java11 with zulu java8 but same error

wborn unfortunately I am not that knowledgeable about linux. I looked at the webpage you recommended - how do I “adapt java command line arguments”. Where are they.

I don’t know how it works with snaps either. Most users here use either Debian packages using APT or Docker. Maybe you can switch to that or open an issue for adding some documentation about using non standard ports with snaps in the issue tracker:

I will start again with a clean install of ubuntu 20.04 and install openhab 2.55 using apt. I think snap is an un-necessary complication. Thanks

1 Like

Thanks for the advice. I reinstalled ubuntu 20.04, installed zulu java8, and openhab2 via apt. The zwave stick was found and went online. problem solved. goodbye snap


Great! I’d personally only use snaps if I would really like to run some newer version of an application that would otherwise mess up the system. That usually doesn’t occur often when upgrading to each LTS release in a timely manner.