Zwave thing detected twice

Platform information:
Hardware: RPi 4 8 GB and 32 GB micro SD + zwave: Aeotec Z-Stick Gen5 (ZW090) - USB
OH 3.0.1

I recently had issues that my Flood Sensor (Fibaro FGFS101) did not send updates.
Therefore I decided to remove it from controller and delete its thing.
I re-included it as a new node (it was detected as 20 and the previous Node 15).
Because I did not run into the same problems (using the old potentially problematic config, I picked Node 20 and it works well.
However, Node 15 always pops up in my inbox since.

I ignored it and removed it, but it’s still popping up.
Is there any way to get rid of this relict?

It is still on the controller as a zombie node. Removing from a network is not always successful.
SiLabs PC Controller software on Windows can remove it from the controller.

1 Like

Hi Bruce,

thanks for your quick response.
Does the zombie create issues usually?
I will check out SiLabs.

Zombie nodes can cause network routing issues of devices try to route through the non-existent node. Only one may not cause any noticeable issues.

Alright - thank you!

I recently encountered on my Fibaro motion sensor also, that it’s not reporting.
(Actually it indicates that motion is detected with its LED, but does not report this to the controller.)

So I wonder what might be wrong and it seems that several people here have issues with zwave since oh3.

My question is:
What’s the best way to solve this?
Removing all zwave things inccluding the controller?
Re-discover all things?

Any suggestion is greatly appreciated.

Does your Fibaro sensor work when you restart openhab, and then stop working at some point? If so, I suggest turning off Network Heal to see if that solves the problem. That’s the only common issue/solution I’ve noted amongst people moving to OH3, but there’s not enough data to conclude that it’s a problem with the OH3 software.

Anecdotally, I wouldn’t say that there are more people experiencing issues with OH3 than with OH2. Bruce would have more insight on that, though.

Thanks, Russ.
The logs show, that after a restart the timestamp (set with motion by a rule) does only change from NULL to a date in the past (3 days ago), so I assume that answer is “no” and it’s just restored from persistence on startup.
But I will check again.

What’s irritating is, that the node thing is ONLINE

I have checked on this but was not able to find it.
Finally I found this info:

So it’s about Simplicity Studio 5 (registration required)

Yes Silabs made it part of Simplicity Studio now.

Unfortunately, even after including it with a new node number, it’s gone again. :frowning:
(I have changed the battery before the new inclusion).

How could this be?

My heal time is set to 2 am, and the sensor stopped sensing updates at 3:41, which is not related I assume?

I’d try turning off heal if you haven’t done that yet. Only because it definitely helped others, and not for any valid scientific reason. :wink:

Thanks, Russ.
I just switched it OFF and will monitor its effect.
But I guess to heal is good thing, right?
So, how to compensate this then?

The nightly heal is really only needed if you physically move a node (device) It has caused some systems to have huge amounts of traffic during the heal process. Especially if there are lots of nodes or nodes with security enabled. Some systems, the traffic eventually causes the systen to lock up and unable to recover.

I was going to reply just now, but thought I should wait since Andrew was typing and I suspected he’d have a better answer than me. So I did, and he did. :wink:

1 Like

Thank you - That makes sense.
I actually moved some devices around:

  1. A plug closer to the dana lock (security enabled)
  2. A Motion detector to the corridor
  3. The Raspberry to another storage room to be closed to the miFlora bluetooth FlowerCare

However, this happend a few weeks ago and the zwave network was stable in between.

My motion detector did not come up reporting again yet (stuck in REQUEST_NIF)
I deactivated heal yesterday, stopped OH, deleted cache / tmp and restarted OH.

you can also heal individual nodes manually I think

Thanks - yes. looks like
At least there is a function to do so in the thing’s configuration itself.