Zwave - TZ75EU

Hi all,
Using OH2.2, i have added new Zwave Device TK75EU, the device is listed in the database - link to the device db - TZ75

the device discovered fine, however it appears as “unkown device”
without any channels to assiciate…

It was only added very recently, so it won’t be in 2.2. You need to upgrade to a more recent binding to get this device.

thanks, does the jar for 2.3.0 is avaible somewhere? trying to figure where to get it from…

It’s always available on Cloudbees

Thanks, Update to latest - and indeed device recognized.
i have linked the Switch and Dimmer - however something messed up the device entirely after sent the first command.
no matter what command sent - it only lowering the rollershutter,
even the S1 and S2 physical connection does it - tried to reset the device per the documentation and re include it - still the same…

Please grab a debug log showing what is going on so we can see what is happening.

thanks, link to the logs since yestersday after i re-added the TZ75EU with the last snapshot device (yesterday) and some debug from now playing with the switch and the dimmer associated with it… all actions edded lowering the rollershutter
i pulled it back connecting Line physically to S2 of the TZ75

(open as text editor)
node17.xml (108.7 KB)

I don’t see anything wrong with what the binding is sending. Maybe it’s a calibration issue?

There are a lot of ON and OFF commands being sent though - I’m not sure how these translate in this context?

Hello guys! I’m a total newbie on all OH and Zwave technologies. I’m trying to set up the TZ75 controller and I’m stuck in the same situation as Alon_Levy; I was able to pair the controller with OH2 running on the RPi/raZberry2 hardware, but when setting up the Items with the “Switch” and “Dimmer” options, is only the latter (as Switch type) that causes any actual effect, however it only activates the roller motor and I can’t stop it afterwards.

I tried the calibration suggestion but the instructions in the official user manual are not clear, so if anyone knows how to do it I’ll be appreciated.

Any further suggestions on how to solve this issue will also be very welcome :grinning:

@jaravena, are you able to send the roller up and down ?
in my case, i also contacted TKBHome, as also after reset and calibrating it, it only output Down command, without stopping.
according to them the 2nd relay is malfunction, and this HW is for upto 100W and not 1000W as written in documentation…
i tried to claim from them refund for this fraud, however they are not returning any email since this claim.

Thanks for the reply. So far I’m still stuck with only sending ON command with Dimmer item configured as Switch type. Sending OFF command makes no effect and the motor keep spinning. I have to stop it manually from the controller front case button.

When you say that you calibrated it, could you please let me know the procedure for that? I tried doing as per the instructions, by pressing the front case button for 3 seconds, but the motor start spinning endlessly, not the way it’s described in those instructions that it would go bottom, then up and then bottom again, so the controller would then “know the total range of up and down”.

Thanks again for the help!

i followed the process in the manual i got with the device, and i got the exact same result as did you.
the calibration lowers the roller curtain to the lowest point where the motor internal microswitch stops it from continue, and thats it, i have to manually connect the reverse wire to the L to get it back up…
as the internal switch doesnt work anymore.

this started to happen immediately after adding this device to OH, it used to work few weeks without a problem using standard up/down switch connectd to the TZ75.

@chris, what do you think ? seems very unlikely that we both having same problem after adding to OH …

I can only go on what I seen in the logs, and I can only repeat what I said above. I don’t see anything wrong in the binding. The binding is correctly sending through the commands that are sent to it as far as I can see. What I don’t know is how this device works, so I don’t know what these commands do in the device. eg what does ON or OFF do to a roller shutter? Maybe they are not the right commands to send? Likewise with the dimmer commands.

Maybe it requires recalibrating? If you have just included it into the network, then it would have been reset, so any previous calibration would presumably have been lost.

Sorry - but I don’t see any problem with the binding based on the log. If you can provide further information I’m happy to take a look.

Good news! Somehow it started working now, I disconnected everything and started all over. I assume there was a cable terminal that wasn’t screwed correctly into the TKB controller and thus not making the proper contact.

Anyway, it is now working forward and backward only using the Dimmer Channel > Dimmer Item. The percent slider in the Control dashboard works like a charm, remembering the last position and moving to any new percentage number you throw at it.

The only remaining task is to be able to calibrate the upper and bottom limits…I still don’t know how to fix that, is a WIP :slight_smile:

1 Like

Hi everyone and @jaravena,
I am struggling with the same error on OH 2.3 but sadly here it won’t resolve by itself even after

  • checking all cable connectors
  • switching up/down (just to make sure)
  • measuring the current and power while motors are running up/down
  • re-initializing, resetting and rebooting

the thing will nicely pop up as “online” all the time but simply won’t calibrate correctly. Any calibration attempt will cancel somewhere along the up-down-up cycle (which it is for me, other than what it says in manual where is says down-up-down).

I can use 0% and 100% on the dimmer effectively but it would be nice to be able and say 50% or anything else.

Side issue: no matter how I set the power timer, it never displays any other value than the voltage.

Any help would be appreciated.

I just tried this device and I’m curious why is the “dimmer” channel used instead of the “blinds_control”. It just seems weird to me because all other blinds devices use “blinds_control” too…

Am I missing something there? Is this problem related with the @degudejung problem?

@chris @mhilbush

It’s probably just an error with the input into the database. Please feel free to change this.

I’ve changed the SWITCH_MULTILEVEL channel, but not sure if that’s all required or if I need something more (in other devices I see in the XML, the “COMMAND_CLASS_BASIC” in the properties section under “blinds_control”, but I don’t know exactly how/why are related).

That should be all that’s needed. I’ll try to do a database update this evening.

Tested with the last version and seems to work OK.

Thank you