Zwave verses Z-way

My Aeon Tech S2 controller died I think (see below).

I’d like to know from the community whether they think it would be better to pay $20 more for a Z-way licensed dongle or stick with a Gen 5 Aeon controller?

Which would you choose, a new Aeon Gen 5 controller or UZB with a Zway license? Is it worth $20 more for z-way? Or should I stick to the zwave binding? Is there anything the Z-way binding can’t do (e.g. security command class)?

Any recommendations and experience stories would be recommended, particularly if anyone has experience with both.

Trouble shooting

For those who might be able to help me avoid
My Aeon Tech S2 zwave controller has died. At least after much experimentation that is my conclusion. I am moving off of a Docker based deployment of all my servers on an old laptop to an ESXi server. I have the controller passed through to the host correctly and the Zwave binding sees the controller.

None of my devices, be they mains powered or battery powered resolve to what they are. No amount of waking up, removing and reincluding them on the controller or restarting of the guest and host machines changes anything. Everything shows up as Unknown device.

The controller is in the same location as before.

Open Zwave Control Panel shows all the devices correctly and what they are.

I tried reverting back to my old configuration and now I find it does the same thing on the old host. All the devices show up as unknown in the inbox.

All of this has been with the snapshot version from the last couple of days.

I even tried plugging the controller into one of my Pis and setting up ser2net and socat, just in case the VM passthrough of the dongle was causing problems.

Well, it looks like I didn’t give my old setup enough time to resolve the device types. That version appears up and running now without problems. So it isn’t the controller after all. Back to the drawing board…