[ZWave] Zooz ZEN23 support

@chris I have a Zooz Zen23 switch which unfortunately isnt recognized by Openhab. PaperUI reports it as

zwave_class_basic 	ROUTING_SLAVE
zwave_class_generic 	BINARY_SWITCH
zwave_frequent 	false
zwave_version 	20.15
zwave_listening 	false
zwave_plus_devicetype 	UNKNOWN_TYPE
zwave_deviceid 	9500
zwave_nodeid 	13
zwave_routing 	false
zwave_beaming 	false
zwave_class_specific 	POWER_SWITCH_BINARY
zwave_manufacturer 	634
zwave_devicetype 	45329


Is there any way to make it to work?

I’ve added it to the database - I’m assuming it’s the same as already included and not something new…


Thank. Do i need to download the nightly zwave bindings file?

You will, but I first need to do a database export which I probably won’t do until tomorrow as I’m travelling tonight :frowning: .

Sorry for my ignorance, I’m still learning at a snails pace. When you do the data export, what do I need to do from my pi running 2.4 snapshot to get the database in with the switch you put in, I just got one as well.


@chris is this in the nightly build now?

I have not had a chance to update the database over the past few days as I’ve been travelling. I’ll take a look tonight hopefully.

@chris instead of polling you :grinning:, is it possible to look into the jar file to see whether the device is in there ?

Probably not easily. You can get a list of the devices, but it doesn’t give you the device IDs in this list.

In any case, it was been added, so no need to poll :wink: .

1 Like

I updated the Zwave binding,

216 | Active   |  80 |     | ZWave Binding

But still the device is not in the database?


I’ve just kicked off a rebuild - try again in 30 minutes or so.

Thanks it is working well now. The Zooz documentation mentions the following:

Toggle Control
Parameter 1: Choose if you want the to
turn the light on by clicking the toggle up
or down
Values: 0 – Toggle up turns the light on,
toggle down turns the light off (default);
1 – Toggle up turns the light off, toggle
down turns the light on
Size: 1 byte dec.

I dont see this in the settings of the device. Is this something which is not supported right now?

It looks like there are no parameters currently in the database, so yes, at the moment it’s not supported :frowning: .