Zwave ZW096 Nightlight time

I am trying to set the parameter 82 on my ZW096 but it keeps changing to 6144.

According to this it looks like it should have default to 18000730 but it won’t take anything in that format.

 +            <Index>82</Index>
 +            <Type>byte</Type>
 +            <Default>18000730</Default>
 +            <Minimum>0</Minimum>
 +            <Maximum>23592359</Maximum>
 +            <Size>4</Size>
 +            <Label lang="en">Time of Nightlight mode</Label>
 +            <Help lang="en">Set the time of night light mode 
 +                Value1: the time of LED on (unit is hour). 
 +                Value2: the time of LED on (unit is minute). 
 +                Value3: the time of LED off (unit is hour) 
 +                Value4: the time of LED off (unit is minute) 
 +            </Help>
 +        </Parameter>

I do not see the parameter 82 listed here though

Any help would be great.


Should this be a bug? If so where do I make one? I didn’t see any open or closed issue on git for this. I also don’t want to make an issue if it is I am just doing something incorrectly.

According to the manual I have (ie on the database site) there is no parameters 82. Can you point to a manual that shows the parameter 82 - it might be for a different firmware version.

I can’t find it in a manual anywhere but it is currently listed on in the device. Do you know who added this device to the database? Maybe it shouldn’t be there but maybe they have more information as to why it was added.

I also noticed that parameter 84 says it should be 0-100 but mine has to be much higher to even be visible, like 3289650?

I am still on OHv1 as I don’t have time to dive into v2 yet but if I can help in any way please let me know. I don’t know how to program in java but I have a decent understanding of programming.

I do see some other parameters that are not showing up though.
parameters 101, 102, 103, 111, 112, 113

What do you mean it’s “listed on in the device”? If it’s not in the manual, then I would suggest it doesn’t exist. I would suspect it was added incorrectly and has been removed?

No - each BYTE in param 84 needs to be 0 to 100 - not the whole parameter. This will mean much larger numbers (as you see :wink: ).

Maybe the OH1 database entry is a bit out of date and doesn’t have these - it could be updated from the online database if you fancy creating a PR.

I see it under the device in habmin. Maybe it has been removed. I tried updating to the nightly but when I did each time my zwave network would disappear out of habmin and the logs just stopped producing messages. I downloaded it from cloudbees, that is still the right place correct?

Ok, that helps, thanks I can work with that.

I’d love to help with that. Is there a guide on how to get started with making these updates?


Ok - that just means someone added it to the database - it doesn’t mean it exists in the device :wink: . Maybe it was a cut and paste error from another device when people were still making these files manually - I don’t know.

We need to be careful as adding incorrect parameters can cause problems so we can’t just add things that don’t exist - the manufacturers documentation is normally a good place to start and I would say if they manufacturer says it doesn’t exist, then it probably doesn’t.

Sure - see here.

OK, that makes sense.

Agreed - it should be as accurate as possible.

So, I pulled down the latest snapshot from$org.openhab.binding.zwave/ for 12/28 to make sure I had the latest before requesting changes. It seems the original parameter that shouldn’t have been in there has been removed BUT it looks like some other parameters that are in the manual and are in your database have been removed as well. I’m specifically talking about parameters 83 and 84, both of which are in the manual and were functioning correctly. I looked on git to see if I could find any issues or pr’s regarding this removal but I couldn’t find anything. So I guess my question right now is, how can I find out why they were removed? I don’t want to add them back in if there is a reason they were removed.

Thanks Chris. I promise I’m not trying to add to your workload and I appreciate all of the hardwork you’ve put into zwave and openhab.

I can’t see parameter 83 or 84 in this XML in the past - at least not in the history and history of the two versions. Maybe I missed something, but it doesn’t look like these parameters have been removed…

However, if they have, then I would say that’s wrong and I’d be happy to use the version in the online database - we just need to be careful of the versioning.

That’s for zw100-a. I’m talking about zw096. Here is where I see that it was in the database

Hmmm - not sure how I mixed that up - sory ;)… In any case, parameters 83 and 84 are also in the file you linked.

It looks like that’s when parameter 82 (the one that shouldn’t be there) was removed but it looks like a lot of the labels and such were also removed as well as parameter 83 and 84 which should be there.

I’m not sure - I would suggest to align them with what’s in the online database as I think it’s likely to be as accurate as we know - and if it’s then found to be wrong, we should fix it there and propagate through to the bindings…

Ok, I believe what is in the online database is accurate as well. There are a few parameters missing compared to what is in the manual. I don’t think anyone would use them but if you would rather it be as accurate as possible I can add those in. If not that is fine too, I just need to know what I need to do in order to get this corrected? I saw your link on the database for how to update the values, but since most of the values are in the database I’m not sure how to proceed.


While I can understand sometimes people don’t add everything as it takes time - especially on devices with a lot of parameters - but yes, I would prefer the database was accurate and correct :slight_smile: . If you don’t mind, it would be appreciated.

If you have an account on the database site, then you should be able to edit the entry to add the missing parameters - if you don’t have an account, then you need to register and then email me so I can update your access.

Ok, no problem. I prefer things to be as accurate as possible myself. I do have an account and I will make the adjustments. Once I do, what do I need to do to get them in the addon? Make a pull request?

I’ll try to knock it out tonight but I may not get to it till tomorrow night.

Thanks for being so responsive!

Yes - if you can make a PR that would be perfect. Thanks.

I’ve worked on the xml file a bit but sometimes when I recompile it and install it I get nothing but watchdog messages in my zwave log. Just wanted to know, is there a specific number of spaces it needs to be indented or anything?

Also, I’m using mvn clean install to build the new jar. Is that correct?

I am trying to troubleshoot if it is something with my environment or what but it is driving me insane.

I’ve tried adding a little bit to the xml and sometimes it’ll work and sometimes not but I don’t see anything wrong with what I’ve copied so I’m wondering about tabs and spaces?

Thanks for any assistance you can provide. If I can get this figured out I will attempt to update any xml files that I have devices to test with.

Do you see anything wrong with these changes that would make the binding fail?
PR - deleted

No - you just need to ensure that it’s valid XML. I would suggest to add this information direction into the database and export the XML from the database. With OH1 it’s ok to write your own XML, but for OH2 it needs to go into the database first.


Tabs and spaces between elements won’t matter - but you can’t add them inside the elements or they elements won’t match or be decoded correctly.

Good to know. If I export from the database for OH1 is there any cleanup that needs to be done to the file? I know before you said you had automated pulling from the DB for OH2 but OH1 wasn’t as easy to automate it?