$500 for the ability to textually configure openHAB 2 Z-Wave

I understand @chris has made a lot of progress with Z-Wave on openHab 2. I am offering $500 for anyone who can give me the ability to configure Z-Wave textually. I also require the ability to set Fahrenheit and refresh_interval per item.

1 Like

I’m happy to do this of course, but as has been described elsewhere, this is already implemented in the development version of the binding.

If you are after something specific, then feel free to contact me.

If we start throwing money around here, we might create a precedence that will for sure come back at us!
I definitely agree that there are services that need to be paid in terms of the work above the framework, when someone requires it but with a private approach and not public (i.e.: I have seen that this guy knows how to solve an issue, and I don’t want/know and/or have the time to do it). Offering money publicly for a service, will turn to demanding money for services, like a stock market!
I still hope that we will be open source!

BR,

George

4 Likes

2017-04-04 14:15:34.403 [ZWaveActivator ] - Z-Wave binding started. Version 2.1.0.201703151108

my zwave.things

Bridge zwave:serial_zstick:controller [ port="/dev/ttyACM0", controller_softreset=“false”, controller_master=“true”, heal_enable=“true”, security_networkkey=“AF 2D 9E 35 21 A1 ED 2B 45 B1 F4 DA 39 A8 B5 F2” ]

Works, but when I try a zwave thing in the zwave.things:

Thing zwave:device:controller:node2 (zwave:serial_zstick:controller) [ zwave_nodeid=“2” config_1_1=“0” ]

I get:
Configuration model ‘zwave.things’ has errors, therefore ignoring it: [3,56]: missing ‘]’ at ‘config_1_1’

Maybe there should be a comma between the configuration parameters?

Actually, it’s not possible to set configuration parameters like this (ie the config_1_1 parameters, or associations). You can set them, and they will be stored in the system and shown in the PaperUI, but the binding won’t set them in the device. I think you can still use PaperUI or HABmin to set this (but I’m not 100% sure).

Configuration of parameters needs to be done manually - this isn’t something that can be safely set automatically. This is of course the same as OH1…

People like @chris put in a huge amount of effort into openHAB and have a LOT on their plates. I have asked on several posts how to configure zwave textually without much help. It could be because its not possible, it could be because people are busy, whatever. If I need help and am willing to pay for it, I don’t see why it is a problem to offer it in a forum where someone may want to take me up on that offer.

Apologies if I missed this. I did point you at the issue on github when you raised an issue for this and it does say that it is implemented in the test binding -:

There is no problem in asking anyone for help, even for money, but it would be great to keep sharing in mind, and unfortunately money can not be shared publicly, unless anarchy is involved!
Don’t get me wrong, I also own a BMW! :wink:

BR,
George

1 Like

my zwave.things:

Bridge zwave:serial_zstick:controller [ port="/dev/ttyACM0", controller_softreset=“false”, controller_master=“true”, heal_enable=“true”, security_networkkey=“AF 2D 9E 35 21 A1 ED 2B 45 B1 F4 DA 39 A8 B5 F2” ]

Thing zwave:device:controller:node2 (zwave:serial_zstick:controller) [ zwave_nodeid=“2” ]
Thing zwave:device:controller:node10 (zwave:serial_zstick:controller) [ zwave_nodeid=“10” ]
Thing zwave:device:controller:node11 (zwave:serial_zstick:controller) [ zwave_nodeid=“11” ]

However it does not look like it is accepting zwave-nodeid, I am using Z-Wave binding started. Version 2.1.0.201703151108, is that the correct dev binding?

It should be just node_id - this got changed when it migrated from a property to a config parameter - I see the doc doesn’t reflect this so I’ll update… (sorry for the confusion).

The version is probably correct - it is certainly dated on the 15th, so I think this will be right (I assume you downloaded it from my website?).

Status: UNINITIALIZED - HANDLER_INITIALIZING_ERROR java.lang.String cannot be cast to java.math.BigDecimal

Try node_id=2 instead. I think if you add quotes the system treats it as a string.

Everything is showing up as UNKNOWN, do I have to add wave_manufacturer, zwave_deviceid, or zwave_devicetype?

Also, for items, I know that I need to change my current:

Group     Tstat10                                                                                                     (Thermostats)
Group     Tstat10_Chart                                                                                               (Tstat10)
Number    Basement_Tstat_HeatSetPoint         "Basement Heat Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {zwave="4:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=1,refresh_interval=600"}
Number    Basement_Tstat_CoolSetPoint         "Basement Cool Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {zwave="4:command=thermostat_setpoint,setpoint_type=2,setpoint_scale=1,refresh_interval=600"}
Number    Basement_Tstat_Temperature          "Basement Temperature [%.1f °F]"                        <temperature>   (Tstat10_Chart, Room_Temperature)       {zwave="4:1:command=sensor_multilevel,sensor_type=1,refresh_interval=600"}
Number    Basement_Tstat_Humidity             "Basement Humidity [%.1f %%]"                           <humidity>      (Tstat10_Chart, Humidity)               {zwave="4:2:command=sensor_multilevel,sensor_type=5,refresh_interval=600"}
Number    Basement_Tstat_OpMode               "Basement Mode"                                         <settings>      (Tstat10)                               {zwave="4:command=thermostat_mode,refresh_interval=600"}
Number    Basement_Tstat_ModeState            "Basement State [MAP(ct100.map):%s]"                    <settings>      (Tstat10)                               {zwave="4:command=thermostat_operating_state,refresh_interval=60"}
Number    Basement_Tstat_Battery              "Basement Thermostat Battery [%d %%]"                   <battery>       (Tstat10, Battery)                      {zwave="4:command=BATTERY,refresh_interval=1200"}
DateTime  Basement_Tstat_Clock                                                                                        (Tstat10, Clock)                        {zwave="4:command=CLOCK"}

Gets changed to:

Group     Tstat10                                                                                                     (Thermostats)
Group     Tstat10_Chart                                                                                               (Tstat10)
Number    Basement_Tstat_HeatSetPoint         "Basement Heat Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_setpoint_heating"}
Number    Basement_Tstat_CoolSetPoint         "Basement Cool Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_setpoint_cooling"}
Number    Basement_Tstat_Temperature          "Basement Temperature [%.1f °F]"                        <temperature>   (Tstat10_Chart, Room_Temperature)       {channel="zwave:device:67cd13f9:node4:sensor_temperature"}
Number    Basement_Tstat_Humidity             "Basement Humidity [%.1f %%]"                           <humidity>      (Tstat10_Chart, Humidity)               {channel="zwave:device:67cd13f9:node4:sensor_relhumidity2"}
Number    Basement_Tstat_OpMode               "Basement Mode"                                         <settings>      (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_mode"}
Number    Basement_Tstat_ModeState            "Basement State [MAP(ct100.map):%s]"                    <settings>      (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_state"}
Number    Basement_Tstat_Battery              "Basement Thermostat Battery [%d %%]"                   <battery>       (Tstat10, Battery)                      {channel="zwave:device:67cd13f9:node4:battery-level"}
DateTime  Basement_Tstat_Clock                                                                                        (Tstat10, Clock)                        {channel="zwave:device:67cd13f9:node4:time_offset"}

But what I can’t find is how to set the scale and refresh.

It looks like this will need a bit more work - sorry. I’ll take a look in the next day or so, but basically yes, because in this text mode you can’t set properties I need to also make these configurable.

I’m not sure what you mean by setting scale - this should only need to be set through the XML file. If you’re trying to think of this like OH1, then this part is not required.

For refresh, this is set at the thing level.

Ok, no problem, I noticed that after a while many of my devices did get a device type.

Is what I am seeing now.

I thought scale set fahrenheit vs celsius? By default now everything is celsius, trying to get it to fahrenheit via text files.

Interesting that the ones with device types are uninitialised… Are the ones that don’t have a type battery devices?

Ah - ok, yes - this is possible. Again, it needs to be done through a configuration parameter on the channel - see here -:

Well it looks like all uninitialized are ones that are reachable.

When I started up, everything was ONLINE, then slowly as it detected the devices they went UNINITIALIZED.

So, right now all the ONLINE devices are the nodes that have timed out and have not initialized.

zwave.log:2017-04-04 17:31:09.778 [ZWaveNodeInitStageAdvancer] - NODE 18: Node advancer: GET_NEIGHBORS - get RoutingInfo
zwave.log:2017-04-04 17:31:09.778 [GetRoutingInfoMessageClass] - NODE 18: Request routing info
zwave.log:2017-04-04 17:33:28.606 [GetRoutingInfoMessageClass] - NODE 18: Got NodeRoutingInfo request.
zwave.log:2017-04-04 17:33:28.606 [GetRoutingInfoMessageClass] - NODE 18: Neighbor nodes: 1 4 6 7 16 19 20 27 28 37 52 53 55 56 58 59 60 62 63 64 65 72 73 75 76
zwave.log:2017-04-04 17:33:28.606 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:28.607 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) COMPLETE
zwave.log:2017-04-04 17:33:28.607 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init transaction completed with response COMPLETE
zwave.log:2017-04-04 17:33:28.607 [ZWaveNodeInitStageAdvancer] - NODE 18: Node advancer - advancing to DELETE_SUC_ROUTES
zwave.log:2017-04-04 17:33:28.607 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveInitializationStateEvent
zwave.log:2017-04-04 17:33:28.607 [ZWaveNodeInitStageAdvancer] - NODE 18: Node advancer is deleting SUC return route.
zwave.log:2017-04-04 17:33:28.607 [SucReturnRouteMessageClass] - NODE 18: Deleting SUC return routes
zwave.log:2017-04-04 17:33:28.607 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@5baba5c8
zwave.log:2017-04-04 17:33:28.607 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:28.608 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 26
zwave.log:2017-04-04 17:33:28.612 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:28.614 [SucReturnRouteMessageClass] - NODE 18: Got DeleteSUCReturnRoute response.
zwave.log:2017-04-04 17:33:28.614 [SucReturnRouteMessageClass] - NODE 18: DeleteSUCReturnRoute command in progress.
zwave.log:2017-04-04 17:33:28.614 [ZWaveTransactionManager   ] - NODE 18: **** Transaction not completed
zwave.log:2017-04-04 17:33:28.615 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute request.
zwave.log:2017-04-04 17:33:28.615 [SucReturnRouteMessageClass] - NODE 18: Assign SUC return routes failed.
zwave.log:2017-04-04 17:33:28.615 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:28.615 [ZWaveTransactionManager   ] - NODE 18: Response processed after 3ms
zwave.log:2017-04-04 17:33:28.615 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:28.615 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4661
zwave.log:2017-04-04 17:33:28.615 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:28.616 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- COMPLETE
zwave.log:2017-04-04 17:33:28.616 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) COMPLETE
zwave.log:2017-04-04 17:33:28.616 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init transaction completed with response COMPLETE
zwave.log:2017-04-04 17:33:28.616 [ZWaveNodeInitStageAdvancer] - NODE 18: Node advancer - advancing to SUC_ROUTE
zwave.log:2017-04-04 17:33:28.616 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveInitializationStateEvent
zwave.log:2017-04-04 17:33:28.616 [ZWaveNodeInitStageAdvancer] - NODE 18: Node advancer is setting SUC route.
zwave.log:2017-04-04 17:33:28.616 [SucReturnRouteMessageClass] - NODE 18: Assigning SUC return route
zwave.log:2017-04-04 17:33:28.616 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:33:28.616 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:28.616 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 26
zwave.log:2017-04-04 17:33:28.618 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:28.620 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:33:28.620 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:33:28.620 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:28.620 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:28.620 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:28.620 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4663
zwave.log:2017-04-04 17:33:28.620 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:28.620 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:28.621 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:29.636 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:33:29.636 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:29.636 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:33:29.637 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:29.638 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:33:29.638 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:33:29.638 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:29.639 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:29.639 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:29.639 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4728
zwave.log:2017-04-04 17:33:29.639 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:29.639 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:29.639 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:32.723 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:33:32.723 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:32.723 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:33:32.723 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:32.725 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:33:32.725 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:33:32.725 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:32.725 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:32.725 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:32.725 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4762
zwave.log:2017-04-04 17:33:32.725 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:32.725 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:32.726 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:39.023 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:33:39.023 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:39.023 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:33:39.023 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:39.025 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:33:39.025 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:33:39.025 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:39.025 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:39.025 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:39.025 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4793
zwave.log:2017-04-04 17:33:39.025 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:39.025 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:39.025 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:52.593 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:33:52.593 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:33:52.593 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:33:52.594 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:33:52.595 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:33:52.595 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:33:52.595 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:33:52.595 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:52.595 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:33:52.595 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4825
zwave.log:2017-04-04 17:33:52.595 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:33:52.596 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:33:52.596 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:34:20.001 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:34:20.001 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:34:20.001 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:34:20.001 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:34:20.003 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:34:20.003 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:34:20.003 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:34:20.003 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:34:20.003 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:34:20.003 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4861
zwave.log:2017-04-04 17:34:20.003 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:34:20.003 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:34:20.003 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:35:14.984 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:35:14.984 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:35:14.984 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:35:14.985 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:35:14.986 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:35:14.986 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:35:14.986 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:35:14.986 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:35:14.986 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:35:14.986 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4894
zwave.log:2017-04-04 17:35:14.986 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:35:14.987 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:35:14.987 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:37:05.646 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:37:05.646 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:37:05.646 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 2
zwave.log:2017-04-04 17:37:14.451 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:37:14.453 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:37:14.453 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:37:14.453 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:37:14.453 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:37:14.453 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:37:14.453 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4933
zwave.log:2017-04-04 17:37:14.453 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:37:14.454 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:37:14.454 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:40:56.658 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:40:56.659 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:40:56.659 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:40:56.659 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:40:56.661 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:40:56.661 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:40:56.661 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:40:56.661 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:40:56.661 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:40:56.661 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 4982
zwave.log:2017-04-04 17:40:56.661 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:40:56.661 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:40:56.661 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:41:44.167 [ZWaveThingHandler         ] - NODE 18: Polling...
zwave.log:2017-04-04 17:41:44.167 [ZWaveThingHandler         ] - NODE 18: Polling deferred until initialisation complete
zwave.log:2017-04-04 17:48:21.948 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 17:48:21.948 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 17:48:21.948 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 17:48:21.948 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 17:48:21.950 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 17:48:21.950 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 17:48:21.950 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 17:48:21.951 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:48:21.951 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 17:48:21.951 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 5048
zwave.log:2017-04-04 17:48:21.951 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 17:48:21.951 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 17:48:21.951 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 18:03:13.339 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 18:03:13.339 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 18:03:13.339 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 18:03:13.339 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 18:03:13.341 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 18:03:13.341 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 18:03:13.341 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 18:03:13.341 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 18:03:13.341 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 18:03:13.341 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 5142
zwave.log:2017-04-04 18:03:13.341 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 18:03:13.341 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 18:03:13.341 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 18:11:44.167 [ZWaveThingHandler         ] - NODE 18: Polling...
zwave.log:2017-04-04 18:11:44.167 [ZWaveThingHandler         ] - NODE 18: Polling deferred until initialisation complete
zwave.log:2017-04-04 18:32:57.038 [ZWaveTransactionManager   ] - NODE 18: sendTransaction org.openhab.binding.zwave.internal.protocol.ZWaveSerialPayload@3f1633bb
zwave.log:2017-04-04 18:32:57.038 [ZWaveTransactionManager   ] - NODE 18: Adding to device queue
zwave.log:2017-04-04 18:32:57.038 [ZWaveTransactionManager   ] - NODE 18: Added to queue - size 0
zwave.log:2017-04-04 18:32:57.038 [ZWaveNode                 ] - NODE 18: listening == true, frequentlyListening == false, awake == false
zwave.log:2017-04-04 18:32:57.040 [SucReturnRouteMessageClass] - NODE 18: Got AssignSucReturnRoute response.
zwave.log:2017-04-04 18:32:57.040 [SucReturnRouteMessageClass] - NODE 18: AssignSucReturnRoute command failed.
zwave.log:2017-04-04 18:32:57.040 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveNetworkEvent
zwave.log:2017-04-04 18:32:57.040 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 18:32:57.040 [ZWaveTransactionManager   ] - NODE 18: **** Transaction completed
zwave.log:2017-04-04 18:32:57.040 [ZWaveTransactionManager   ] - NODE 18: notifyTransactionResponse 5325
zwave.log:2017-04-04 18:32:57.040 [ZWaveThingHandler         ] - NODE 18: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent
zwave.log:2017-04-04 18:32:57.040 [ZWaveTransactionManager   ] - NODE 18: -- To notify -- TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 18:32:57.041 [ZWaveNodeInitStageAdvancer] - NODE 18: Node Init response (0) TIMEOUT_WAITING_FOR_CONTROLLER
zwave.log:2017-04-04 18:41:44.167 [ZWaveThingHandler         ] - NODE 18: Polling...
zwave.log:2017-04-04 18:41:44.167 [ZWaveThingHandler         ] - NODE 18: Polling deferred until initialisation complete

So:

Number    Basement_Tstat_HeatSetPoint         "Basement Heat Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_setpoint_heating, config_scale=1"}
Number    Basement_Tstat_CoolSetPoint         "Basement Cool Setpoint [%.1f °F]"                      <temperature>   (Tstat10)                               {channel="zwave:device:67cd13f9:node4:thermostat_setpoint_cooling, config_scale=1"}
Number    Basement_Tstat_Temperature          "Basement Temperature [%.1f °F]"                        <temperature>   (Tstat10_Chart, Room_Temperature)       {channel="zwave:device:67cd13f9:node4:sensor_temperature, config_scale=1"}

Correct?

Is that related to HANDLER_MISSING_ERROR?

zwave:device:controller:node27 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node37 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node56 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node52 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node57 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node58 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node59 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node53 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node60 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node64 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node62 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node65 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)
zwave:device:controller:node63 (Type=Thing, Status=UNINITIALIZED (HANDLER_MISSING_ERROR), Label=Unknown Device, Bridge=zwave:serial_zstick:controller)