"#6 Invalid credentials" when using the Heos binding 2.5.5


I’m using the Heos binding in version 2.5.5 with an openHAB Windows running on 2.5.6.

While intially the binding discovered my bridges and players and everything was working I’m not just receiving the error message “#6 Invalid credentials” from the bridge. Of course I double-checked the credentials, also tried to delete and re-add the bridge. I also deleted the bridge and added another new bridge (from a different speaker). While it initally says that the credentials have not been set, which is correct on the new bridge, as soon as I provide the credentials it falls back to “#6 Invalid credentials”.

I’m seeing the same. Did you resolve this? I anticipate it’s caused by special characters in the password that aren’t playing ball with the binding requests

1 Like

I’m seeing this too, with an OH3 setup.

(But my existing OH2.5.9 setup is working fine)

Sorry for the late reply, yes I also changed the password and remove the special characters. That worked.


@MDAR I completely missed this message, it is interesting to see that it works for the 2.5 branch but not for the 3 version. Because I fixed in 2.5.6, see also the linked issue.

1 Like

Confirm I have the same behaviour in OH3 with special characters in the password

1 Like

Confirm I have the same behaviour in OH3 with special characters in the password

Hi, I have the same issue with special characters in the password. I’m on OH 3.3.0.

I think the issue comes from the URL encoding in the Heos binding (@ is already not encoded):

Reading the Heos CLI specification makes it a bit unclear to me if only ‘%’, ‘=’ and ‘&’ needs to be URL encoded, or all special characters needs encoding…

I will remove my special char in my password, as a work-around :slight_smile:

Best regards

Openhab 3.4.2 - same issue still, flags wrong credential when password contains a “!” - shouldnt this be fixed by now?

Bump! Heos password requires special charter. When i do want to change the password on the site i do get mandatory restrictions error.