Add zigbee2mqtt devices in the UI


I installed zigbee2mqtt using this tutorial: Running Zigbee2MQTT |

It’s working fine, but I don’t know how to add a new device (thing) to my openhab 3 UI.

I reset my zigbee device and it was found my the mqtt broker:

Successfully interviewd '0x842e.....79e1' device has successfully been paired.

Whnn I turn the Switch ON/OFF, I see the values in the topic (zigbee2mqtt/0x842e.....79e1).

But how can I configure the thing in my Openhab UI?
I configured all my things with the UI and I don’t want to configure the MQTT things with an config file.
My MQTT Broker is up and running (ONLINE in the thing overview).

BTW: How can I change to topic name to a more readable name instead of zigbee2mqtt/0x842e.....79e1 ?!


Use the friendly_name parameter in zigbee2mqtt.

You could try following this tutorial, adjusting your topics to suite.

This ist cuttently how it works for me:

Great, so it’s all working?

Update: now, yea

Battery is working because this is readonly but a Switch is not working.

A Switch works a little bit different:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.