Adding Parameters to Aeotec Nano Dimmer

I think it may help due to the new association options.

Here is the xml file generated by the binding, but it doesn’t contain any information relating to the new parameters.
network_c3f37c26__node_5.xml (24.8 KB)

OK, I have started on the database item. What version is the new firmware? 2.04?
The old was 2.03 according to the document.

@kendaop I have been able to make an entry for the new firmware but we cannot find the information needed to add the new configuration parameters.
The upgrade document just lists their ID numbers & description. We have no information on the values for the different options (& their description) or the size of the configuration parameters. If needed, we can usually guess size from the minimum & maximum option values.
The user & engineering documents we could find online have not been updated for the new firmware. If you are able to find us the information, we can add it to our database.

I found some more config information, but still incomplete, from another open source project. I am working to get that added to our new entry.

A little rough, but just submitted the entry for review.

  1. Reviewed
  2. Published to Githib
  3. Snapshot Jar built
  4. Upgrade the binding. I recommend the install script.
    Zigbee and Z-Wave manual install script

Sorry for the delay. It appears that the firmware version is 2.03. That’s the version number indicated by Aeotec’s upgrade executable, and the version reported by the Zwave PC Controller app. But you’re right, they seem to indicate on their upgrade page that they just updated FROM 2.03. I’m wondering if I don’t actually have the latest version of the firmware.

According to

you have firmware version 1.2


1 Like

Do they need to delete & re-add the Thing to rebuild the xml after a firmware upgrade so they cam export it for us?

Deleting and readding the Thing does not rebuild the xml file.
Reinitialization rebuilds the xml file.

Sorry, no idea. As openHAB does not support upgrading firmware versions (it is on the to-do list, though, but will take a while) I have no experience what to do after a firmware upgrade :sunglasses:

1 Like

When does “reinitialization” happen? Are you referring to reinitialization of the binding, OH2, or the zwave device?

I’m running OH2 in a Docker container with my config stuff mounted into it, so it would be a piece of cake for me to create a new container, which would essentially provide me with a fresh install of OH2, if that’s what it takes.

Either when the XML file for the device is not found (eg if you delete it), or if you click on the Reinitialise option in the configuration.

The XML I refer to is in the {userdata}/zwave folder.

1 Like

Ok, I reinitialized the device, and here is the new xml file.
network_c3f37c26__node_5.xml (26.2 KB)

I tried running that upgrade script, but it broke my zwave binding installation. I managed to re-install the stable version of the binding through PaperUI, but I’d like to attempt manually updating it. I couldn’t find any thorough instructions on how to do that, though.

I’ve grabbed the snapshot of the jar file and placed it in my addons directory, but I can’t figure out how to actually install it. Any ideas?

I ran that script on 2.5M1 successfully and multiple people used it with 2.4.
If you uninstall the binding, I think OH will automatically load any addons in the folder. I believe the newer zwave binding needs another one too, though.
The new entry will not be available until the new binding has been released anyway.
The xml now shows application version 2.3 so I will update the database with that.

Updated my item with your xml.

  1. Item gets reviewed
  2. Binding gets pushed to Github
  3. jar is made as part of OH snapshot.

The updated binding will then be available with the newest item but not before all the previous steps.

It’s here in the forum about 100 times :grinning:
Uninstall the current binding through a GUI
Download the latest zwave snapshot binding and place it in your addons folder
That’s it.
If you encounter problems:
restart openHAB
clear the cache and tmp folder
verify through Karaf the actual binding version:
bundle:list | grep -i ZWave

1 Like

Please post your issue in GitHub or the topic for the script.

Hmmm… you must have not read the instructions for the script, which gives details on how to perform each step manually.

1 Like

They did not read the process I stated twice here either.
I doubt the latest binding had the new entry because Chris only periodically republishes the binding. Not every snapshot has an updated binding.

I had seen several instances of people suggesting adding the jar file to the addons directory, but I didn’t realize those were the official installation/upgrade instructions. In that case, per my comment above, this didn’t work for me. Nothing happened.

Zwave wasn’t returned in the bundle:list command at all. I hadn’t seen the cache and tmp folder suggestion before, so I’ll try that and see if it does anything.

I’ll see if I can dig up the logs again. I know it was an issue that’s been reported before. Something about a 2-minute timeout.

Actually, I had read those instructions as well, but they didn’t work for me, which is why I was seeking out instructions on how to update the binding manually.