Aeon Labs Gen5 Z-stick RPI2, RGB Bulb and Switch config

Dear community, I’d love some help as i’m stuck. I’ve been scouring over and over but I cant make any progress. I am not sure which Z-wave devices are paired to my Z-Stick so I cant write the necessary binding ID to them. I got really hopelessly stuck trying to install openzwave control panel because I couldnt figure out how to install the open z-wave library using subversion and configuring it)

I currently own an LED bulb from Aeon labs (the RGB one) and a TZ68 on/off plug. The Pi has an Aeon Labs 5th Gen z-stick connected.

My sitemap works and generates the web page but nothing happens when I toggle the switch. I guess I need to know which ID is which of my z-wave devices (that “I think” ) i have paired.

The guide says you can “To find out your devices nodeIds either look at the startup log of openhab” but not sure how and where to see this. Is this what appears in terminal when I type “sh” in terminal? am I scouring for something in there that will tell me?

. Fresh install of debian jesse: sept 2015
. pi:raspberry has ownership of /opt/openhab (where I installed)
. SSH on
. made a SMB share to put all the files in the configurations folder

Must also note I am not good at using Linux CLI, I am just doing what I can from reading up guides. But I guess thats why this is in the beginners section! :smile:

(openhab.cfg) - renamed from (openhab_default).cfg (I think ttyAMA0 is right? see below for lsusb)

Z-Wave Binding

pi@raspberrypi ~ $ lsusb
Bus 001 Device 006: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 005: ID 0658:0200 Sigma Designs, Inc.
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


sitemap demo label=“My House”
Frame {
Group item=Bedroom label=“Bedroom” icon=“bedroom”


Group Bedroom
Group Lights

Switch ZwaveDevice “My Cool Device!” (Bedroom) { zwave=“1:command=BASIC” }

This is what the terminal says when I switch the switch in the browser:

[INFO ] [runtime.busevents             ] - ZwaveDevice received command ON
2015-10-25 09:40:46.793 [DEBUG] [.z.internal.ZWaveActiveBinding] - internalReceiveCommand Called, But Not Properly Configure yet, returning.

2015-10-25 09:41:44.267 [INFO ] [runtime.busevents             ] - ZwaveDevice received command OFF
2015-10-25 09:41:44.268 [DEBUG] [.z.internal.ZWaveActiveBinding] - internalReceiveCommand Called, But Not Properly Configure yet, returning.

I recommend habmin for including/excluding z-wave devices.
“zwave=1” mens zwave id 1 and is usually (if not always) the controller itself.

1 Like

thanks for the tip, have now followed a guide and installed habmin, currently looking through the web interface trying to figure out where to find new z wave devices that can be added to items


I’m not sure I have the z-stick connected properly or either the 2 z-wave devices are not paired or dev/tty/AMA0 is not the right port

Under Bindings in Habmin I have Zwave binding 1.7.1 and Zwave binding…

Neither one when selected allow me to see any “devices” or Network. When I reload properties nothing shows up.

The USB Z-wave dongle is flashing, Blue, Orange, Red in succession. I have both the plug switch on and the light bulb on.

Ive tried installing Aeon Labs IMA tool on my windows machine and it is showing up 2 Node IDs.
001 Static Controller Listening is True
002 Multilevel Switch Listening is True

you have to incude the zwave devices in habmin to make them appear there. If they are included directly via the controller “externally” they won’t show up, since habmin isn’t aware of them.

Try excluding the devices from the controller and reinclude it via the habmin interface.

1 Like

Oh I think I get what you mean, so I should exclude them then try to re-include but not using the button on the dongle (use habmin to do it… ill try now)

EDIT: Did this…

When I Press “Include” within Habmin - it says “Error sending action to the server!”

You should change this to :

alternatively (if that doesn’t work):
zwave:port=/dev/ttyACM0 (this is what I use, I have the same USB stick as you)

edit: and of course, restart openhab :wink:

No - that’s not correct. HABmin (or more correctly, the binding) reads the device list from the controller, so you can include using other software, or the button on the Aeon stick and HABmin will see the devices.

1 Like

oh I stand corrected :slight_smile:

################################ Z-Wave  Binding ######################################
# The Z-Wave controller port. Valid values are e.g. COM1 for Windows and /dev/ttyS0 or
# /dev/ttyUSB0 for Linux

Trying this one now, manually setting in openhab.cfg then cd in to /opt/openhab/ then sh

Fingers crossed…

Same error in HABmin “Error sending action to the server!” - but Log shows below when I press it too -
2015-10-25 14:07:35.622 [DEBUG] [] - security is disabled - processing aborted!

I will now try:


Edit: Same error in the log. Every time I try to include or exlude from HABmin on 1.71 or 1.8… It says error sending action, the log shows that same "security is disabled - processing aborted! message.

I am pretty sure of the numbers now for the device ID’s as I got this with the IMA tool from Aeon Labs

FINALLY!!! I win :smiley:
zwave:port = /dev/ttyACM0
Group Bedroom

Switch		ZwaveDevice1	"My Cool Device! 1" 	<switch> (Bedroom)   { zwave="5" }



sitemap demo label="My House"
Frame {
Group item=Bedroom label="Bedroom" icon="bedroom"


Now i’m off to see if HABmin is working - It was and it is! Thankyou so much guys.

Now I have to read up on the binding for this RGB bulb to use it properly (its currently just a switch) but I think ill post that elsewhere as its a different issue.

1 Like

Color currently NOT supported for zwave devices. Anticipated for OH2, but not yet available.
@chris has answered this repeatedly.

Did you get to post the items for the RGBW bulb?

This post has provided me with the single best understanding of how the items/sitemap and z-wave interact. Thanks for posting the detail.

1 Like

Thank you for your information.
However, I really have no idea how to edit configuration files or habmin to include new zwave device.

As I use aeon zstick s2 as a controller, I plug it into USB port, I can see its status online in paper UI . I can see a “node 1/thing name:zwave serial controller” in zwave network viewer.

Actually I also have a switch binary which is also from aeon lab.
I am trying to use the controller to control this switch binary. But I really have no idea how to do it.

Can you shed some light how can I include zwave device in habmin or in any other way?