Aeon Z-wave stick s2 on OSX

Im trying to add an Aeon Z-wave stick to openhab and I keep getting this message when running openhab:

2015-08-29 13:19:48.907 [INFO ] [.z.internal.ZWaveActiveBinding] - ZWave 'updated' with null config

I added the z-wave binding to the “addons” folder, added this to the demo.items:

Switch Z_socket1 "Living Room" (Lights) {zwave="2:command=SWITCH_BINARY" 

Lastly, i tried adding different ports on the z-wave portion of the openhab.cfg file.

what else should i be doing?

1 Like

Can you post the configuration you’re using? This error means that the configuration is probably not correct.

what host computer are you using ? The z-sticks show up as different devices on Windows, OSX and Raspbian so your openhab.cfg has to reflect that.

Thanks for responding! I don’t have the .cfg file on had at the moment, but I tried running it on two different OSs, raspbian(on a raspberry pi 2, and a MacBook running OSX

For the raspberry, in the openhab.cfg file, under z-wave binding, I put “/dev/ttyUSB0”

So it reads:

On my MacBook, under the .cfg file, I used “PL2203-0000103D” as the z-wave port

While this doesn’t look right to me (it’s certainly nothing like I use on my Macbook) this isn’t the problem. If you’d specified the wrong port, then you’d get a completely different error. The error that you are seeing is because the ‘system’ is passing a null into the bindings configuration method, so it probably means that the system isn’t reading the config file correctly.

Is this the only line you have in your config file for the zwave binding?

Yes, that is the only line i have under zwave in the config file

I’ve been searching online to see if there is a way to find the correct port number that the stick is using in OS X. Do you know how to do this? I found something online that said input “ls dev/tty” in Terminal, but that didn’t help.


Does this mean that you had the same error on both systems? I guess you copied over the configuration? I’d suspect that there’s an error in your openhab.cfg file, but it’s unclear what…

@teichsta any thoughts on why the updated method would be called with a null dictionary? The check is right at the beginning of the method as below…

public void updated(Dictionary<String, ?> config) throws ConfigurationException {
    if (config == null) {"ZWave 'updated' with null config");

On my mac, here is my line item…


It should be ls dev/tty*. The do this with the dongle plugged in, and then out, and look to see what changes…

This isn’t the problem though - you can type whatever you like into the configuration and it should be passed to the binding. If the port is then wrong, you get a “port not found” error (or something similar) - not the error that you currently get.


ls /dev/tty*

(the initial forward slash is important)

I know you know this, I’m flagging it up for Ryan’s benefit. :smile:

Ryan: on my Mac Mini the zwave entries in my openhab.cfg are:


and I am using the same Aeon stick as you.

i am not quite sure about the particular circumstances but you should handle null configs accordingly. Most of the bindings do check on config == null and return fast (without logging these cases)

Ok - that’s basically what the zwave binding does, but it logs it (and that’s the error I’m trying to work out). So you’re saying then that this is normal and nothing to worry about? I’ve just never seen it before and was wondering what would cause the system to send a null dictionary…

yes :slight_smile:

However using MangedServices is somewhat “old school” and has been superseded by using another Declarative Service mechanism (don’t know the name by now). See the actual binding archetype for more details on that.

So, on my Mac, I used the line item that Kevin & Jon posted:


And something different came up! I guess this is a good thing, right?
2015-08-30 13:07:07.403 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2015-08-30 13:07:14.230 [INFO ] [runtime.busevents ] - Z_socket1 state updated to ON

BTW, i’m using all the demo files, and editing in openhab designer.

In the items directory, I added this at the bottom…

Switch Z_socket1 “Living Room” (Lights) {zwave=“2:command=SWITCH_BINARY”}

Then, I assume, all I have to do is run openhab runtime, press the button on the z-wave stick, bring the stick close to the z-wave outlet, press the button on the outlet, wait for the stick’s light to return to solid(from blinking), and plug the stick into a USB slot on my mac. Then, in openhab designer, navigate to the website, and click on the switch and that should turn on my appliance, right?

1 Like

I’ve found that openHAB can’t recover once the stick has been removed. The zwave thread shuts down and doesn’t restart. You’ll have to restart openHAB once the stick has been plugged in again.

Hi ryanradoc,

As I use same aeon z-wave stick s2 as you, can I ask some quick questions related?

As in this post, I only see your switch device in demo.items,
Switch Z_socket1 “Living Room” (Lights) {zwave=“2:command=SWITCH_BINARY”

Do you also a line for the controller in demo.items?

For me I plug my aeon zstick S2 to USB port as a controller, and I am trying to connect controller to my zwave switch. That being said, my zwave switch is not connected to my USB port.
I assume your case is similar to me.
So in this case, should I still put a line for zwave switch in demo.items?

If not, any idea how should I use my controller to include that zwave switch?

It seems there is no a channel related to inclusion/removal new zwave device to zwave network within the _controller_serial.xml which include a id called “serial_zstick”. I assume serial_zstick is for aeon zstick s2.
Do I have some mistake here?

Thank you very much.