Aeotec Wallmote Quad - Defective or am I not setting up correct?

I have an Aeotec Wallmote Quad (ZW130-A) that am struggling to get working.
When I set PaperUI to discovery for ZWave, it detects 2 unknown devices. All my other ZWave devices are accounted for so not sure why it is detecting 2 new?

I have tried factory resetting the Wallmote several times, and then performing a secure inclusion however it always shows a 2 devices, and the Wallmote doesn’t follow through with what the manual describes with how the inclusion should work:

The blue LED will be on for 2 seconds and then the orange LED will fast blink for 10 minutes

The blue led will blink, then change to a 2 second red and then no display. I have also let it sit for well over 24hrs to complete the inclusion but it does not populate the Thing information.

It seems to be locked/unresponsive also, that pressing the buttons does not cause it to illuminate or chirp.

Any thoughts or suggestions?

OpenHAB version: 2.5.0-SNAPSHOT (#1606) running on ESXI, Debian 9 VM
ZWave controller is an Aeotec ZStick


Since it is a battery operated device, you need it to be close to the controller.
Also enable logging for Z wave and post the logs. It will be helpful.

Good luck

I recall having a similar issue with my zwave configuration at one point, I did an inclusion and then factory reset the device without doing an exclusion.

I recently changed from Win7 to Win10 and can’t recall the software name, but it will load up the associated devices with the Aeotec stick and allow you to remove associations; I think I did a full wipe and had to reassociate everything on my network.

At the very least I would load up the software (recall it being Windows only) and verifying the Aeotec side of things.

Where did you get that from?
Sorry, this is not true. Battery operated devices don’t act as a repeater (because they need to preserve battery life). Apart from that they can be at any place in the meshed zwave network.

If you did a factory reset on that device without excluding it before, this can happen. You can remove those via HABmin, switch to extended settings for that node.

Make sure you are starting secure inclusion via the binding, not via the button on your zwave stick. After starting inclusion process through the binding you have 15 seconds to finish inclusion on your device.

You don’t have to wait, just wake battery operated devices up manually.

I meant the battery operated device needs to be closer to the controller for inclusion purpose.:smiley:

That is a different story … but should also not be needed :grinning:

Thanks everyone for your suggestions and help.

  1. I have removed the Wallmote things from the controller using Habmin.
  2. Using the ZStick, removed the Wallmote from the ZWave network.
  3. Then started discovery using PaperUI.
  • Two devices are discovered.

Redo of 1 and 2.
4. Factory reset the Wallmote.

Redo 1, 2, 3.

  • Two devices are discovered.

Redo 1, 2, 4.

  1. Used Habmin for discovery
  • Two devices are discovered.

Trying to get somewhere, added one of the nodes in PaperUI.

  • Trigger a wakeup of the Wallmote using the button.
    And this is what is also causing me grief, the light indicator for a wakeup doesn’t follow through as to what the instruction description should be:

The LED on WallMote will now rapidly blink its Yellow/Orange LED while it is in its awake state.

It states it will remain like this for 10 minutes unless the button is pressed, but as soon as i release the button while activating wake, it displays no coloured indicator.
I have set logging to TRACE, and what I am seeing for the discovered nodes is it is not awake. Catch 22 as I am trying to make it wake up so the process can complete but it does not seem to be reacting properly to the force wakeup button press.

So really not sure how to proceed at this point. if you happen to recall the software you used I would like to try it. I’ve done some searching and get hits for Openzwave. Could this be it? I may install it on my windows box and see…
@sihui thanks, I’ve tried various ways from how you suggested to remove the nodes from my network, but no luck.

And thanks everyone, any other suggestions would be greatly appreciated, I don’t want the Wallmote to end up being a paperweight! If it is thought best to return/exchange it I can do that too.


Took me a number of google searches, but the final trail led me back to the OH community (go figure) - Looking for Zensys Tools

That software seems to be a pita to obtain now too!

Download an Aeotec firmware update. They use a modified Zensys Tools as their firmware updater.

I too have issues with 2 x Wallmote Quads, just wont display the firmware version or details or item types.

Im having a load of issues. Ive reset them many times…grrrrrr

Im using the latest binding, even when i reset the node, remove using zensys and repair, it doesnt even display in OpenHab. But Zensys sees it…

Thanks and @5iver.
I connected the ZStick to my Windows machine and downloaded a firmware update from Aeotec. Removing the nodes goes through process, but the 2 nodes discovered by PaperUI never actually get removed. If I add a node with the tool it creates a new node (now totaling one device, three nodes) and connects no problem! The Wallmote appears to function properly, following how it should react to a wakeup, communicates with the software. The button presses work when connected as this new node, and can see them occurring in the log.
But just like @dastrix80, if I remove all the nodes, perform a factory reset, reconnect the ZStick to OpenHAB and run a discovery, PaperUI or Habmin, it is not discovered with a new node. The two nodes I can’t get rid of keep reappearing and the Wallmote remains unusable, no item types, details, etc…
(I am now running the latest snapshot -Build#1607 as I restored an older Debian VM snapshot and did a clean install)


So a small success. Installed the Zensys tool and was able to finally remove the two nodes that kept showing up!
Now back to trying to get this Wallmote to be detected with PaperUI or Habmin. Haven’t had any luck yet…

dastrix80 if you make any progress let me know, I’ll keep you posted too if I get this thing working!


I would suggest going with Habmin as you can kick off the inclusion from there vs having to disconnect the USB device (and I prefer to be lazy). However since you are on a recent snapshot, I noticed with a Leviton zwave outlet it took an abnormal amount of time to have the discovery show up (even though the outlet wouldn’t go back to inclusion) after dinner I saw it was discovered.
There is a known CPU issue with newer snapshots, so just keep that in mind with your testing of this zwave inclusion.

Thanks for the advice, I’ll take another try at it tomorrow.
And I appreciate your help with suggesting the Zensys tool, I was at a complete loss with what to do next…


I wont be doing the WallMotes for a few weeks as they are at another site that I wont be visiting for a while.

I was able to get the WallMote Quade to be included and is partially working now.
I reverted back to a build I had an ESXI snapshot of (with OH snapshot#1555).
Could not get it to be fully included with Snapshots 1606 or newer.
I don’t see any “Swipe” functionality or Battery reporting with this install.

Looks like there may an OH2.5-M2 release coming up, so I’ll do an update then…

Thanks all for your help.

I am having some issues with my Quad Wallmote too. I can add it to OpenHAB just fine using the Paper UI and it initially works. I can press any of the 4 buttons and it triggers a rule that I set up.

But after several hours, the unit stops sending anything to OpenHAB. I have enabled debug logging for the zwave binding and I see no logs for that unit. To be clear, when I press a button on the unit, it lights up properly but thats it.

I have deleted it and readded it. I have factory reset it and readded it and the above process repeats itself…it works for a few hours then stops. Any one got any ideas or an alternative to the quad Wallmote that works better?

I ended up reverting back to OH2.5M1 as a fresh install.
Per my post above it worked well for a bit, but I started having problems again.
After installing 2.5M1 I upgraded the zwave binding to a version from a few weeks ago (not at home now so can’t check it).
Since doing this, the Wallmote has been rock solid and never misses a press. I haven’t figured out the swipe function though…


I managed to resolve my issue and am posting how I did it here in case it helps anyone reading this:

  1. Deleted the Things in Openhab.
  2. Deleted the .XML it created in usershare/zwave/ (not sure if this step is necessary)
  3. Rebooted OpenHAB (not sure if this step is necessary)
  4. Factory reset the Wallmote Quad by holding the action button down for about 20 seconds. Hold the button down and you’ll see a red light flash slow, then fast, then it’ll turn green, then it’ll start slowly changing between colors. Then release (you may be able to release on the green)
  5. Securely include the item to Zwave/OpenHAB by double clicking the action button on the Wallmote. I believe the LED should fasho blue. Then click the action button on your controller. It should securely include.
  6. After this, I personally have to plug my controller back in and reboot my openhab instance.
  7. Add the thing through the HABmin panel securely. You can install HABmin through PaperUI on interfaces and you can access it from your openhab homepage. Click the configuration tab in HABmin and then the Things subcategory. Then up at the top leftish of the page you’ll see a magnifying glass with a plus sign in it. Click that, click Zwave and add the things from the top right of the page.
    8 Done!