AEOTEC Z-Wave ZWA021-C still problem with "unknown device" in OH 3 (binding z-wave 3.0.1)

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage RPI 3
    • OS: what OS is used and which version (openhab image)
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 3
  • Issue of the topic: My OpenHab still see my AEOTEC ZWA021-C still as uknown devices. I check previous threads about this issue and it “should” be solved in OH 3 but for SPIRIT . Iam not sure if it is really same for AEOTEC. Can you help me ?

Other threads also say since it is a barrety operated device it needs to be woken up many times until fully discovered. If there is no xml file for this device in the zwave directory of userdata, it was not completely discovered. If there is an xml file there, perhaps it is truly an unknown device.

yes in directory /var/lib/openhab/zwave/ are newly created xml files . In xml file is writen:

  <associationGroups class="concurrent-hash-map"/>
  <endpoints class="concurrent-hash-map">

Does it means, i need to remove battery add again, try to let it search again ?
Or if I understand well, when xml file is created (like mine) There is problem that this device is not yet in the database ? What is the process or easy way how to get it in ?

Please post the xml file. the forum software made a mess of your copy / paste.

:frowning: new users cannot upload a files… sorry for that… can I share with you different way ?

I edited the post so it’s readable.

The device needs discovering first - I guess this is a battery device and if so it needs waking up so it can be fully discovered.

1 Like

network_e130e53a__node_2.xml (3.1 KB)

You are right, this is battery radiator thermostat, but are we speaking about minutes, hours or days ? Becuse, my openhab system is started several days, and I add the devices already few days ago …I don’t think it should take so much time

Agreed. This is an indication of that. These are invalid values vof manufacturer, device id & device type.

You probably need to push the button - so it depends on how quickly you do this. :slight_smile:

I’ve had to delete battery devices from OH but not from the controller. Should be able to add the thing again after that.

This worked for me recently for some door sensors. I did have to repeat it an extra time for one. Might be worth a shot.

1 Like

I have sometimes had to wake up battery devices 20 times. Usually it is quicker than that though. I do not own any battery operated Aeotec devices.

What is strange, when I use my USB AEOTEC controler in PC with tool for configuring, I can see immediatelly all the details about the Thermostat devices. If it will not discover it during the night, i will reset my devices tomorrow and start from the begining …

No need to reset the devices. Just delete the Thing from OH and scan to discover again, waking up the device.

So after 10 hours, nothing changed, i again removed the device in OH again found, but still as unknown device… It really looks that thermostat device doesn’t sent all info about “manufacturer…and so on…”
Xml files are recreated but without all info…

That would indicate a defective device is that is true.Many times battery operated devices are tricky to get fully discovered even though OH relies on a mandatory part of the specification. Battery devices eventually fully respond but the vendor does not necessarily make it easy.

Without the identifying information the binding cannot use its database information to know how to respond and manage the device.

What about if I put the manufacturer code and device type manually into the xml file? Do we know exact codes for this thermostat device ?

These are FLiRS device so will wake when beamed so no need to wake.

I have 6 of these running on OH3 with no issues and all included and setup with no issue.

Do you have any other issues with your network?

Are you using PC and stick closer to the device than your openHAB. If you are you might have introduced some bad routes that are not possible so openHAB and the device can not communicate.

First i used aeotec zwavecontroler and connect all my 3 devices (2 aeotec thermostat valve , and 1 Qubino Flush 1D Relay) than, i putted into the RPi3 with OH3 and i can see correctly my USB controler, Qubino, but for these 2 therstat valve i don’t see the details… Maybe iam wrong with configuration of network, but i suppose there is not so many things to make wrong, just add, push button on valve and it pairs.