Aeotec ZW141-A Zwave device

Hi, I bought the product “Aeotec Nano Shutter Z-wave Plus S2” with the specified part number ZW141-A. I tried to include into my z-wave network and within few days it only display as an unknown device. This device appears in the z wave database but as OH advice, there could be some set of references that may need to be update or include.

How can I accomplish this task please?

Thanks for your help.

Please provide thing id, device id and firmware version (from the Properties page or your xml file in /userdata/zwave folder)

I’ll leave here both OH properties and XML file.

zwave_beaming	true
zwave_class_basic	BASIC_TYPE_ROUTING_SLAVE
zwave_deviceid	141
zwave_devicetype	259
zwave_frequent	false
zwave_lastheal	2019-06-19T07:28:56Z
zwave_listening	true
zwave_manufacturer	134
zwave_neighbours	1
zwave_nodeid	3
zwave_plus_devicetype	NODE_TYPE_ZWAVEPLUS_NODE
zwave_plus_roletype	ROLE_TYPE_SLAVE_ALWAYS_ON
zwave_routing	true
zwave_secure	false
zwave_version	2.2

  <associationGroups class="concurrent-hash-map"/>
  <endpoints class="concurrent-hash-map">

I’ve already create an account in cd-Jackson, but I’m not sure if I have to request a ticket to modify the database device, because I’m not sure if I’m wrong but It’s already register the same type and ID.

I aprecciate your help.


No, 0003:008D is registered, your device has 0103:008D, so I’ve added it.


You need to wait a couple of days until the database changes got merged into the binding, then you need to upgrade to the latest 2.5 zwave snapshot binding.

That was fast! I will upgrade it.

Thanks for your help.

1 Like

Hi there, I didn’t tried last week if this device can be recognize by OH. But yesterday I tried it by upgrading it to the latest snapshot. So actually is running 2.5.0~S1623-1 (Build #1623). And the procedures that I’ve take is to uninstall z wave binding and re installing it with the latest version. I’ve already try installing it through the paper UI and also manually with vs code but it’s still recognizing as an unknown device. Maybe I forget to take any additional step?

In the OH logviewer I’m still getting the same message since this device wasn’t update in the zwave database.

2019-06-26 10:28:31.957 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery could not resolve to a thingType! 0086:0103:008D::2.2

I will appreciate your help!

It’s in there:

Uninstall the zwave binding through PaperUI, download the latest zwave 2.5 snapshot binding, drop it into your addons folder.

You may need to install two dependencies manually: xstream and the serial driver.

I uninstall zwave binding through PaperUI and install zwave 2.5 snapshot binding and xstream into the addon folder. serial binding through the addon.cfg. but still not working.

I verified through the karaf console if zwave and the xstream is active and I got this.

bundle:list -s | grep zwave
278 │ Active │ 80 │ │ org.openhab.binding.zwave

list -s | grep xstream
66 │ Active │ 80 │ │ org.apache.servicemix.bundles.xstream

I removed the device many times and still unknown device. The device recognition should be quickly as it suggest OH if this is main power.

You can’t mix, either install your bindings through PaperUI and addons folder or through addons cfg and addons folder.

Actually all this time I had my bindings through addon.cfg. Previously just tried once to see if it works with Paper UI but it didn’t. So I installed again all my bindings through addon.cfg, the xstream file and the latest zwave snapshot version are in the addon folder. I will be trying and looking around if theres anything I missed or doing wrong. Thanks for your time and help!.

This is already a good start.
Make sure you have something like this in your log:

27-Jun-2019 17:44:25.107 [INFO ] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
27-Jun-2019 17:44:25.212 [INFO ] [g.openhab.binding.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
27-Jun-2019 17:44:25.483 [INFO ] [ab.binding.zwave.internal.protocol.ZWaveController] - Starting ZWave controller
27-Jun-2019 17:44:25.483 [INFO ] [ab.binding.zwave.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

If not, just restart the binding:
bundle:restart 278