Alexa cannot find any devices anymore with the HueEmulation Service

Hi guys,

Since my upgrade yesterday Alexa cannot control my published devices with HueEmulation anymore. I tried uninstalling and reinstalling it, checked my *.item files of the tags are correct and case sensitive however I cannot get it working :frowning:

Alexa cannot find my devices anymore.

Example Item:

Switch Outlet12 “Christmas Tree” (Outlets) [“Switchable”] { channel=“tplinksmarthome:hs100:A2713C:switch” }

When I look at the URL’s I get the following:

[{“error”:{“address”:"/",“description”:“GET not allowed for this resource”,“type”:4}}]

[{“error”:{“address”:"/discovery.xml",“description”:“Not Authorized”,“type”:1}}]

[{“error”:{“address”:"/testuser/lights",“description”:“Not Authorized”,“type”:1}}]

When I reinstalled the binding the only lines in the log I got were:

2018-12-28 11:43:19.102 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled ‘openhab-misc-hueemulation’
2018-12-28 11:43:19.103 [thome.event.ExtensionEvent] - Extension ‘misc-hueemulation’ has been uninstalled.
2018-12-28 11:44:04.233 [INFO ] [eemulation.internal.ConfigManagement] - Hue Emulation pairing disabled. Service available under /api
2018-12-28 11:44:04.248 [thome.event.ExtensionEvent] - Extension ‘misc-hueemulation’ has been installed.
<root xmlns=“urn:schemas-upnp-org:device-1-0”>
<friendlyName>openHAB Hue Emulation (</friendlyName>
<manufacturer>Royal Philips Electronics</manufacturer>
<modelDescription>Philips hue compatible Personal Wireless Lighting</modelDescription>
<modelName>Philips hue bridge 2015</modelName>

Can anyone help?

Tag [“Switchable”] is not supported anymore, you have to use tag [ “Lighting” ] instead.

See also here: (not so easy to find… :wink: :wink: )

I will try to change it, but the documentation clearly states:

The following default tags are setup:

  • Switchable”: Item will be exposed as an OSRAM SMART+ Plug
  • “Lighting”: Item will be exposed as a dimmable white bulb
  • “ColorLighting”: Item will be exposed as a color bulb

Also “Switchable” is a default tag in the configuration of the binding in PaperUI?

Switch item tags
The HUE emulation can either publish Switch items if this is set to an empty string or filter items by tags. You can supply multiple tags by separating them with a comma.

[“Switchable”] works for some people, but not others. I was waiting for some additional testing, in case a solution could be found, before updating the documentation with using the [“Lighting”] tag as a workaround.

Ok, so for now I configured in PaperUI that the tags for Switchable items are “SwitchableNotWorking” and the tags for Lighting items are “Lighting,Switchable”.
Then Alexa still could not find any devices. So I deleted all devices from Alexa via the Alexa Website and told Alexa to find new devices. They are all back now in the Smart Home List.

Thanks for the help so far, so it is my understanding that this is a BUG and it’s not like Switchable items are not supported anymore?
It seems still most of the items (power plugs) are not reacting with Alexa, I will try some things and report back…

Same problem here… still not working either with Lighting or Switchable. :frowning:

Please read the breaking changes before updating. It clearly says to remove all devices in Alexa and perform a rediscovery.

Switchables were exposed as lights before the update. That was fixed by exposing them as as Osram ZigBee plugs now. Unfortunately Amazon has a very mixed support for this. Even more unfortunate it worked for me as the developer but for most people it doesn’t. If most firmwares do not support this, I will change the tag for lights to include Switchables.


What list of breaking changes are you referring to as this list from the release announcement does not show anything about removing all Alexa Devices?


If you had followed this sequence, you maybe could have seen it:

Step1 (=releasenotes of openHAB 2.4.0)

there goto “hueemulation” and then click on Enhancements 4216

Step2 (=Enhancements 4216)

and there goto Fixes #3754 or #3753

Step3 (=Fixes #3754)
Step4 (=Fixes #3753)

There you can read the following:

Steps to Reproduce (for Bugs)

  1. Remove all [“Lighting”] tags from items.
  2. Add a couple of [“Switchable”] tags to items.
  3. Delete all devices from Alexa via webinterface or via Alexa app.
  4. Start a scan for devices via or voice command.
  5. Devices with the above described names show up, although they are not tagged.

Steps to Reproduce (for Bugs)

  1. Disable pairing mode in Hue Emulation.
  2. Delete all devices from Alexa via webinterface or via Alexa app.
  3. Start a re-scan for devices via or voice command.
  4. Newly discovered devices via Hue Emulation show up.

If you never had one of these bugs, then you @KidSquid are right!

And the actual problem is still an “open issue” see here #4293

My fault. It is not in that file, but only in the breaking changes note that is shown while upgrading.

1 Like

I just upgraded from 2.3 to 2.4 and all of my previous working devices now respond with…

“DEVICE XXXX isn’t responding…please check it’s power supply or network connection”

Is this the same issue folks are having in this thread or is this something different?

I have not removed any devices from Alexa or made any changes to the settings.



And you have not read the breaking changes ^^.
The storage system has changed and the hue emulation binding reassigned a new ID to each item. Alexa will use the old item ID (and invalid access key on top). You need to rediscover devices.

Ok…must have missed that. my apologies…

Couple of questions before I blow everything to hell.

  1. I deleted one item from Alexa and tried to run discovery…she was not able to re-discover the device.
  2. I’ve also noticed that discovery mode now turns it’self off - this is new? I used to leave discovery mode on.

My fear is that I’ll leave the house in an unusable status…just want to make sure I can bring back voice control if i need to revert back to 2.3



Yup, the new code tries to mimic a hue bridge to every detail also this specific one. You can extend the timeout to a ridiculous big number though.

That also never worked for me. Make sure you follow the instructions in the troubleshoot section if you are having troubles. But in general, it works, I’m using it myself. You might need to use the Switchable,Lighting for the dimable lights tag configuration though. Most Echos don’t understand the currently exposed Osram Plug+.

Finally upgraded last night and seems I have this too. Have there been any further updates, or will I have to clean up and recreate as per above? Guessing the latter… but living in hope :stuck_out_tongue_winking_eye:

Another storage mechanism is in use now. Clean up and recreate is unfortunately your only option.

Thanks David, I got this working but it has produced 2 problems.

  1. after another reboot (when I already had this working again), it seems Alexa tagged all devices as offline - and I had to rediscover again? I wouldn’t want to be doing this every time I do a maintenance reboot?

  2. it seems the updates mean that if I issue an off command against an off item again, the command gets ignored? My hue binding binds to some dummy switches. One example is ‘tv’ - when I issues a command to switch tv off, it switches a bunch of other devices off too - some of which may have been powers on manually and connected by infrared bindings - so I can’t track state. Is this a known issue? I have tried to automate loads of legacy gear which is stateless - hue emulation WAS my solution before.

The new storage system that I’m using is the json storage. That interface is also used to store Things and Items that are created via Paper UI etc. But unfortunately it resets after every start and non of the core developers has answered my help request yet. See also

I have the exact same issue, I though I am the only one and it is so annoying.
Similar scenario, I have 3 Scenes:

  1. “Home Cinema”: turn on AVR, switch to HDMI1, turn on Projector, turn on PC (WOL)
  2. “Android”: turn on AVR, switch to HDMI2, turn on Projector
  3. “Nintendo”: turn on AVR, switch to HDMI3, turn on Projector

Before the update it was no problem to trigger an Item Scene to ON when it was already ON, the rules fired again, this does not happen anymore after the update.

Why this is an issue:

  1. Someone turns on the scene “Home Cinema”
  2. Someone forgets to turn it off and the projector and AVR turn of automatically after 30min inactivity or someone uses the remote and switches manually -> the state of the scene “Home Cinema” is still ON
  3. Now the status of the item “Home Cinema” in OH is still ON but the devices are actually OFF
  4. In the past I could just say “Turn Home Cinema On” and everything would turn on again, this now does not happen anymore as the status is already ON.

I can also not determine during runtime what scene apparently is currently on as some devices do not report the status back properly

Are you on OH 2.5M1? The OH2.4 release was more or less very unfortunate for the hue emulation service and MQTT binding.