Alexa says sorry when changing Thermostat TargetTemperature

So I have my Alexa controlling my thermostat finally. And the temp can be changed with voice commands. But Alexa thinks that it didn’t work and always says sorry something went wrong…

Anyone got an idea there?

Could you please elaborate a bit more how you connect? Via Cloud service or Hue Emulation? Configs? Etc?

Sorry, I didn’t appreciate that there was more than one way.

I use the Alexa with the openhab skill, and that comes back via the openhab cloud plugin. I have no Hue or anything. The thermostat TargetTemperature does change successfully. But it seems that the Alexa doesn’t like something that comes back in the response (I’m not an Alexa developer, so never looked at the internals of the skill itself)

Config is

Group gMainHallThermostat "Hall Thermostat" (gFF) [ "Thermostat" ]
Number ZWHallwaySensor_SensorTemperature "Hall Temp" <temperature> (gMainHallThermostat) [ "CurrentTemperature" ]
Number MainHall_Target_Temp "Hall Target" <temperature>  (gMainHallThermostat) [ "TargetTemperature" ]
String MainHallThermostatHeatingCoolingMode "Main Hall Heating/Cooling Mode" (gMainHallThermostat) [ "homekit:HeatingCoolingMode" ]

Same here, i use MAX! thermostats. I say in german: “Alexa setze die Wohnzimmertemperatur auf 19 Grad” Alexa replies in german: “Ich weiß nicht, was schief gelaufen ist” but the thermostat changes to the correct temperature. My item-definition is:

Group GROUP_DG_Wohnen_Thermostat "Wohnzimmer" [ "Thermostat" ]
Number DG_Wohnen_Thermostat_SollTemperatur "Solltemperatur Wohnzimmer" (gDatabase, GROUP_DG_Wohnen_Thermostat) [ "TargetTemperature" ]
Number DG_Wohnen_Thermostat_IstTemperatur  "Isttemperatur Wohnzimmer" (gDatabase, gChart, GROUP_DG_Wohnen_Thermostat) [ "CurrentTemperature" ] 
String DG_Wohnen_Thermostat_Modus "Mode" (GROUP_DG_Wohnen_Thermostat) [ "homekit:HeatingCoolingMode" ]


Short answer for anyone else having the same issue is that the thermostat mode HAS to have one of the supported strings associated with it. That’s not spelt put anywhere that I know if.

Supported strings that I know of are ‘OFF’, ‘HEAT’, ‘COOL’

If you’re controlling your heating via rule then using something like


when you turn the heating off, and the matching ‘HEAT’/‘COOL’ settings should do fine.