Alexa Smart Home Skill - No devices found - Solution

myopenhab
echo
alexa
Tags: #<Tag:0x00007fae053deef0> #<Tag:0x00007fae053dd0a0> #<Tag:0x00007fae053dbde0>

(Thomas Moulton) #28

Because it takes more than one try to read and get things right, how can I clean up all the old mistakes I made and use what works?

I currently have

Number HVAC_Temperature "House Temperature [%.1f F]" <temperature> (gHVAC) [ "CurrentTemperature", "Fahrenheit" ] {channel="zwave:device:1608131a9e2:node2:sensor_temperature" }
Number HVAC_HeatSetPoint "House Heating [%.0f F]" <temperature> (gHVAC) [ "CurrentTemperature", "Fahrenheit"] {channel = "zwave:device:1608131a9e2:node2:thermostat_setpoint_heating" }
Number HVAC_CoolSetPoint "House Cooling [%.0f F]" <temperature> (gHVAC) [ "CurrentTemperature", "Fahrenheit"] {channel = "zwave:device:1608131a9e2:node2:thermostat_setpoint_cooling" }

I had been “Deleting items and events” in myopenhab.com and deleting the items in the Alexa app but now have gotten to a point where she tells me I have more than one Thermostat and can’t tell me the House Temp any more.

I do have “item linking” “Simple Mode” OFF

When I ask for the House Temperature she says that a few things share that name, yet I only see “House Temperature” “House Heating” and “House Cooling” in the app

I do now see that all three are listed as “CurrentTemperature” but they do each have unique names
Where is she seeing the duplicates from?

The only 3 items that have Tags are the ones listed above.

what am I missing?

Tom


(Alex) #29

@w2vy

“House Temperature” “House Heating” and “House Cooling” are the labels of your taged items.

You will see them (labels) all as a device in Alexa APP with the corresponding name.

First:
It is not necessary (makes no sense) to tag a “thermostat_setpoint_heating”-item and a “thermostat_setpoint_cooling”-item as [ “CurrentTemperature” ]. Delete both tags from your item file.

Second:

When you label an item “House Temperature”, then you have to ask “Alexa, what is the temperature of ‘House Temperature’?”

You better put your Alexa-Device “House Temperature” in an Alexa-Group e.g. “House”.

Then you have to ask “Alexa, what is the temperature of ‘House’?”


(Thomas Moulton) #30

Ok I have it working now, I even switched to using the Thermostat structure.

Where is the language documented that can be used to access each field?

Target Temperature, Heating/Cooling mode

I may need to use a internal tag for the Target Temp, since my thermostat (CT100) has a heating setpoint register and a cooling setpoint register and have rules update the proper register based on the heating/cooling mode

I live in Florida, so the Heating setpoint is mostly fail safe, the cooling we do change from time to time…


(Alex) #31

@w2vy

Here you can see all utterances:

And here is a complete Openhab Alexa Skill documentation:

https://docs.openhab.org/addons/ios/alexa-skill/readme.html


(Thomas Moulton) #32

That helps, but is might be better if we could have the supported voice commands paired up with example item definitions (with proper tags etc) so we can look in one place.

Maybe added to the Openhab Alexa Skill docs?

Tom


(Thomas Moulton) #33

I am now trying to add my Door sensors and no new device is discovered.

Contact zone1          "Front Door [MAP(contact.map):%s]"  (gContact) ["Lighting"] {alarmdecoder="REL:12,01#contact"}

I first tried the “Switchable” tag

I looked at the rest items and they looked ok

{"link":"https://myopenhab.org/rest/items/zone1","state":"CLOSED","transformedState":"closed","stateDescription":{"pattern":"","readOnly":false,"options":[]},"type":"Contact","name":"zone1","label":"Front Door","tags":["Lighting"],"groupNames":["gContact"]},

Thoughts?

Tom


(Alex) #34

@w2vy

As I written one post above, in first Link you can see all utterances supported in OH2. (see in brackets [supported in OH2]).

In my second Link you can see also some examples, how to configure your items and tags.

And you also should read 1st post here: Link3

That’s all I can do for you. I am neither a maintainer nor do I make the documentation here. Sorry! :slight_smile:


(Alex) #35

Contact is not supported. What do you want Alexa to do or ask?

I guess: “What is the state of Front Door?” This is not supported, neither Alexa Smart Home Skill nor the OH2 skill.


(Thomas Moulton) #36

Yes - more specifically “Alexa is the Garage Door open?”

Since you are not a maintainer, etc I will stop bugging you on this thread…

Seems you do have a decent understanding of the way it works…
Maybe you could become a contributor… :slight_smile:

Tom


(John Doe) #37

I have a lot that look like this, is this ok or must the empty tags completely being removed?

,“tags”:[],“groupNames”:[“FF_Sz”]},


(Alex) #38

Does Alexa find your device(s)? Did you test it with at least one tag, e.g. [ “Switchable” ] ?

If Alexa doesn’t find this [ “Switchable” ] device , then you better should remove your blank tags…


(Garth Bushell) #39

So I can’t get Openhab to work with either Alexa or Google. I have a fairly complex setup and I believe I have tagged this things I needed and they all have labels but I maybe doing something stupid of missing something so to remove all possible issues with my install I started from nothing again and have something that can be reproduced.

  1. Completely clean install of docker version of Openhab-2.2 (Latest version)
  2. Install openHAB Cloud Connector
  3. Create new account with this uuib/secret on myopenhab
  4. Add one single item Switch testswitch2 "Light" <light> [ "Lighting" ] in items/test.items
  5. Link Alexa to this Openhab and try to discover lights (https://alexa.amazon.co.uk)

I get the error

There was an error discovering your devices.

And this is the error returned from the discover call from the web version of Alexa. (XXX is an id that I’ve hidden as I’m not sure if it’s sesitive or not)

{"message":"Customer XXX does not have any devices that supports home automation"}

I don’t think I have any way of diagnosing this as it is all happening out of my control somewhere else.

What is it that I’m doing wrong or missing?

Thanks

Garth


(Alex) #40

@garthy

Can you see your testswitch2 under the following link:

https://myopenhab.org/rest/items/ (login to myopenhab.org first!)

Is this the only one? Or are there even more tagged items visable?

Search for tags":[" on above site… Are there tagged items WITHOUT labels?


(Garth Bushell) #41

Sorry for delay as I deleted everything and had to wait till I’m home to recreated my steps.
The complete output of https://myopenhab.org/rest/items/ is:-

[{"link":"https://myopenhab.org/rest/items/testswitch2","state":"OFF","type":"Switch","name":"testswitch2","label":"Light","category":"light","tags":["Lighting"],"groupNames":[]}]


(Alex) #42

Looks ok.
@garthy

Can you control your Openhab items via myopenhab.org?

Is your Openhab server in the same LAN like your Echo device. Same subnetmask, same gateway?


(Alex) #43

You have to check ALL items, not only testswitch2.

What output delivers?https://myopenhab.org/rest/items/


(Garth Bushell) #44

If you read steps to reproduce post #39 you will see I installed a new clean instance with just one testswitch2 item in my items directory, The cloud connector setup with a brand new account on myopenhab and nothing else.
The complete output of https://myopenhab.org/rest/items/ is as in my post above as I only have one item in my test instance as I wanted to remove all other Variables.

[{"link":"https://myopenhab.org/rest/items/testswitch2","state":"OFF","type":"Switch","name":"testswitch2","label":"Light","category":"light","tags":["Lighting"],"groupNames":[]}]

For Alexa I don’t own a Echo and I am using https://alexa.amazon.co.uk, the Alexa app on my phone and Alexa on my Fire. All error out at discovery. Also Google Home errors out but this is newer so I thought I’d go with the older more tested solution.

(As a side not but possibly related I’ve just tried to reset my password and am getting the reset link has expired. If I look at some of the response headers coming from myopen hab I see Thu, 22 Feb 2018 20:13:32 GMT This could be causing a problem with discovery/registration?)


(Alex) #45

I don’t know if it’s possible to use this without an echo device! Perhaps someone else knows this?

But you also should try to control your items via myopenhab.org.

Click on “Click here to access your OpenHAB’s dashboard”…

Then you should see your configured dashboard, e.g:

You also should check, if your Alexa Application is authorized to access myopenhab.org:


(Garth Bushell) #46

Yeah I Think maybe you do need an Echo to get this to work and I suspect that is what the error message I see back from Amazon means… Customer XXX does not have any devices that supports home automation. I just assumed that having the Amazon Alexa App on my Fire would be enough as I assued all it does it talk to Openhab via myopenhab and some sorta Lambda and no hardware is needed. Maybe we can confirm and document.

On the plus side after fixing up my labels as described above My Google Home setup now works when it didn’t before.

I’ll see if I can borrow an Echo and check it works with hardware.

Thanks for your help.


(bernd_boehm) #47

Did you find out if this is true?
I am using the amazon alex app on android and the Hue emulation… Also here Alexa does not find any devices.
I have tried a lot (redirecting ports) etc. but did not get it working.

[EDIT] To answer my own question: No you don’t need an Echo. I have just installed the CC and it works with the items I have configured.
What I found out for me: I really need to do the tagging in the items file precisely. i.e.

[ "Switchable" ]

with capitalization and withspaces etc. If I got one thing wrong - No devices were discovered.