Alexa Smart Home Skill - No devices found - Solution

Tags: #<Tag:0x00007faecc6a8c40> #<Tag:0x00007faecc6a8ad8> #<Tag:0x00007faecc6a8998>

Hello folks,

I had the problem (like many others!) “finding any devices” with Alexa, while using “myopenhab cloud service” and “Official Alexa Smart Home Skill”. After several investigations I found the cause!

EDIT: There were missing labels! --> In my case, there was NO problem with my .items file! (But you better should check it also!)

The missing labels came from here:

If you have set in \conf\services\runtime.cfg the following:

org.eclipse.smarthome.links:autoLinks=true

or via PaperUI:

AND you are using e.g. the following bindings:

lifx, tradfri, hue, max, mihome, tplinksmarthome, feican, dmx

then you automatically will get created the following tags [ “Lighting” ] (from hue, lifx, tradfri) and [ “heating” ] (from max) and [ “Lighting” ], [ “ColorTemperature” ], [ “weather” ] (from mihome) but (I don’t know why) without any label !!

EDIT: But it seems, that later on (after July 2017!) the labels were added!!
EDIT: This problem only happens, when you have installed the above mentioned bindings a long time ago, with “Simple Item Linking” = ENABLED!

See here (hue): channels.xml

and see here (max): thing-types.xml

see also here (mihome): channels.xml

see also here (lifx): channels.xml

see also here (tradfri): thing-types.xml

see also here: (tplinksmarthome): thing-types.xml

see also here (feican): thing-types.xml

see also here (dmx): channels.xml

Maybe there are many other bindings with predefined tags?

3 Likes

Here are all my steps to get it running:


Prerequisite: openHAB Cloud Connector (openhabcloud), configuration see here: openHAB Cloud Connector

You do NOT have to expose ANY item!



ALSO NOT MANDATORY: hueemulation, homekit



Before you start “tagging” your .items file please check the following:

You need a “clean” https://myopenhab.org/rest/items/

EDIT: If you already have tagged your .items file, you can also use this method to detect, if it’s correct!)

Login to https://myopenhab.org

Then go to: https://myopenhab.org/rest/items/

search this site if there are any tags!! Search for the following: tags":["

and check right beside your highlighted hit if you find: Lighting, heating, Switchable, Thermostat, TargetTemperature, CurrentTemperature, and so on…

Also check the same line, if there is a label!

In my case I found the following automatically created from “Simple Item Linking” (and many others!!):

{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_8_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_8_brightness","tags":["Lighting"],"groupNames":[]}
{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_1_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_1_brightness","tags":["Lighting"],"groupNames":[]}
{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_2_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_2_brightness","tags":["Lighting"],"groupNames":[]},

As you can see, there were no labels !! (please check your .items file again, if you never have used “Simple Item Mode”!)

To get rid all these “wrong” tagged items do the following: (in my case!!)

Go to PaperUI: Configuration --> System

or set \conf\services\runtime.cfg

 org.eclipse.smarthome.links:autoLinks=false

Then in PaperUI go to: Configuration --> Things

Delete ALL your hue things, delete ALL your max things. And maybe others you found above…

Do this procedure as long as you cannot find any tags in https://myopenhab.org/rest/items/

If there is NO tag left, then go to (PaperUI): Configuration --> Inbox --> + (Search for your hue and max, and so on, again…) If you have a corresponding .item file, the channels will be linked automatically to your items.

Now check https://myopenhab.org/rest/items/ again! Are there any tags??
If none, then you are now ready to tag your .items file.

But be carefull with the syntax! You should start only with ONE tag, e.g. [ “Switchable” ].

Example;

Switch KitchenSocket "Kitchen Socket" <light> (gKitchen) [ "Switchable" ]  {channel: your channel definiton}

Save your .items file and check if it also appears here: https://myopenhab.org/rest/items/

If so, then go to Alexa APP and start discovering your devices!

Now you should see: “Kitchen Socket” (from example above).

Done it!!

The correct semantic or syntax for further tags can be found here: HomeKit Add-on

BUT, attention!!

If you want to use tag [ “Thermostat” ] then it is MANDATORY to use ALL 4 tags like in this example:

Group gDownstairsThermostat "Downstairs Thermostat" (gFF) [ "Thermostat","Fahrenheit" ]
Number DownstairsThermostatCurrentTemp "Downstairs Thermostat Current Temperature" (gDownstairsThermostat) [ "CurrentTemperature" ]
Number DownstairsThermostatTargetTemperature "Downstairs Thermostat Target Temperature" (gDownstairsThermostat) [ "TargetTemperature" ]
String DownstairsThermostatHeatingCoolingMode "Downstairs Thermostat Heating/Cooling Mode" (gDownstairsThermostat) [ "homekit:HeatingCoolingMode" ]


Tags NOT running with Alexa are: [ “CurrentHumidity” ] and standalone [ “TargetTemperature” ] !!

Have fun…

11 Likes

didnt fix me unfortunately - i did have simple item linking but no hue or max items in rest

@Andrew_Pawelski

Do you have any other tags in https://myopenhab.org/rest/items/ ?

Search for tags without labels! Like this example:

{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_8_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_8_brightness","tags":["Lighting"],"groupNames":[]}
{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_1_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_1_brightness","tags":["Lighting"],"groupNames":[]}
{"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_2_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_2_brightness","tags":["Lighting"],"groupNames":[]},

A correct item looks like this: recognize the “label” field !!

 {"link":"https://myopenhab.org/rest/items/Hue_Light1_Toggle","state":"OFF","type":"Switch","name":"Hue_Light1_Toggle","label":"Licht Kicker An/Aus","category":"light","tags":["Lighting"],"groupNames":["GF_Living","Lights"]}
1 Like

Do you use: lifx, tradfri, mihome??

You can also use ONLINE JSON Code Viewer to analyze your https://myopenhab.org/rest/items/

Go there and click: Copy/Paste, Browse, Tree Viewer or Validate

Yes I use LIFX - I was specifically looking for hue items will check but eyeballing it before it looked ok

So I have lots of things without lables such as my z-wave controller and my harmony remote currentactivity item - should ALL items have lables? My group items dont either

@Andrew_Pawelski
Yes, the label will be the “device name” you will see then in Alexa App!

@Andrew_Pawelski
Only items with a tag need a label. Groups like “Thermostat” (see above) with 3 childtags need a label, too. All others without a tag need no label.

OK good news! I had to go through each item and I had a couple of items I was using in rules without tags that once I aded them, as well as removing the items added by simple item linking by removing the things and readding them, the items immediately appeared idiscovered by alexa!

Thanks so much I will reply back to the other topic to confirm this is needed!

1 Like

Here is what I did and now it is working flawlessly…
I have removed ALL Hue items except for the bridge itself.
Then I have switched OFF Simple Mode.
After that, reboot and wait for Hue items popping up in the Inbox.
When you accept an item, the channels are no further automatically linked. Instead, click on the channel you want to activate --> Item --> create new item. Leave everything as it is and click "Link"
You have to do this for EVERY hue item and every channel you want to add.

@Celaeno1 is on the right track. When you add a hue item in simple mode, the item gets tagged but NOT labeled. In order for Alexa to work, I believe an item needs to be tagged AND labeled correctly.
I hope this helps somebody.

I also had this issue with Alexa.
I did what @Andrew_Pawelski suggested, and now I can find ALL my items in Alexa.
Thanks for your effort @Andrew_Pawelski great job!

But can you tell me one thing: What about my Sonos? How does the item look?
I have this, but not working:

	Player Play5_Controller "Play 5" (Dining, Music) ["Switchable"] {channel="sonos:PLAY5:RINCON_5CAAFDF1B16001400:control"}
	Dimmer Play5_Volume "Play 5 Volume [%.1f %%]" (Dining, Music) ["Soundvolume"] {channel="sonos:PLAY5:RINCON_5CAAFDF1B16001400:volume"}

I can get it thru to MyOpenhab, but not from there o Alexa.

Furthermore, all my items are not shown in my items list, on MyOpenhab

Your first item is not a switch it is a player
Try defining an item for control:

Player Play5_Controller “Control [%s]” (Dining, Music) {channel=“sonos:PLAY5:RINCON_5CAAFDF1B16001400:control”}
Switch PlayOrPausePlay5 “Play 5” [ “Switchable” ]

then a rule to control the action

// Play or pause kitchen speakers, with Alexa
rule "play or pause play 5 speakers"
when
Item PlayOrPausePlay5 received update
then
if (PlayOrPausePlay5.state==ON) {
sendCommand(Play5_Controller , PLAY)
} else {
sendCommand(Play5_Controller , PAUSE)
}
end

Then the Alexa command would be “Alexa Turn On Play Five”


Your second item has a tag [“Soundvolume”] You need to use [“Lighting”]

I do not get following to work.
I want to say to alexa “turn test on”.
then a rule should set two hue lights to 10 %.

my items and rules look like following.
I read a lot of posts here in this forum but still do not get it to work. what am i doing wrong?

Items:
Switch Stimmung_Esstisch “Test” [“Switchable”]
Dimmer Lampe_Esstisch1 “Lampe1” {channel=“hue:here inside is my hue hub adress:1:brightness”}
Dimmer Lampe_Esstisch2 “Lampe2” {channel=“hue:here inside is my hue hub adress:2:brightness”}

Rules:
rule "Stimmung_Esstisch ON"
when
item Stimmung_Esstisch changed from OFF to ON
then
Lampe_Esstisch1.sendCommand(10) //go to 10% dimlevel
Lampe_Esstisch2.sendCommand(10)
end

rule "Stimmung_Esstisch OFF"
when
item Stimmung_Esstisch changed from ON to OFF
then
Lampe_Esstisch1.sendCommand(100) //back to 100% dimlevel
Lampe_Esstisch2.sendCommand(100)
end

Thank you

Your openhab.log or the Smarthome Designer should have told you the error: Item instead of item (capital “i”)

I’m trying this

Switch forhaven_lys “Garden light” {ihc=“0xc115e”} [ “Lighting” ]

But no tags show up, what am i doing wrong?

You are using a wrong order, tags have to be defined before binding/channel definition.

ok heh

thanks, what temperature tags can be used with alexa ?

If you want to use tag [ “Thermostat” ] then it is MANDATORY to use ALL 4 tags like in this example:

  Group gDownstairsThermostat "Downstairs Thermostat" (gFF) [ "Thermostat","Fahrenheit" ]   
 Number DownstairsThermostatCurrentTemp "Downstairs Thermostat Current Temperature" (gDownstairsThermostat) [ "CurrentTemperature" ]
 Number DownstairsThermostatTargetTemperature "Downstairs Thermostat Target Temperature" (gDownstairsThermostat) [ "TargetTemperature" ] 
   String DownstairsThermostatHeatingCoolingMode "Downstairs Thermostat Heating/Cooling Mode" (gDownstairsThermostat) [ "homekit:HeatingCoolingMode" ]

But you also can use tag : [ “CurrentTemperature” ] standalone…