Alexa Smart Home Skill V3 is now live!

Hello,
I am trying to control my TV set using Alexa (in french) and OpenHab. I have created the following items:

Group TV “TV” {alexa=“Endpoint.TV”}
Switch Power “Power” (TV) {alexa=“PowerController.powerState”}
String Channel “Channel” (TV) {alexa=“ChannelController.channel”}

The power command does work when I speak to Alexa but when I try to ask for a specific channel Alexa indicates that this command does not work on my TV device.

Is that a French language limitation or did I missed something?

The ChannelController interface is unfortunately not available in France yet.

https://www.openhab.org/docs/ecosystem/alexa/#regional-availability

That what I thought thanks.

Any idea when ChannelController will be available in French? Could I be of any help?

Is there a workaround to pass a string from alexa to openhab so that I could use it in a routine?

This is a limitation with the Alexa API. There isn’t much that can be done at the skill level.

The ModeController interface would be the other interface that would pass a string from Alexa but it also not available in French.

If using routines, a virtual percentage device could be used and each percentage value would map to a string on the OH side via a rule.

Thanks for your suggestion.
I ended up using a simple workaround where I list all channels as switches and use a trigger when a specific switch get an ON command. The voice command is a little weird “Alexa allume (switch on) France 2” but it works ok

That works too. If going that route, you should make sure to model these items as activities (alexa="SceneController" [category="ACTIVITY_TRIGGER"]).

Anyway, I just read in the latest Alexa API upcoming changes that the mode, range and toggle capabilities will be extended to other languages shortly. So once available, you should be to implement what you initially wanted to do.

Hi.
I’m just starting with OpenHAB and trying to setup an OH and Alexa link. Due to “geographic restrictions” (I`m from Brazil) I can’t download the alexa skill from amazon. Any tips about how can i fix that? If I get the github code and deploy (as dev only), will it work normally?

We actually need to add Portuguese translation to support that language. Until it is added to the skill, you will not be able to use the official skill unfortunately.

Have you tried to deploy your private skill? The localization in that setup may not be a factor. Also, I am curious to see which region the Lambda function should be deployed since Amazon hasn’t updated their documentation for your skill language as of yet. My guess would be with the North America endpoint (us-east-1). It would be great if you could confirm? :+1:

Maybe I can help, just replied there.

Thats right. I deployed as a private skill in us-east-1 and it’s working :slight_smile:

1 Like

Awesome :+1: I will update the documentation.

Hi All

Just a question on Alexa groups, am I right in saying that creating the Light and the Echo into a group is an Alexa app side configuration and that nothing is needed in OH2 to make this work? I only have a need to say ‘Alexa, turn on the lights’ in a room which has an Echo and a number of lights (but I’ll only put the downlights into the group) for example

Thanks

I just added a Security System, as defined in the documentation, and it shows up in Alexa as a security system, but it does not seem to be recognized by Alexa Guard. Has anyone else gotten it to work? Is there something I am missing, or is there a limitation where Amazon only allows this to work with Ring and ADT?

You are correct. Just create a group in Alexa app, add the lights that should be controlled and link the relevant echo device to that group.

You are correct. Alexa Guard is considered as a separate security system device. However, you should be able to use the latest beta version of the Amazon Echo Control binding to synchronize the arm state between the two via OH rules.

2 Likes

I am not using myopenhab.org, but rather my own public (via nginx) openHAB server. I did not run into any issues with the install and my devices all showed up!!! The bad news is they are all offline. Any ideas on how I can debug?

Actually they were old devices, I removed them all and then ran discover and nothing shows up. :frowning:

Expired cert… now works!

1 Like

Hey guys,

i just switched to the new v3 tagging of items:

Switch Sonoff_MAXS20002 "Max Stehlampe" <light> (Lights_MaxZimmer, Lights) {channel="mqtt:topic:Sonoff_MAXS20002:switch", alexa="Switchable" [category="LIGHT"]}

I deleted all items in the alexa app and started a new discover search. The first try was yesterday and i now tried it again. Unfortunately alexa isnt finding any new items.
What am i doing wrong?

Kind Regards,
Max

The syntax looks fine if this is the only Alexa-enabled item. Have you gone over the troubleshooting guide? It could be a server issue.

With the recent ability added to the Alexa API, to set a given mode, range and toggle controller interface as a non-controllable property, support for the CurrentHumidity label has been added and is now available in the live skill. This is currently only available in the US since it is based of the range controller interface but should be available globally in the near future based on Amazon’s latest announcement.

Now it works (overnight) dont knwo why.
But what is the german command to switch a homematic thermostat to off?

String Homematic_CLAHRT002_Mode "Claudius Heizung Links Betriebsart [MAP(HM-CC-RT-DN.map):%s]" <clipboard_flow> (Heating_ClaudiusZimmer_L, Heating_OpModes) {channel="homematic:HG-HM-CC-RT-DN:e99d2e90:OEQ1708935:4#CONTROL_MODE", alexa="ThermostatController.thermostatMode" [OFF="OFF", AUTO="AUTO", NORMAL="NORMAL"]}