Alexa Smart Home Skill V3 is now live!

It sounds like you didn’t trigger a manual discovery update after you changed your configuration.

Not sure exactly what the German utterance is but this is how you would request it in English:

Alexa, set <thermostatDeviceName> to off

And if you only have one thermostat device defined in your Alexa account, you can just use the term “thermostat”:

Alexa, set the thermostat to off

Hey,
i have Devices for my Rollershutter:

Rollershutter AlexaArbeitszimmerRolladen “Arbeitszimmerfenster” (gAlexaRolladen) {alexa=“PercentageController.percentage” [category=“SWITCH”]}

Rollershutter Arbeitszimmer_Rolladen_Fenster “Arbeitszimmerfenster” (gArbeitszimmer, gOnline) [“Lighting”] {mqtt=">[mqttBroker:shellies/shellyswitch25-76C719/roller/0/command:command:*:MAP(shelly.map)], <[mqttBroker:shellies/shellyswitch25-76C719/roller/0/pos:state:MAP(shelly.map)]"}

rule "RolladenArbeitszimmerAlexa"
 when 
   Item AlexaArbeitszimmerRolladen received command
 then
   logInfo("RolladenArbeitszimmerAlexa", "Status" + AlexaArbeitszimmerRolladen.getState())
end

Is it possible to link the “Original”-Item directly to the Alexa-Item? What i want:
i will see the current % of my Shutter. i will get the % from alexa. i will control the shutter by voice to x%

I hope someone can help me :slight_smile:

Yes as long as your original item can directly process the commands issued by the Alexa skill. Based on the description you provided, it seems to be the case.

Looking at the configuration you provided, your original item is already Alexa-enabled through the “Lighting” tag which the skill converts as metadata configuration {alexa="PercentageController.percentage" [category="LIGHT"]}.

So my recommendations here would be to remove your AlexaArbeitszimmerRolladen item, as it would be conflicting with your original item due to same label name, and update your original item to use the “Switchable” tag in place of “Lighting”, if you rather stick with tags configuration in case you are using other smart assistant integrations.

Rollershutter Arbeitszimmer_Rolladen_Fenster "Arbeitszimmerfenster" (gArbeitszimmer, gOnline) ["Switchable"] {mqtt=">[mqttBroker:shellies/shellyswitch25-76C719/roller/0/command:command:*:MAP(shelly.map)], <[mqttBroker:shellies/shellyswitch25-76C719/roller/0/pos:state:MAP(shelly.map)]"}

Or convert the tag to metadata configuration as below:

Rollershutter Arbeitszimmer_Rolladen_Fenster "Arbeitszimmerfenster" (gArbeitszimmer, gOnline {alexa="PercentageController.percentage" [category="SWITCH"], mqtt=">[mqttBroker:shellies/shellyswitch25-76C719/roller/0/command:command:*:MAP(shelly.map)], <[mqttBroker:shellies/shellyswitch25-76C719/roller/0/pos:state:MAP(shelly.map)]"}
1 Like

Spanish supported? Wohoo. Thank you very much and excellent work! Can’t wait to get my echo dot

Would the V3 Skill using the MediaPlayer tag allow you to get basic stop/pause/play voice commands through to the kodi binding?
If this would work can anyone start me off with an example item?
my current kodi player item:

Player  Kodi_Control "Kodi Control"	{channel="kodi:kodi:56633dfc-xxx-xxx-xxx-42392bba46xx:control"}
1 Like

The metadata label MediaPlayer would allow you to send requests to your Player item linked to the kodi binding. Keep in mind that the “Stop” command is not supported by a Player item on the OH side and therefore not available with the skill. You can find all the supported actions in the documentation.

You should update your item as below. For example, you can request Alexa, play on kodi or Alexa, rewind on kodi. Additional utterance examples can be found here.

Player  Kodi_Control "Kodi"	{alexa="MediaPlayer", channel="kodi:kodi:56633dfc-xxx-xxx-xxx-42392bba46xx:control"}

@jeshab youve made my day - one change and I am set up! all controls work - even Stop! Its not as feature rich as the kodi-alexa dev skill I set up but all I really used from that was the player contrals anyway - and this without any code to manage - awesome!!!

Are you sure you are controlling your device with the Alexa OH skill and not the Kodi one? I am asking because you should be getting an unsupported message when issuing “Stop” commands. You may need to disable your Kodi skill and delete any associated devices as I have seen conflicts between smart home devices linked to different skills with the same capabilities.

So I can’t make it work so far.

I got my openhab cloud connected to alexa skill succesfuly. Now I created a dimmer item just like in the guide with the alexa endpoint. Then I go to PaperUI and link the item to the thing channel. Now I say the words and Alexa says "I don’t recognize device ".

Should I create thing, channels and items through configuration and not paperUI to make it work maybe?

Forgot to discover the item through Alexa, that was black magic for me now lol

:+1: That was actually the first question I would have asked :smile:

For reference purpose, there is a troubleshooting section in the documentation that we try to keep up to date with all the known issues and how to resolve them.

1 Like

My Kodi-alexa dev skill stopped working ages ago and yes I was surprised as well but it also used a different utterance
“Alexa - tell kodi to stop”
this doesnt work any more
“Alexa - stop Kodi” does

it is supported on the Alexa side, but stop isnt documented on the OH side - but it works…

I’m, trying to setup a group with category “LIGHT”, but Alexa always sees it as OTHER and does not understand that it should be able to dim the thing. I’ve already gone through all the information I could find and the setup should work as far as I understand.

This my setup:

Group gWohnzimmerStehlampe "Stehlampe" <light> {
    alexa="Endpoint.WohnzimmerStehlampe" [category="LIGHT"]
}

Switch Wohnzimmer_Stehlampe_Switch "Stehlampe" <light> (gWohnzimmer,gWohnzimmerStehlampe) {
    channel="mqtt:topic:exs-dimmer-01:switch",
    alexa="PowerController.powerState"
}

Dimmer Wohnzimmer_Stehlampe_Dimmer "Stehlampe" <brightness> (gWohnzimmer,gWohnzimmerStehlampe) {
    channel="mqtt:topic:exs-dimmer-01:dimmer",
    alexa="BrightnessController.brightness"
}

Is there anything wrong with that?

Your group endpoint is incorrectly setup and therefore ignored. This means your other two items which should be setup under that endpoint have been discovered as single devices using the same label name.

First, you should delete these two devices, if not all your OH related devices, from your Alexa account using console or mobile app. Secondly, the display category for group endpoints should be defined in the metadata value and not parameters. Last, trigger the discovery process once you updated your configuration.

Group gWohnzimmerStehlampe "Stehlampe" <light> {
    alexa="Endpoint.Light"
}

Switch Wohnzimmer_Stehlampe_Switch "Stehlampe" <light> (gWohnzimmer,gWohnzimmerStehlampe) {
    channel="mqtt:topic:exs-dimmer-01:switch",
    alexa="PowerController.powerState"
}

Dimmer Wohnzimmer_Stehlampe_Dimmer "Stehlampe" <brightness> (gWohnzimmer,gWohnzimmerStehlampe) {
    channel="mqtt:topic:exs-dimmer-01:dimmer",
    alexa="BrightnessController.brightness"
}

hi jeremy im trying to get my daikin fan speed working in AU with V3 but I get no new devices found with this:

My device has AUTO and 3 fan settings, any thoughts as to why? I assume syntax. Even setting just

String DaikinACUnit_Fan                     "Fan Speed"        (Group_HabPanel_Dashboard) { channel="daikin:airbase_ac_unit:ducted_ac:airbasefanspeed", alexa="ModeController.mode" }

Doesnt find it. And mode is definitely australian supported.


String DaikinACUnit_Fan                     "Fan Speed"        (Group_HabPanel_Dashboard) { channel="daikin:airbase_ac_unit:ducted_ac:airbasefanspeed", alexa="ModeController.mode" [supportedModes="AUTO=@Setting.Auto,LEVEL_1=Level One:@Value.Low,LEVEL_2=Level Two:@Value.Medium,LEVEL_3=Level Three:@Value.High",friendlyNames="@Setting.FanSpeed,@DeviceName.Fan",ordered=true] }

If you use your last item definition, the device should at least be discovered. However, even if the Alexa Skill API now expanded the language support for the mode, range and toggle controllers, it is not yet available in the live skill.

So, if im using the V3 privately, I would need to update the code?

Correct. Once the changes related to this enhancement are merged into the repository. We will update this thread when it’s available for all the users.

1 Like

Along with the openHAB 2.5 official release, we are excited to announce that the following enhancements are now available in the official Alexa skill:

Additionally, it would be much appreciated if you could leave your review on the Amazon website. The current comments don’t reflect all the hard work we put in the recent months. And I believe having a higher overall rating for the skill would steer more new users to our community.

Happy holidays!

@jeshab

6 Likes

Is it possible to only have items using the new metadata format discovered by Alexa?

I don’t want all my items tagged “lighting” to be included in the devices found by Alexa, only devices that I specify with metadata.

Not that it was intended to be used that way but you could just specify an invalid Alexa metadata value. The skill ignores the tag values if the Alexa metadata is defined.

Switch Light "Light" ["Lighting"] {alexa="disable"}