Amazon Alexa mqtt shutters integration help

Tags: #<Tag:0x00007f61737c8130> #<Tag:0x00007f616d7eff10> #<Tag:0x00007f616d7efb00>

Hello, Today i installed openhab 2.55 with the new mqtt binding and i’m not able to inegrate my rollershutters.
I have simple rollershutters motors UP -STOP- DOWN and this config settings:
Items:

Rollershutter 	    Shutter1 	           "Office Shutter"	(Shutters) 	              	{alexa="ModeController.mode" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedModes="Up=@Value.Open,Down=@Value.Close", actionMappings="Close=Down,Open=Up,Lower=Down,Raise=Up", stateMappings="Closed=Down,Open=Up"]}

sitemaps:

Switch item=Shutter1 mappings=[UP="UP", STOP="X", DOWN="DOWN"]

In openhab works perfect but Alexa is not able to discover the “Office Shutter” device.
I want to say: Alexa! Office Shutter up / down or Office shutter open / close …
How can i do that ?
Thanks

So the first thing is that you can only use percentage number currently, as per the examples in the documentation, when modeling a Rollershutter item as ModeController. If you want to use the direction command, you would need to use a proxy String item part of a group endpoint to achieve as per the example in the post below:

1 Like

Hello, Thank you for your help
I managed to integrate the blinds with Amazon Alexa following your instructions but now I would like to create an item that will command all the blinds at the same time.

Now I can say:

Alexa! Open the Office Blind!
Alexa! Close the Office Blind!

Alexa! Office Blind command UP!
Alexa! Office Blind command STOP!
Alexa! Office Blind command DOWN!

items:

Group OfficeTest                "Office test blind"                                {alexa="Endpoint.Other"}
String OfficeBlindCommand       "Office Blind command"     (OfficeTest)            {alexa="ModeController.mode" [supportedModes="STOP=STOP,UP=UP, DOWN=DOWN"], autoupdate="false"}
Rollershutter OfficeBlind       "Office Blind"             (OfficeTest)            {alexa="RangeController.rangeValue" [category="INTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="100:0", actionMappings="Close=100,Open=0", stateMappings="Closed=100,Open=0"]}

Group KitchenTest               "Kitchen test blind"                               {alexa="Endpoint.Other"}
String KitchenBlindCommand      "Kitchen Blind command"    (KitchenTest)           {alexa="ModeController.mode" [supportedModes="STOP=STOP,UP=UP, DOWN=DOWN"], autoupdate="false"}
Rollershutter KitchenBlind      "Kitchen Blind"            (KitchenTest)           {alexa="RangeController.rangeValue" [category="INTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="100:0", actionMappings="Close=100,Open=0", stateMappings="Closed=100,Open=0"]}

sitemaps:

Switch item=KitchenBlind mappings=[UP="UP", STOP="X", DOWN="DOWN"]
Switch item=OfficeBlind mappings=[UP="UP", STOP="X", DOWN="DOWN"]

rules:

rule "Office Blind Command"
when 
    Item OfficeBlindCommand received command STOP or
    Item OfficeBlindCommand received command UP or
    Item OfficeBlindCommand received command DOWN
then
    OfficeBlind.sendCommand(receivedCommand.toString)
end

rule "Kitchen Blind Command"
when 
    Item KitchenBlindCommand received command STOP or
    Item KitchenBlindCommand received command UP or
    Item KitchenBlindCommand received command DOWN
then
    KitchenBlind.sendCommand(receivedCommand.toString)
end

I created an item and i set a rule using rule engine so:

Group AllTest                   "All test Blinds"                                  {alexa="Endpoint.Other"}
String AllBlindsCommand         "All Blinds command"     (AllTest)                 {alexa="ModeController.mode" [supportedModes="STOP=STOP,UP=UP, DOWN=DOWN"], autoupdate="false"}
Rollershutter AllBlinds         "All Blinds"             (AllTest)                 {alexa="RangeController.rangeValue" [category="INTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="100:0", actionMappings="Close=100,Open=0", stateMappings="Closed=100,Open=0"]}

Now i can just say:

Alexa! All Blinds command UP!
Alexa! All Blinds command STOP!
Alexa! All Blinds command DOWN!

It is not working with:

Alexa! Open All Blinds! 
Alexa! Close All Blinds!

This post should answer your question:

1 Like

Thank you :slight_smile:

So I updated the item definition on my original post that I initially linked above. The way the device category was defined is incorrect. Basically, it should be at the group endpoint level. You should update your configuration the same way.