Amazon Echo Control binding cannot log into Amazon account anymore

Every since the last time Amazon made me change my password, the echo control binding will no longer allow me to log in. I am trying with the correct username and password but it does not work. I just keeps saying invalid email. Others on the forum are now having the same problem.

Here’s what I did:

Stop OH.

Go To --> /homes/openhab/userdata/jsondb

Rename this file --> amazonechocontrol%3Aaccount%3Aaccount1.json to amazonechocontrol%3Aaccount%3Aaccount1.json.BAD

Start OH wait for it to fully startup

Go to your Echo binding login page and try again.

Best, Jay

1 Like

Unfortunately that did not fix the problem. No change.

I had this some weeks ago. I had to delete my amazon-thing and then create a new one with a different name. I use config files so I deleted the thing first from the things-file and saved it. After the thing was gone (keep an eye on the logs), i created a new one with a different name. After that i could log in again.

I completely deleted the thing files and deleted the binding, rebooted, put in the latest version of the binding (2.5.7), replaced the thing file, rebooted again. Same problem, no change. Still get the failed login. @michi?

Have you tried just logging into Amazon.com as if you were going to purchase something to confirm that your user/pass is working on it?

Best, Jay

Yes I have logged out and logged in on the web and all my devices. Everything works fine except the binding.

Just noticed the binding version in Paper UI is 2.5.8. Installed that instead and now it’s working fine. Thx.

Hello huys,

I have a similar problem with the binding. When i try to login to http://XXX.XXX.X.XXX:8080/amazonechocontrol/e8d2df76/ after typing in my username and password, it lets me go to a new page in witch i have to first allow trough my phone(SMS) the login. The problem is, it gives me only 4s and the page goes back to the login.4s is not enough for me to recive the SMS on my phone and click on the link from it to allow the login.

Some have any idea how i can battle that ?

3 Likes

I have been having the same problem today when trying to connect to my account

What do you mean with enable 2FA ? I have the same issue and I cannot login.

Two factor authentication in your amazon account

https://www.amazon.com/gp/help/customer/display.html?nodeId=202073820

OK. Thank you. I got it and managed to log-in. Now all Alexa Things are available :slight_smile:

I realized that 2FA doesn’t really work either. So the error can obviously have several causes. Furthermore, the alexa.amazon.com password may be different from the Amazon account itself. I’ll try renaming the .json files and if that doesn’t work, I’ll create a new Thing. If there are still problems, the binding will be reinstalled.

Just wanted to note the two things, that 2FA would not always be a workaround and that passwords could differ.

so in my case @jwiseman answer worked.

I’m running into same issue right now. I’m on rpi4 with openhabian. Openhab version is 3.2
3 days ago I checked echo control binding first time and I was able to login via amazonechocontrol successfully. Unfortunately I had other issues due to binding conflict between normal repo version and 3rd party version (Smarthome/J). So I decided to uninstall everything again and start from a clean point.

Unfortunately I’m now hanging with the login after Amazon account thing creation. It keeps saying that it can’t log in and “try again”.
I checked all the hints from this thread, tried enabling/disabling 2FA, installed the binding (v3. 2.9) via 3rd party addon mechanism as well as by putting the jar directly into addons folder. Nothing helped so far. Does anyone have an idea or is there maybe just currently general issue with the login?
I also see no hint in openhab logs.

In the past, when Michael was developing the binding, when there was login issues - he told me to delete this file in the \openhabian\openHAB-userdata\jsondb area and it will be recreated when you log back in.

To be safe, I would just rename it to .OLD and give it a try. I would do a clean start of OH also when you do this.

amazonechocontrol%3Aaccount%3Aaccount1.json

Best, Jay

Thank you! I already checked that before and it didn’t help.
I did removed again account thing and echo binding, cleaned cache/tmp folders of openhab. Afterwards I saw the binding installer offered even more recent version 3.2.10 of echo control Smarthome/J binding. I installed it and it works now. So finally success! But I cannot say if it was the cache cleaning or the new 3.2.10 binding version that solved it.