Amazon Echo Control - lastVoiceCommand not receiving updates

Hi there,

i´m currently having an issue with the Amazon Echo Control binding and the Channel of lastVoiceCommand.
The Channelt stopped working today and doesn´t receive any updates.
There´s also an error message in the log that suggests that Amazon has removed the lastSpokenText option.
2023-08-30 15:23:08.405 [WARN ] [core.thing.internal.ThingManagerImpl] - Failed to normalize configuration for thing 'amazonechocontrol:echo:home:arbeit': {thing/channel=Type description amazonechocontrol:lastSpokenText for amazonechocontrol:echo:home:arbeit:lastSpokenText not found, although we checked the presence before.}

Who´s currently working on the binding and can have a look at this?

kind regards

Edit: I`m using the following platform.

Raspbian GNU/Linux 11 (bullseye)
Linux 6.1.21-v8+
Raspberry Pi 4 Model B Rev 1.1
openHAB 4.0.1 - Release Build
4.0.1 org.openhab.binding.amazonechocontrol
1 Like

These messages have nothing to do with the removal of channels on Amazons side. The openHAB version of the binding never supported lastSpokenText, so the channel is probably there because you used a 3rd party version of the binding. Since the openHAB version has no knowledge of this channel, it can’t provide a proper channel definition.

It could be that i used a third party version of the binding in the past but i´m currently using the openHAB version.
I think it was a version from the community that had more features until they went into the regular binding.

So what could be the cause that i don´t get any updates on the lastVoiceCommand channels/items?
It worked fine until yesterday evening where i started the night time routine but stopped working in the morning when i wanted to use the morning routine.
I tried every Echo device i got and none of them updated the lastVoiceCommand.

lastSpokenText (from the messages above) is a different channel than lastVoiceCommand. lastVoiceCommand contains the last command received by Alexa, lastSpokenText contains the last text that was output by Alexa.

lastVoiceCommand indeed does no longer work because of a change of the behavior of Amazon’s servers (there is no notification about that any longer). Have look at the discussion here.

Strange that it was working until yesterday while others started having problems a month ago.

I believe it works until you re-connect/re-login or the connections is terminated by the server.

1 Like

mine stopped working now too. probably somewhere during this week.
maybe they shut down that function by region, germany here.

Same here. Since August 31st lastVoiceCommand hasn’t received any updates.

Yeah the workaround version worked for one day and then also stopped working.
I switched to an dummy item that is exposed to Amazon through myopenhab.
The only problem is, i can‘t identify which Echo was used to start the rule.

That‘s really a big bummer from Amazon.