Amazon Echo Control - Logon Fails

I am having some issues with the Amazon Echo Control Binding.
This may have been triggered by me changing my Amazon account password - or it may have been caused by clearing the OH3 cache - or perhaps something totally unrelated.

When I try to logon (http://openhab:8080/amazonechocontrol/) I get prompted for username and password - then OTP code. After a few seconds it returns with …

" Login to ‘’ failed: Request failed
[Try again]"

I have tried disabling OTP - this makes no difference.
The OH Log is full of HTML that includes references to

Any help or suggestions would be great - thanks

I don’t use Amazon Echo Control, but this recent post seems to indicate that 2FA needs to be turned on, not off.

Thanks for getting back to me. That post was why I turned 2FA on in the first place. It made no difference (ie 2FA off or on - I still get the same message).

Found the issue. It seems that some time ago when having issues, I installed a version of this binding in the add-ons folder. When OH updated to the latest version, it seems to have turned on the standard version - conflicting with the add-on folder version (perhaps only after I cleared the cache??).
Removing the file from add-ons solved the problem.