Android device not registered in own cloud instance


after updating to the latest version my cloud instance is running and I could login.

But there is one problem at the moment:
My android device doesn’t receive messages and I can’t see any devices in the devices section. But I can see the messages in the website.

Another user posted this in the forum with IOS devices. Could this be the same error or should I see my device?


1 Like

Having the same issue right now. At first I thought it was because I had not verified my e-mail, because I had not set up mailing, did that yesterday, and still no device registered.

Without having any devices registered you are not able to receive messages. Did you connect remotely to your cloud? For example, turn wifi off and connect via mobile data connection. Then your phone gets registered and you should be able to receive messages …

Yes I connected remotely to the cloud.
When opening a window-contact, I see the changes directly on my phone while WLAN is off and I’m connected to the cloud.
But still no device appears in the device section…

Make sure you have notifications and remote access enabled:


notifications and remote access is enabled.
I got notifications while it was configured to use myopenhab, but while using my self hosted instance I got no notifications on the phone. But I can see the notifications on the website of the cloud instance.

Anyone using successfull notifications with a self hosted cloud instance?

I think it the problem is this:

I think so too.

From what I see hete it would seem you are correct. Under features, “It serves as a connector to Google Cloud Messaging (GCM) and Apple Push Notifications (APN) for pushing notifications to mobile phone apps.”

Looks like we need gcm installed for push messages.

Ooops, looks like GCM is there, see this thread, Own openhab cloud and GCM (Google Cloud Messages) and ifttt, which reference this ->Notifications on Habdroid not working #67

Ok, I got HABDroid working by recompiling with my GCM Key, (I will post location) and changing the url as discussed in one of my links above, finally have a device registered in the cloud.

Now, what information do I need to supply for the cloud to send messages other than the info in config.json, which I believe is configured as:

 "gcm" : {
      "jid": "project",
"password": "web API Key"

Anything else I need to change on the “cloud side”?

Line 145 of “” needs to be changed to the “GCM Sender ID”

Thanks for the hints!

I got it!
After changing the mentioned lines ( line 145 and 1201 I think) in the source code of Habdroid, deploying the newly compiled app to my phone and changing the gcm-key in json.conf of the openHAB-Cloud instance, my phone gets registered in the cloud instance and I can receive messages.

Thanks for the help

1 Like

Great, I just got mine working minutes ago!

So for those looking to set up OpenHAB-Cloud notifications, here is a quick summary of what needs to be done.

Jid =
Password = server key
I don’t know if the legacy server key will work, I used the server key from Firebase console, also make sure you use the keys on the “Cloud Messaging” tab!

Before compiling habdroid"
Change line 145 and 1201 to match your system.

Are you getting Droid alerts, or only in the HabDroid App??? I don’t get any droid sounds or alerts, only the alert in HabDroid. Yes, I have all my alerts enable in notifications, on my phone.

Fixed with a Habdroid rebuild from the very start.

Does anyone know how to do this for iOS APNS?

As of today, it looks like it would need you to have a working, paid Apple Developer subscription: