Anybody interested in BARRIER_OPERATOR Zwave Command Class?

@dbadia - tried it, still no luck.
After pairing I still can’t see BARRIER_OPERATOR in the list of supported classes. Not sure if secure pairing is successful or not. securePairingComplete is still showing as false in node xml, so I guess something is still wrong.
See link below for zwave log and node xml. I also attached log from homeseer previous pairing which clearly shows that BARRIER_OPERATOR is supported by the device once it’s successfully paired.

@dbadia Dave, have you had a chance to look at this?

Yeah I looked at the log. The secure pair process stops about halfway through. It’s most likely a merge problem when I merged the security-beta-test changes into the security-mmerge branch. The security portions of those 2 branches should be the same but they obviously aren’t.

Next step is to merge the barrier change commit eb5a203303 into security-beta-test and try that out. Chances are that will solve the problem.

It’s a really busy time of year for me. Give it a shot if you don’t feel like waiting for me to find the time, it should be very easy to do…


Hey guys

I bought one of these GoControl Linear GD00Z Garage Door Openers. As always, I turn out buying stuff that doesn’t work with OpenHAB yet… I should learn to check before I click that button!

Usually, it’s just a matter of database add, so I can file a request and add the XML, and a couple of days later I’m able to download a working ZWave binding jar.

But apparently this one is a bit more complex. Is there any chance that there is a file somewhere that I can download to get this opener to work, or should go buy some other device?


I tried this approach: . It didn’t work though - I couldn’t get it to complete the inclusion. So I will either just wait, or go buy some other device (this time doing some research first).

But - som funny side effects:

I have an Aeon Labs DSB45-ZWUS water sensor, and I have a Fibaro FGMS-001 type 801 multisensor.

When using the ordinary 1.9.0 snapshot jar from August 11:

When using the security testing jar:

  • Fibaro FGMS-001 caused loads of errors in the log, complaining about not existing in the device database. But - it continued to work fine. It sent sensor reports when it was supposed to, and temperature / luminence / battery reports came in normally. The device name was still visible in Habmin, but I could no longer configure parameters or association groups.
  • Aeon Labs DSB45 got included in seconds, and worked perfectly fine. I took the opportunity to tweak the configuration parameters and association groups to my liking.

When going back to the ordinary 1.9.0 snapshot jar:

  • Fibaro FGMS-001 got back to the fully working state.
  • Aeon Labs DSB45 complained in the log about securedCommandClasses and wakeupCommandClass not being supported. In Habmin, the entry was all UNKNOWN again (as described in ). But - it continued to work fine. Both the sensor and the battery reports came in normally.

Don’t know if this might be already known and normal for you, but if it’s not I can always craft some logs for you.


PS. As rather expected, the Gocoontrol GD00Z complained about securityCommandClassWithInit at startup.

I am also interested as to the state/stability of supporting this device within OH1 or OH2. Thanks.

It has been included in OH2 for a long time - feedback is welcome of course…

Hey, maybe that is my solution! Running OH1 for my regular stuff, and OH2 for that lock and possibly some other stuff. I guess they could talk MQTT to each other the same way that my two instances of OH1 does now.

Has anyone gotten this to work with the Linear GD00Z Garage Opener ? I have the device paired with OpenHab2 using security, but I only see the BARRIER_POSITION channel.

I don’t see the BARRIER_OPERATOR channel. Does anyone have any idea on how to add code for the BARRIER_OPERATOR channel under OpenHAB2 ?

This probably means that the device is not securely included. If the device did not complete secure inclusion, then it won’t even tell you that it supports these classes.

If I remember correctly, people are using this with OH2 if you use the development binding, but I’m not 100% sure without checking.

@chris The device is securely included. I am using the OH2 Development Binding. See pic below:

Please refer to my post: (OpenHab2 and Linear NGD00Z-4 Garage Door Controller)

on details of how I uninstalled the SNAPSHOT binding, installed the development binding, included the device securely, but still don’t see the BARRIER_OPERATOR channel. I only see the BARRIER_POSITION channel.

Are you sure that the BARRIER_OPERATOR command classes are included in the latest OH2 snapshot ?

Any help on this is appreciated.

Well, I’ve not checked recently, but I don’t think it will have been removed - so pretty sure. We implemented it a long time ago now (even for OH1).

@chris could you please take a look at this thread and help me diagnose why I dont see the BARRIER_OPERATOR channel even though the device is included securely.

@ashgupta - this works as intended. What you are likely missing is what I missed originally. I was thinking there would be an open/close “switch” that I could use. It seems there isn’t. What you need is to first ensure the device is securely included, validate by using HABmin to see if Using Security is a green checkmark in attributes. Once that is confirmed, then you need to create a virtual item to use as a switch, or use a Site Map to create a “switch” on the sitemap that will operate the door. The sitemap will use a mapping of 0 and 255 for the two states.

Reference this post in the OH2 Security testing thread: OH2 Z-Wave refactoring and testing... and SECURITY

If you would like to “validate” this before creating the map or virtual item - use the API (REST Documentation under MISC in Addons in PaperUI). You can test sending a 0 and 255 to the controller to validate.

@shawnmix yes it works by sending 0 to close the door and 255 to open the door. It is confusing to new OpenHab users since we are used to a switch to open/close on/off an item.

I am currently working with chris to define channels for the various alarms the device reports.

Hi AshGupta,

I just bought GoControl Garage Door opener and I am trying to configure it. I have installed z-wave binding and through PaperUI I was able to discover the GoControl opener which showed up as Z-Wave Node 3 but had only 1 channel: “Barrier Position”. I added “Barrier Position” in my sitemap but I am not seeing its value changing on tilting of the sensor. Even if it had changed, how would I send command to the opener to open/close? I am not sure how to proceed from here. I would appreciate any feedback you can provide.
I just wanted to add that in the previous post it says “What you need is to first ensure the device is securely included, validate by using HABmin to see if Using Security is a green checkmark in attributes.” I am seeing a “?” for “Using Security” attribute in HABmin. How do I change that to green checkmark?


  1. Make sure you are using the secure binding from
    The default z-Wave binding in OH2 doesn’t have security

  2. Then exclude and include the device in your network and in Habmin make sure that the device is showing up as Secure. Paper-UI doesnt display the security status of the device.

  3. Once you have the device securely included you will see that the Barrier_Position number is 0 when closed and 255 when opened. If you have got this then your garage door opener is working with OpenHab2.

  4. You send number “0” to Close the Door and number “255” to open the door. Below is my item and sitemap definition for this.

Number Garage_Gate_Position     "Garage Gate [MAP(]"   <lineargarage>
0="0 - CLOSED"
252="252 - CLOSING"
253="253 - STOPPED"
254="254 - OPENING"
255="255 - OPEN"
Switch item=Garage_Gate_Position mappings=[0="CLOSE", 255="OPEN"]

Just to clarify, shall I uninstall the current z-wave binding that I installed through PaperUI? I have never manually installed a biding before so not sure about how to add the jar file that you sent the link for. Shall I copy it in /srv/openhab2-sys/addons as-is, and then try to find items again?

Yes uninstall the current binding.

Go to the link and download the latest secure binding. Put it into openhab2/addon folder

Read the first 20 posts in that link. Somewhere you will find directions on how to install the serial binding and then how to restart the z-Wave binding.

Also install Habmin

Then follow my directions above.

Here is what I did:
Removed all the Items / Things related to z-wave and uninstalled z-wave binding from PaperUI.
Copied the jar file to /usr/share/openhab2/addons
Rebooted my Raspberry Pi
Using HABmin, added Z Wave Serial Controller, configured the port, which discovered the Garage Door Controller. Added the garage door controller and then the “Barrier Position Channel”. I still don’t see the green checkmark for “Using Security”. Did I miss any step? Here is the screenshot from HABmin:

And here is my log:

2017-04-17 18:41:58.881 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - ZWave port is not set.
2017-04-17 18:42:31.090 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2017-04-17 18:42:31.685 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
2017-04-17 18:42:31.717 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2017-04-17 18:42:31.732 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2017-04-17 18:42:31.737 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2017-04-17 18:42:35.128 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2017-04-17 18:42:35.130 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 2: Node found
2017-04-17 18:42:35.134 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2017-04-17 18:42:35.136 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2017-04-17 18:42:35.138 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2017-04-17 18:42:35.141 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2017-04-17 18:42:35.143 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2017-04-17 18:42:35.802 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:15b7e4b4fb7:node2' to inbox.